Can't Log In

Bug Report
I'm trying to log into the Blizzard client but I simply can't.

I type in my e-mail and password, click login, and get the authenticator screen where I accept the code on my phone. Instead of entering the game selection screen, I get sent back to the login screen.

I know there's nothing wrong with my login data and authenticator since I do the same thing in the website and I can log in just perfectly.
I bypassed the problem by putting in my authenticator code manually.

This should still be checked though. Can't log simply tapping accept anymore.
Confirming both above posts as I just went through the same process.

OS: Mac High Sierra
Having the same problem. Clicking Approve isn't letting me in. Typing in the long manual code does work.
Went through tech support, same issue tried the following:

1. full shutdown and restart of pc.
2. uninstalling and reinstalling blizzard app
3. running app as admin
4. removing auth aloud the login
5. after adding auth again would not login
6. manually typing code works

TLDR; manual type auth code to login
Same. Windows 10, authenticating on Android. And yes, the manual authcode works.
Same problem, code works always and one-button once in a blue moon. Another thread about it in the mobile section with some more people.

https://us.battle.net/forums/en/bnet/topic/20764496683
07/07/2018 12:19 AMPosted by Bungalo
Same problem, code works always and one-button once in a blue moon. Another thread about it in the mobile section with some more people.

Not sure they collect information on the authenticator on that forum though, it's meant for the mobile Battle.net app rather than all their mobile stuff.
That said I doubt they're not aware of it, although from seeing certain comments it might be a connection issue, seen some people that got it to work by turning off wifi and using their mobile connection instead.
07/07/2018 12:19 AMPosted by Bungalo
Same problem, code works always and one-button once in a blue moon. Another thread about it in the mobile section with some more people.

https://us.battle.net/forums/en/bnet/topic/20764496683


Confirm this endless login loop pertains to One Button Approval only - manual entry still works.

Frustrating but with solid workaround.

Wish they would disable one-touch until bug resolved.

Kindly,
Carjack

Join the Conversation

Return to Forum