WC3 - Building farm glitch [PTR]

General Discussion
Hi Classic,

Found a bug when building a farm, it didn't build the farm but still took my resources. It was my second farm of the game (first one built normally), but was a shift build command. I moved my peasant away so the highlight image would go away and I would get my resources back, but it didn't. I moved every peasant I had and still the highlighted farm wouldn't go away nor refund of resources.

I have the replay saved if you would like to see the bug.

Thanks!
That's good to know, if what you are saying is true...
Also uploaded a video just to explain it.

https://youtu.be/_yj6JURb9dY
07/07/2018 07:45 AMPosted by ZsoltSzalait
That's good to know, if what you are saying is true...
Who are you to say that it isnt true? Why would he post all of this then?
07/07/2018 07:45 AMPosted by ZsoltSzalait
That's good to know, if what you are saying is true...


Made a ~1min video of it! Check it out bc I don't know what I'm missing.
Never seen this bug before and I have been playing Warcraft III for a very long time...

This bug was likely introduced with one of the more recent patches. It would appear that the foundation leaked away from its placement order and hence could not be cancelled.

Would be interesting to know if killing the peasant refunded the foundation resources. Or if issuing the stop order explicitly cancelled the foundation.
I wish I killed the unit but I just quit and saved the replay so I can report this issue.
I think it has to do with queueing commands with holding Shift tend to fail alot on the PTR. Its the same for queueing workers to go harvest lumber when they are constructing buildings right now.
Same thing happened to me. I was playing Night Elf.
I had a wisp who was building a moonwell; I wanted it to build another after it was done, but I wanted to cancel for something else however, the moonwell shade was not gone along with the resources.
07/08/2018 03:22 PMPosted by SeriaKirmin
Same thing happened to me. I was playing Night Elf.
I had a wisp who was building a moonwell; I wanted it to build another after it was done, but I wanted to cancel for something else however, the moonwell shade was not gone along with the resources.
OOooohh... Bummer...

Dear Blizz, Blizz... You guys better get these fixed up, or else, lol...
Is this fixed yet, or what?
Is this fixed yet, or what? (My post didn't came up as an update, so I posted again.)

Join the Conversation

Return to Forum