[Warcraft 3 1.30] Cannot change resolution

Bug Report
10/28/2018 10:23 AMPosted by andreas
right click your wc3 desktop shortcut
--> properties
--> shortcut tap
--> in target: this should be the text "C:\Program Files (x86)\Warcraft III\Warcraft III.exe".
--> Add a space and -nativefullscrr behind the text in target.


thx mate !
What if your properties doesn't have a shortcut tab. I'm on windows 10.
NsideSoldier! Press rmb on warcraft3.exe in war3 folder than choose 'make a shortcut to desktop'
Can confirm that this still works

right click your wc3 desktop shortcut
--> properties
--> shortcut tap
--> in target: this should be the text "C:\Program Files (x86)\Warcraft III\Warcraft III.exe".
--> Add a space and -nativefullscrr behind the text in target.
tyvm folks =)
10/28/2018 10:23 AMPosted by andreas
right click your wc3 desktop shortcut
--> properties
--> shortcut tap
--> in target: this should be the text "C:\Program Files (x86)\Warcraft III\Warcraft III.exe".
--> Add a space and -nativefullscrr behind the text in target.


Corrected my issue; thanks
03/06/2019 11:38 AMPosted by Idil
Can confirm that this still works

right click your wc3 desktop shortcut
--> properties
--> shortcut tap
--> in target: this should be the text "C:\Program Files (x86)\Warcraft III\Warcraft III.exe".
--> Add a space and -nativefullscrr behind the text in target.
tyvm folks =)


This isnt working for me, it just says that the name in target box is not valid. Halp?
10/13/2018 05:05 PMPosted by TheRuiner846
Add -nativefullscrr to your game shortcut, then you should be able to select different resolutions.

This fixes the selection of resolutions but there's still blackbars on every resolution i pick.
04/23/2019 08:42 AMPosted by Sneo
10/13/2018 05:05 PMPosted by TheRuiner846
Add -nativefullscrr to your game shortcut, then you should be able to select different resolutions.

This fixes the selection of resolutions but there's still blackbars on every resolution i pick.


The black bars only appear in the menu in order to maintain the original 3:4 aspect ratio. Otherwise the display would be stretched. Once you play a game, however, the extended GUI will show up, while still offering a widescreen camera (that isn't stretched either).
Unless you're saying that black bars appear even in normal gameplay, but otherwise just test your resolution option beyond the main menu screen.
Thanks it worked for me too !
dont forget the space between ur target location and -nativefullscrr tho,

so if i am correct the real problem is that the game starts in fullscreen windowed mode without borders and the solution is to force the game into fullscreen mode ?....
10/13/2018 05:05 PMPosted by TheRuiner846
Add -nativefullscrr to your game shortcut, then you should be able to select different resolutions.


Praise Jeebus, I don't feel like I'm leaning with my face right up against the screen anymore. Thank you! :D
05/01/2019 06:22 AMPosted by RealLifeChi
10/13/2018 05:05 PMPosted by TheRuiner846
Add -nativefullscrr to your game shortcut, then you should be able to select different resolutions.


Praise Jeebus, I don't feel like I'm leaning with my face right up against the screen anymore. Thank you! :D

It does NOT work!

Join the Conversation

Return to Forum