[War3] 1.30

General Discussion
Prev 1 4 5 6 13 Next
Thanks Pete and team.

I am looking forward to playing with the new updates.
The game seems to terminate silently during loading some custom maps, like, for example, DotA. There is no report or other sign of crashing, just a silent process termination.

I think that the new "anti-cheat" measures are probably messing with custom maps:
  • Updated anti-cheat to keep the Horde at bay
Wow Amazing work in august! Thanks
what happened to the smooth transition with alt-tab?

screen starts flickering and mouse freezes for two seconds although the game is basically windowed fullscreen

blizzard what are you doing
Every new patch they are creating, there's more and more people who can't play the game anymore.
It truly feels they are cutting out slowly but surely all of the players still playing Warcraft 3. They are trying to push them to play World of Warcraft or some other rubbish game where you have to pay monthly subscriptions.

After having installed the game for the first time, why do people have to go in the "Warcraft 3" folder and look for the "Warcraft 3 Launcher" icon to update the game.
Why make it so difficult? The update should be as easy and accessible as possible to all people. We shouldn't be looking in some folders to update the game.

This has to be the worst patch I've ever seen.
Nothing works.
They broke everything.

-Locked gamma
-Locked resolution
- "-nativefullscr" does not even work anymore
-Instant crash on custom games
-Completely destroyed cursor control and mouse positioning on 5:4 resolutions
-Unstable framerate
-Still is not properly optimized for newer computers (this game was made in 2003) and we still can't get constant 60 frames per second.
This game should be running like butter on new machines with a minimum of 60 frames per second at all times
Why did blizzard dont update the game engine like starcraft remastered?
Hey Blizz,

Thanks for the patch and good luck wading through the outrage to find sensible constructive criticism. Good luck!

Haven't tested much, but I did notice right away that my autohotkey scripts (.ahk) are no longer compatible with 1.30. (Basically inventory rebinds to tyghbn and space and control are swapped). Be nice to get that fixed.

Thanks,
Hiromatsu
Rollback this awful patch thanks
i have tested the patch, tier 2 fort is indeed still too weak, i think just make fortified towers tier 1
Hey everyone,

I've found a fix for -nativefullscr to work again (on windows 10 for me at least)
Go to Windows 10 settings (start > settings cog)
From there, click SYSTEM, on the left side, click "Focus Assist"
Turn EVERYTHING off, whatever is ON in that section.
Recreate your Warcraft 3 shortcut and add -nativefullscr.

Let me know if this works for others :)
The patch has reverted the delay in online games back to 150+ ms instead of 50 ms as it was in 1.29. Please take a look at it.
Add wc3 icon to the Blizzard launcher. This is so uncomfortable without it
hi there , why is some random people running bots on ur game and banning people based on their rules? have you sold battle.net to them do they own it?

can you please remove these ip leachers from your platform as they seem to have gained complete control over it
btw im getting a looot of random crashes now bliz u sure u know what u doin? :D
after i patched, everytime i try open the game he crash and this code appear

90782BC4-0BA5-490A-8D8F-309931F64039

only works if i open as admnistrator

how fix that?
Lol my custom keys ''Z" is broken having downloaded the patch 1.30 .

what u doin? ...
I just gotta say that it seems like this patch completely screwed up how the cursor works in game. I managed to fix it in 1.29 to work correctly, but in 1.30 with the removal of -graphicsapi opengl2 it lags a lot and when i use the add -nativefullscr + "minimize/maximize wc3" trick mentioned earlier, it "kind of fixes it" but it still does not move properly and the mouse movement is FAR from as accurate as it should be.

Considering I played competitive wc3, if this mouse issues does not get fixed, I and probably many others who have the issues will completely drop wc3.

I am on w10, GeForce GTX 1060, have made the regedit fix, i have added -nativefullscr to start option, i have vsync disabled (because it fixed it for me in 1.29)

I'm not even gonna get into some of the, to put it lightly, stupid balance changes made for this patch. I'd prefer to have the damn game working as it should.

Tips would be appreciated
08/08/2018 01:00 PMPosted by Pixel
Patch 1.30 also broke a good amount of foregin maps though. A lot of the non-english maps (Korean, chinese, russian...) simply show an error message like "map data not found" when you select the map in custom games. They used to work perfectly fine in 1.29 and I tried to investigate some further. MPQ protection is a big thing in Korea and China and they constantly try to improve their protections. The maps where I had issues all seemed to have some sort of protection (some newer ones, some older ones.) as deprotecting them actually made them work again.
That is their problem and why most sensible developers have been telling people to not protect their maps like that for many years now.

All it would take is that Blizzard added proper validation to the MPQ version field and all such maps would break. Worse, if they start trying to parse newer MPQ versions it may even out right crash due to the maliciously designed data.
PLZ update customkeybindings, i looked into the file, it didnt change a bit.

Join the Conversation

Return to Forum