Freezing W3TFT

Mac Technical Support
Hi,

I just reinstalled my W3TFT on my mac (10.14, up to date), and I keep having freezing issues with my game.

I am playing and all of a sudden I get my game freezing, with no error message or stuff like this. Just freeze (I can still select my characters but cannot move them or save the game).

It is quite annoying.

Please help me on this.

Best?
Hi, has there been an update to this? It still happens on 1.30.4 unfortunately.

Basically the game freezes up during offline custom campaigns and it's like you desync in online games, where you can still pan around with the camera, hear the correct sounds and are able to click on units, but it's defacto stuck. Can't save or close the game either, which means you have to force close it every time it happens.

I've tried with different custom campaigns from the hiveworkshop, aber around 15-30mins it happens.

Cheers
Hey you two,

That behavior indicates a connection error, not a freeze. You're actually disconnected from the game servers but the client doesn't know it just yet.

I recommend power cycling your router and resetting your PC. If that doesn't work and your computer supports it, try an ethernet cable if you're on wifi. Last up, close any background apps which might fight us for control of your connection (especially security/firewalls/VPNs)

Hopefully that helps out, but if not it would help to have you run a pathping test to your warcraft server.
Hi Drakuloth,

thanks for your reply! Unfortunately the problem I encounter, isn't online, but it's in offline maps.
It does feel exactly the same as classic the online desync you were describing though. It happens on custom campaign maps, but it doesn't seem to be campaign specific, since it happens to all of them.

Cheers
Interesting! I misread "offline" previously. Sorry for missing your reply, but that does give me a few more ideas. Are you running any third party security or something like that? If so, does uninstalling it temporarily fix it? Is the game on an internal harddrive or is it installed to a harddrive connected via USB? Does moving it to an internal drive change anything, in that case?
Hi,
I'm experiencing exactly the same problem.
Problem occurring on macOs Mojave and High Sierra.

Problem occurring when playing LAN games and only when hosting it, never freezes when someone else creates it. Same issue happens when just playing agains AI (which I suppose is running the server, therefore same as first scenario).
Started happening after updated the game to 130.4.

scramouch and iacidna described the problem very accurately.

Thanks for your help.
02/24/2019 05:27 PMPosted by capodoster
Hi,
I'm experiencing exactly the same problem.
Problem occurring on macOs Mojave and High Sierra.

Problem occurring when playing LAN games and only when hosting it, never freezes when someone else creates it. Same issue happens when just playing agains AI (which I suppose is running the server, therefore same as first scenario).
Started happening after updated the game to 130.4.

scramouch and iacidna described the problem very accurately.

Thanks for your help.


Please don't tell me to uninstall and re-install, already tried several times :)

Join the Conversation

Return to Forum