Diablo II crashes when I try to connect to battle.net

Technical Support
Everytime I click on Battle.net, the game instantly crashes a message of,

"This Application encoutered an unexpected error."

And then there's an ID to report to Blizzard that is always random.

Please help?
I'm getting the same.

ID Report
17A6846A-106E-48DB-8BD3-4A93C3D079C8

Edit:
I'm running it on a windows 10 VM running on Hyper-V.
Firewalls on the VM and host have been disabled. The game is running in compatibility mode and windowed.
Hey guys!

I just wanted to share this, because it might be the easy and silliest fix. This/a reminiscent error suddenly appeared for me when running my usual shortcut for D2. Game repeatedly crashed upon connecting to battle.net.

After having reset the regedit gateways, fiddled with compatability mode, tried unticking "run as admin" - what was the cause actually was this: the "-ns" (no sound) tag-line in the shortcut...
-w, -skiptobnet, they all work: just the -ns for nosound caused it. Everything else the same, having just removed the -NS, and it works again.

This was how my error looked, for your reference. Perhaps you also have -NS toggled? try turning that off.

https://i.imgur.com/eTzvZmH.png

I don't know how that's even possible, and haven't updated myself if Blizzard enrolled some updates to the clients lately. But thats a strange bug, to my mind atleast.

Hope it's this easy for you guys aswell/that you have solved it otherwise!

edit: HM, odd, I was wrong: the client also does not seem to approve of the old "-skiptobnet" command: gives the same error, with or without "-ns" tag. Just having -w atm, and then it works...
hi all

i was having the same problem on windows 10. i had -skiptobnet added. once i shut it off i was able to launch to offline and play no problem but when i tried to go back to online bnet it would crash and throw an error.

something i did that may have helped was

1: go into the d2 folder under program files x86.
2: in the d2 folder there is the d2 application and under it it says Game.
3: highlight Game by clicking on it.
4: then right click it and go to properties.
5: click compatibility and only have the "run this program as an administrator" checked.

you can also do that for the d2 application.

after i did this i was able to launch the game to bnet.

i'll check back if this happens to me again.

hope it helps!

Join the Conversation

Return to Forum