Starcraft BW update 1.22.3 won't install

Mac Technical Support
My Brood War version is currently on 1.22.2.5147 and Battle.net tells me my SC is up to date. However when I start the game I get the notification that I need 1.22.3.5293 to be able to play online.
I have tried Options -> Check for update in Battle.net and I have reinstalled the game completely, both to no avail.

I'm currently on Mac OS X 10.13.2

Could you guys help me out please?
Marked As Solution
BouBro,

10.13.2 is out of date with respect to the 10.13 (High Sierra) releases. Can you please combo update to the latest build of High Sierra, or switch to Mojave? If that fails, I'd actually reinstall the battle.net application - it may be having problems locating our patch service.
Thanks for the help!
I did both things and it worked out

Join the Conversation

Return to Forum