Can't install wc3 on Macbook running 10.11.6 El Capitan

Mac Technical Support
Title says it all.

Running a 2015 MacBook Air on 10.11.6. Everything I've read indicates that this OS should support wc3. When I try to install the wc3 launcher it simply returns the message:

"You can't use this version of Warcraft III Launcher with this version of OS X. The application requires OS X 10.12 or later."

Is that really the case? Please help!
That is going to be the case. The minimum requirements for the newest build of WC3 can be found here.

Join the Conversation

Return to Forum