D2 LOD on Mac OSX 10.14.1 always wants to patch even though already up to date

Mac Technical Support
Hi,

2 days ago i was playing fine on my mac running OSX 10.14.1 and now when i open the game and connect to battlenet it tries to update the game. When the patch download is complete the screen goes grey and BNUpdate error window pops up to say:

"This patch does not need to be applied to the game. The version of the game you have installed is more up to date than this patch.

File name: \(MacPath01)\Diablo II.app
File version: 1.14.3.71
Patch version: 1.14.3.71"

This happens every time i start the game. I've tried a fresh install and rebooting and also different servers but no luck. Can someone help to troubleshoot this please?
Same here
i have the same problem
Same here too
Thank you all for your reports. This is currently an issue we're looking into. We have a primary thread on the Support section here. Our team is currently working on this and we'll continue to update with more information on our primary thread.
i cant open the link cause it goes always on this page
Blizzard BNUpdate v2.136 compiled on Mar 30 2016
Log created at 4:12 pm on 02/15/2019

This patch upgrades Diablo II Lord of Destruction from version 1.07 or later to version 1.14d.

NOTE: patch not required for file '\{MacPath01}\Diablo II.app' [version 1.14.3.71]

RESULT: Patch failed

Here is what is captured in the log.
02/15/2019 12:46 PMPosted by Caterpepi
Thank you all for your reports. This is currently an issue we're looking into. We have a primary thread on the Support section [url="https://us.battle.net/forums/en/bnet/topic/20771197204"]here[/url]. Our team is currently working on this and we'll continue to update with more information on our primary thread.


I cant follow this link either, please can you provide a working link?
Okay suddenly its working again. I didn't change anything on my side so it must be backend Bnet?

Thanks for acting on this.
Ive had that problem for three days now.
Sorry about the folks! This is the link, edited the previous post, too! The issue should be resolved now for the patch failed loops and crashes due to the failed loops.

If the issue continues, please try a uninstall and reinstall. If the reinstall does not resolve the issue, please start a new thread to help us diagnose and track each issue individually!
Hi,

After playing for a while, i find i am timing out every 20 minutes or so and also when trying to kill hell diablo as i encounter him the game crashes EVERY time...

Please help!
That is an unrelated issue. You'll want to start your own thread or contact support for help.

We've confirmed the error originally causing this was resolved. I'm locking this thread to prevent future confusion. Thanks again to everybody for reaching out about this!

Join the Conversation

Return to Forum