Browser freeze

Bug Report
After try to access options of feedback, manage account, support or game guide by the b.net application when try to used the mozilla firefox freeze and won't unfreeze until i kill the browser process.
When the browser is open and then i clicked to that options open normal but if browser is not open and running it freeze.

The version of the firefox is 22.
I've got a similar problem, also using Mozilla Firefox!

When I click on an external link within the battle.net app my Mozilla opens but freezes. It is unavailable for some time (some seconds up to 5 minutes) before it properly loads the site. When the site is loaded and I try to do something there (i.e. scrolling down or opening another link within) the delay happens again ... and again, and again. It's almost impossible to browse the forums or news this way.

But when I open my Mozilla outside the battle.net app everything works perfectly fine and smooth. So my current "workaround" is to open the wanted link within the battle.net App, wait until it is loaded the first time, copy the address-link, kill the firefox-process, reopen the browser outside the battle.net app and then paste the link there again. This is the only way to use the links within the battle.net app right now for me - and that's quite tedious!

What could cause such a problem? It's not in the "known issues" thread so I really hope someone blue would answer if this one is known and maybe worked on?!

But everything else is quite perfect. Loving the battle.net app so far! Thanks to Blizzard for this!

Have a nice day and happy gaming!
Hello nehegeb,

This is a known issue with some browsers and how they interact with links passed from the Desktop App (usually this happens with Chrome rather than others but can happen in some rare cases to others). Occasionally with no open browser window the links from the Desktop App will cause issues such as the one you've seen. You can, as you've discovered, have an open browser window available before following any links to workaround the issue. Thanks!
Thanks for the quick reply, Exeliran!

So just having my browser open and ready before using links within the battle.net app is all I need to do? I think I can manage that. ;)
And yes, this way it works quite perfect. Thanks again!

But maybe you can update your "Known Issues" thread in due course? The last update (1.0.6) was in April and hence over half a year ago.
http://us.battle.net/en/forum/topic/9245384955
Hello again nehegeb,

The known issues list for 1.0.6 was updated on December 4, 2013 (here in the States we do them as month/day/year - so 12/4/13 instead of day/month/year like most others). Glad to know the workaround still helps people get past this issue, thanks for the response!
Oh, I forgot about the US date format (it's the other way around here in Germany). You are right, sorry about that... But it's good to know that such posts are up to date and you get very quick support from people like you if you need them!

Happy holidays to you and keep up the good work! :)

(I think you can mark this thread as solved so far, if possible.)
A necro that has to be done. It is now 4 years (!) since this post and the issue is STILL there. Seriously? Billion dollar company and you let a bug/error/glitch like this stay present for FOUR years?

Join the Conversation

Return to Forum