"Play" button grayed out despite download bar pass "playable"

Bug Report
I tried the cache, repair and many suggestions, nothing worked. What I did was 'uninstalled' and download over, it fixed it. I had to start from beginning but could access game again within 10 minutes.
^ Same issue here
This just happened when I tried to update WoW. I did play it yesterday without any problems, but now i can`t even hit Play, so I guess there still is a problem.
I also did everything, from deleting all the cache, up to unistalling and reinstalling the game. Nothing changed.
I have this same issue too. I uninstalled WoW last night and reinstalled because the play button was grayed out. After it downloaded for a while it was playable again. Then today going back to the game the play button is grayed out. Kind of frustrating because I could play for a few hours yesterday on this same download, and now I am locked out again. I don't have a lot of free time and just re-subbed my account, but now I can't play in the time I have.
I talked to EU tech support about this same issue but then with Heroes of the Storm. Deleting cache, reinstalling battle.net app, the whole works.. done it. It didn't change a single thing. I even freshly installed my entire laptop, did not work. Even put in a WIRED connection and it didn't download past the playable point. To which tech support replied: "You are a unique case then"

Yeah.. thanks blizzard. Forums are full of this issue, even in the EU it's full of it.
A program that you need to give special permissions in your firewall and anti-virus just to play? (Windows standard anti-virus I might add) No thank you. I have unsubscribed to WoW. All my games lost and unable to download again and they seem to refuse to aknowledge a possible issue on their end with their LATEST battle.net version. Before this version (1.12.1.10252) everything worked fine over a Wi-Fi connection and now it doesn't and this MY fault, Blizzard?

Thanks but no thanks, see you when you've fixed this issue

Join the Conversation

Return to Forum