If You are stuck on Updating Battle.net Agent

Technical Support
Solution, done this a couple of times now and I believe has been said previously but not in a topic-

Ctrl+Alt+Delete

Task Manager

Disable or quit out of the program running called - Agent.exe

This will restart the ping and you should be good to go!
I'm still stuck at about 90%, even after trying this :\
Let's be sure to try these steps too.
I've disabled my antivirus and made sure that everything is up to date, no success.
Problem solved, I just uninstalled the client and re-installed it, works perfectly now.
I was about to create a thread on this topic. So far I've simply been directed to this page:

https://us.battle.net/support/en/article/BLZBNTBTS00002

I've made sure the system was up-to-date, checked firewall availability, disabled anti-virus, and even checked for the suggested "Agent.exe" and nothing has come up. The next thing I am going to do is simply uninstall and reinstall as Foxtrap suggested. Hopefully this fixes it for me as well.
Update:

After trying to uninstall I was directed here:

https://us.battle.net/support/en/article/battlenet-requires-update-to-uninstall
I had the exact same problem! I deleted the battle.net folder, compatability, basic windows theme etc... THIS worked for me:

Proxy settings on your system can also block access. Make sure to disable proxy settings from the control panel:

Pull up your Control Panel and select Internet Options.
Click on the Connections tab.

Click the button called «LAN Settings»

Uncheck all of the options on that screen.

Then try again.

Hope it works for you!
OMG. This fixed it. You are a genius. As soon as I unchecked the options under LAN Settings the updater jumped from 33% to complete and the installer started. You my good sir/madame are a life saver.
Didn't do it for me, still at 33%
I have 5 times agent.exe running and when I try to close one it sais: Access denied.
Its simply DISGUSTING to see that AFTER months and months of reports and issues this unbelievable application still have this freezing problem, is incredible how incompetent Blizzard can be regarding this application.... unbelievable.....

FIX IT
^
2015... and the problem continues... complete desregard... want to show WoW to my wife and maybe comeback and play with her, but cant...

I can't believe this still happens...
Did the solution in the OP work for you? If not try creating a new thread and try to be as descriptive as possible so someone can try to help you out.
thanks man, helped me out a bunch!!!
Fix for Windows 7 users (and other OS too maybe):
1. Open cmd with admin rights: Start -> write "cmd" in search bar -> rightclick cmd - > Run as admin.
2. In command prompt write: "netsh in tcp set global autotuninglevel=normal".
3. Now you can close cmd window and start Bnet client.
gg.

Everything without the quotation marks.
This worked for me thank you
Oh yeah, this is it. It started moving as soon is I unchencked and pressed OK button in connection settings. Thank you very much!

Join the Conversation

Return to Forum