PS3 Multiplayer infinite loading problem

Console Bug Report
Prev 1 2 3 7 Next
Hi Guys,

Most of the issues that have been described in this thread are all very likely a result of some sort of connection issue, likely involving NAT/Firewall settings on your console or network (likely in your router). The troubleshooting that I can provide for this here in the Bug Report forum is limited, but here is a link to our support article on Diablo III Console Connection Troubleshooting, where you will find links to the appropriate Playstation 3 support articles:

Playstation 3 players will need to double check your router or modem's settings to ensure that the appropriate ports are being forwarded, and that any other network settings that would restrict your console's connectivity are disabled.

You can find the information on which ports to forward in the following Playstation support article:

For more information on how to configure your modem or router to allow traffic over specific ports, please see the support information provided by the manufacturer of your specific network device.
The infinite loading thing isn't just multiplayer it's also single player offline.

I don't think any one's router has anything to do with it.

Well thats just weird, there was a Blue post here seconds ago and it poofed.

Well thats just weird, there was a Blue post here seconds ago and it poofed.

Yeah i Saw the blue post too, weird.
Suddenly, a wild blue post (re-)appears!
10/04/2013 05:19 PMPosted by Tsarnis
Suddenly, a wild blue post (re-)appears!

Remind me not to walk closely near bushes in Irvine late at night.
10/04/2013 05:19 PMPosted by Zombie
Remind me not to walk closely near bushes in Irvine late at night.

For real.
Thanks Tsarnis.

Feedback suggestion, put in a timeout on connection attempts so if they fail, which it looks like they are, it doesn't infinite loop.

If there already is a timeout value then we can be fairly certain this problem isn't being caused by the NAT/Firewall issue as mentioned as these users would be seeing the timeout/failure.

I am having the same issues with the infinite load screens as well as being unable to join games with my friends. I was not experiencing this problem before the latest patch, nor am I having any difficulty connecting with other games. However, connecting directly to my modem fixes the problem, so I went through the PS3 support articles as you suggested and also tried port forwarding for the ports listed in the support article. None of these steps has solved the problem, and I'm not sure where to proceed from here. I can't plug my PS3 into the modem every time I want to play, as others in my family need to use the internet.

Thank you for your assistance,
Ok so how is it, it works for you and a few if my buddies after the download. But it does not work for us? I've reset all setting to default and ran internet connections tests. I've done everything it has said and still get nothing. All my buddy gets is a error message when he try's to join me!
I agree I just connected directly to my modem and it works great, but how do I check my router settings from my play station, I don't know own a laptop nor a desktop?
its not our routers...its got to be this patch update...
10/04/2013 07:32 PMPosted by JetJaguar
connecting directly to my modem fixes the problem

10/04/2013 09:15 PMPosted by Jwo
I just connected directly to my modem and it works great
I opened all the ports possible that the PS3 recommended. Can I ask what ports the PS3 diablo needs? ( I have port 6116 and 4000 already open.) this problem didn't occur until the 1.02 patch and other games are not effected... so...

its still in infinite loading.
The fact that we're using routers should be irrelevant. This problem did not exist (at least in my case) until I installed the 1.02 update. I've been playing since release with absolutely no issues and I've changed nothing on my end.
10/05/2013 05:18 PMPosted by SCfinalvirus
The fact that we're using routers should be irrelevant.

I disagree. The fact that removing the router allows it to work says it all.

While I do believe there is a coding issue with the infinite loops that needs to be looked at and Blizzard should give a specific list of ports that need to be open so we can do it properly, the fac tthat no router = no problem speaks volumes.

Personally, I would love to have this issue so I can do some network sniffing to determine whether it is in fact network related. For now, you have the uninstall/reinstall option Necro mentioned. Hopefully some of you can get some similar results.
This is horrible, so ur saying I cant use my router? this problem came when I updated to V1.02. I have opened all my ports on my router and even spent 3 hours with sony on the phone. I have reformatted my playstation and lost all of my high lvl chars and have a ticket in with sony for them to take my PS3 and look at it. Blizzard, this problem was in the patch not our routers, your patch is blocking us from freedome! lol please fix it because i have to use my router, my PS3 is 30 feet away from the modem.
Regardless, the game worked before the patch and now it does not. Blaming it on hardware after a software update breaks something is just foolish and improper troubleshooting. The update is the only problem here and I don't think it's right to tell people that their equipment is faulty when it worked perfectly fine before this update.
Are they ever going to fix this!? i can't connect to my modem every single time i go to play this game. The game worked fine until this update just like everyone is saying.

Join the Conversation

Return to Forum