[BUG] Can't force VSync externally

Technical Support
Prev 1 2 3 4 18 Next
The last few posts aren't relevant to this bug, please keep the discussion on topic.
Ingame vsync works fine for me. I don't get any stutters. Of course, I have a good enough gfx card to run it at constant 60fps..
03/12/2014 08:28 AMPosted by DuguQiubai
Ingame vsync works fine for me. I don't get any stutters. Of course, I have a good enough gfx card to run it at constant 60fps..


really bad troll

I have GTX 770 and it's not working.
I have the same issue with the newest NVIDIA drivers installed. I'm forced to use the in-game VSync.
03/12/2014 10:21 AMPosted by silec
I have the same issue with the newest NVIDIA drivers installed. I'm forced to use the in-game VSync.


Just ignore him, he doesn't understand the issue. Maybe he works for customer support part time?
03/12/2014 09:36 AMPosted by Pandemon
03/12/2014 08:28 AMPosted by DuguQiubai
Ingame vsync works fine for me. I don't get any stutters. Of course, I have a good enough gfx card to run it at constant 60fps..


really bad troll

I have GTX 770 and it's not working.

It's an old bug in D3 that never got fixed. You just have to disable the framerate limiter in the options (move it up really high), then turn on vsync. I have mine at 100.
What we know:

¤ Forcing Vsync in NVCPL or any 3rd party app - Does not work
¤ Using Triple Buffering through D3DOverrider - Does not work
¤ Using latest drivers - Still does not work

Solution: Blizz patch the game
03/12/2014 03:09 PMPosted by Astralen
What we know:

¤ Forcing Vsync in NVCPL or any 3rd party app - Does not work
¤ Using Triple Buffering through D3DOverrider - Does not work
¤ Using latest drivers - Still does not work

Solution: Blizz patch the game


And we know it was working perfectly until patch 2.0.1, so they just need to work out what they broke and fix it.
Bump
Please, can anyone look into this for us?
03/15/2014 09:41 PMPosted by Popesickle
Please, can anyone look into this for us?


A blue post letting us know it's on their radar would be very welcome at this point.
Oh wow, I finally try to find a solution for my issues with the game above 60Hz and it turns out they broke third party vsync. Typical.

Anyway, to fix the stuttering you need to switch your display to 60Hz and enable ingame Vsync without the FPS limiter (or set above your refresh rate). Yes, you suffer input lag, but the game runs smooth as a side effect. If you limit the FPS to your refresh rate to reduce input lag, the game stutters.

So, pick your poison: Smooth with input lag, stutter without input lag, or 61+Hz and tearing/jitter.

Blizzard really don't give a damn about supporting the enthusiast crowd, it really sucks with what we have to deal with while playing their games.
Mine does nothing either.
03/16/2014 12:14 PMPosted by Weaver
Mine does nothing either.


Yeah, there is absolutely nothing we (the players) can do to fix it, the fix must come from Blizzard. I have Tweeted several devs, the CM and sent a ticket to customer support but we are no closer to a solution. There is no reason for them to break externally activating vSync so it was obviously done in error, but I'm not sure if they're even aware seeing as they've not replied to this thread nor fixed the issue outright. I feel really sorry for the people with 120/144hz monitors as this must be a nightmare for them, at least for us 60hz users it's "just" some stuttering we have to deal.
still no blue word on this bug
you need to set windows desktop refresh rate to 60hz AND use fullscreen AND enable vsync in game. for some reason d3 likes 60hz. if you have desktop set to 50hz or anything else than 60 - vsync will just make it worse.
dont try to force any settings with nv inspector or any such pfograms. it wil make it worse or wont work. keep your CCC and NV copntrol panel on defaults.
03/17/2014 05:40 PMPosted by Piglet
you need to set windows desktop refresh rate to 60hz AND use fullscreen AND enable vsync in game. for some reason d3 likes 60hz. if you have desktop set to 50hz or anything else than 60 - vsync will just make it worse.
dont try to force any settings with nv inspector or any such pfograms. it wil make it worse or wont work. keep your CCC and NV copntrol panel on defaults.


nvdia control panel vsync not working 2
03/17/2014 05:40 PMPosted by Piglet
you need to set windows desktop refresh rate to 60hz AND use fullscreen AND enable vsync in game. for some reason d3 likes 60hz. if you have desktop set to 50hz or anything else than 60 - vsync will just make it worse.
dont try to force any settings with nv inspector or any such pfograms. it wil make it worse or wont work. keep your CCC and NV copntrol panel on defaults.


You don't understand the issue.
Adaptive Vsync does work, you have to leave vsync enabled in game.
Before the patch you could turn it off, in game, and it would still work.
So there's no fix for a close to unplayable game right now? -.-

Join the Conversation

Return to Forum