Battle.net launcher update on Wine/Linux

Technical Support
Thx for the setarch reminder. I now havet Wine 1.7.9 but had to use dbghelp (enabled,builtin) before it would load. Thx.
I now can run Wine 1.7.4 with the setarch command also the Battlenet launcher is pulling content advertisement as it should.

Thx for the help.
Today I installed wine x86 1.7.15 inside playonlinux (not the distro's wine) and everything worked without crashes nor need to override anything. For the record, the distro is gentoo amd64 with wine 1.6.1. So I guess wine devs play blizzard games too and they fixed it in the latest version. ;) Thanks to everyone who helped debug the issue and provided workarounds.

PS: Occasionally I get stuck on "retrieving heroes" and/or starting games but I think it's unrelated to this. In that case it might help to start playonlinux with "setarch i386 -3 -L -B -R <your regular command>".
Still glitchy with either 1.7.14, 1.7.15. When leaving (not exiting) the app hangs.

Due to horrible network timeouts with these later wine versions "You've been removed from the game", I'm going back to 1.5.5.

Just not doing it for me.

If there is anyone out there that has had absolutely no negative impact with a 1.7.x wine post your exact configuration.

Cheers
Wine 1.7.16 running on Fedora Core 20 results:

Will load with the setarch i386 -3 statement. No need to add the dbghelp entries. They change nothing.

Results more stable, however exiting D3 fails with an app crash every time. This is no different than any of the 1.7.x versions I've experimented with. I'm still getting "you've been removed from the game" after an hour of play.

However progress is made where the Blizzard launcher loads content and consistently loads the game every time!

Any need for adding components like physx, directx or such?

Can anyone conjecture why the app crashes on selecting the Exit option? Failure to return control back to the launcher I suspect. If we can solve that issue, my vote is to enhance 1.7.16 with a Diablo III revision!
Thank you for looking into this! I played WoW and D3 but I can longer because of the new launcher! :( Please do what you can to help fix this, I am certain many battle.net users will be grateful!
Have been trying for the last few days to install both diablo3 and starcraft2 with wine and play on linux and they both keep crashing without loading.
Seems this thread has worked out a problem to the issue but as I am kind of new to linux am struggling to understand it all.
Is it possible someone could point me in the right direction for an explanation on installing them as most of this thread seems to be about having it already installed before the new battlenet loader but as I am trying to istall it fresh it wants to update that before anygame is installed and then I cant seem to do anythign
@Buggs. Try the wine hq website http://appdb.winehq.org/objectManager.php?sClass=version&iId=29952&iTestingId=83598
That worked for me pretty flawlessly. D3 RoS is running like a charm under my Ubuntu 14.04 64-bit with Wine 1.7.19. Just follow the description and the howto and give it a go.
I just started using Linux, and when I googled "D3/Linux" I noticed that at one point there seemed to be a serious issue with Linux users getting banned?
What's the story on that? Did that get resolved at some point?
If you read back in the thread, a blue said that linux is not supported, but using it is not a bannable offense. I play in linux all the time, and have since launch. Never had a problem (except having to troubleshoot when new patches come out and things break :) )
Thanks to mashdar for the launcher-dbghelp solution. Worked ok on STARCRAFT-2 onLinux-Mint 17-64b-cinnamon. Game began crashing after august launcher update.
pd: this game is NOT supported but runs better on Linux...
Sorry to relaunch an old thread, but even with the setarch command I'm getting stuck at Authenticating Credentials. I've gotten through once or twice, but not nothing works. I'm running Ubuntu 14.04 x64. I've tried the dgbhelp as well as running launcher in 32bit.

Any help would be massively appreciated.

Join the Conversation

Return to Forum