AH fixed, but still crashes resuming/starting

Mac Technical Support
Thanks Blizzard, the AH appears to have been fixed. However I'm still getting the crash occasionally when resuming and starting games. I'd say about 25% of games resumed or started. It also appears to happen 100% of the time after long idle sessions on the menu screen.

Running an iMac mid 2011, 2.5 GHz i5, 20 GB RAM, Radeon 6750M 512 MB, OS X 10.9.2
Give it another week, at least. After all, it's not like Mac users paid 60$ for D3 and maybe another 40/60$ for RoS, right? Oh wait...
I'm wondering if the people who are having crashes when resuming and starting games are all on Mavericks 10.9.2?

I'm on Mountain Lion 10.8.5 and I've never had the crash while resuming or starting games.
I'm on Mavericks 10.9.2 and I don't crash like OP. I had 1 crash the first game after patch. After that no crashes...Except of course the AH..
If you do manage to get a crash report ID, can you please post them? We're investigating these.
03/04/2014 10:14 AMPosted by Machkhan
If you do manage to get a crash report ID, can you please post them? We're investigating these.


Sure, if I get one. I don't believe I've ever gotten one though. When it happens I resume/start a game, it starts the loading process and before it switches to the loading screen the curser switches from the in game cursor to the OS desktop cursor for a second before turning the the beach ball and hanging. I have to pull out to the desktop and close Diablo (which isn't responding).

Like I said, it seems to do it more often after longish idle sessions between resuming/starting games. Perhaps I should just log off for the time being when not playing. Once I'm playing and swapping between games consecutively it doesn't seem to crash.
Thanks. I'm looking at some similar reports and looking to see if I can match crashes based on information here so I can get these over for investigation by the team.
03/04/2014 10:39 AMPosted by Machkhan
Thanks. I'm looking at some similar reports and looking to see if I can match crashes based on information here so I can get these over for investigation by the team.


Also, I usually have iChat, Twitter app, Safari, Mail, Calendar, and iTunes open while playing. I'll try shutting them down tonight when the game is back up. I can't imagine how those being open would effect the game though. In fact a few of the crashes yesterday occurred when iTunes was not open.
I crash periodically when trying to enter or create games. I run 10.9.1 on a 2012 Macbook pro. It seems to happen more frequently if there is a longer delay between games (maybe 10mins or more).
Thanks for the additional information. I'll get this over to our teams.

How often does this happen (4 out of 5, 9 out of 10, etc).
03/04/2014 10:14 AMPosted by Machkhan
If you do manage to get a crash report ID, can you please post them? We're investigating these.

You've probably already seen it but I posted my crash logs a few days ago for these exact crashes (resume/start and crashes when exiting Diablo III).

http://us.battle.net/d3/en/forum/topic/11914351578

I also have Spin Control running but it ended up crashing when I tried retrieving the text reports for the above CTD's.
Thanks. Reports like this helps a great deal with investigating this.
03/04/2014 12:01 PMPosted by Machkhan
Thanks for the additional information. I'll get this over to our teams.

How often does this happen (4 out of 5, 9 out of 10, etc).


I'd say 25% of the time resuming/starting games crash.
I don't have crash reports, but my story is pretty much the same as everyone else. I've reset my cache multiple times, at first it seemed to help a lot but now it seems like it's hit or miss. Sometimes the game will freeze on my first attempt to create/join a game sometimes I can make it 10 games without it happening (if I just reset my cache, but doesn't always work). Also like other people have reported if I've spent 5+ minutes (maybe less, not positive on the time) in menu screen chatting or w/e it always freezes and crashes.

I'm running 10.9.2 on a late 2013 Macbook Pro
I find it very variable. I can go an entire night not seeing it. Another night, have it every third game cause it.
I've added this to our Mac issues thread here: http://us.battle.net/d3/en/forum/topic/11914142073
03/04/2014 10:39 AMPosted by Machkhan
Thanks. I'm looking at some similar reports and looking to see if I can match crashes based on information here so I can get these over for investigation by the team.


I've only started getting them recently, but here:

6ABF5234-B68B-4690-983A-37AE576B9FC4

2D4053B7-07CA-42A5-BC85-B0EBE24D9171

75639762-8234-4D58-904C-440B8D961490

I found that as long as I don't have my browser open (Any browser causes me to crash, not a specific one) I only crash maybe 1% of the time. With a browser open it's closer to 98% of the time.
Thanks for that tidbit. I'll make sure this get over to the team.
Still crashing for me occasionally when starting a new game or when exiting diablo. Spinning ball o doom that never stops. Have to hard reboot.
The hard reboot can be avoided by playing in Fullscreen (Windowed), though the game still crashes.

I am still crashing maybe once every 3-4 times I resume a game. The flickering issue is also occuring for me.

OS X Mavericks
Late 2011 iMac

Thing is, this issue has existed in Beta / PTR since December. Why did you let 2.0 go live when you had these reports? Just look at the first page of the Beta Mac Tech forum alone. This isn't Blizzard quality. I said it before and I'll say it again; if your Windows OS users were experiencing these crashes, it would have been fixed Day One.

Join the Conversation

Return to Forum