AH fixed, but still crashes resuming/starting

Mac Technical Support
Hi I'm too crash when resuming, starting games. also quit game crash as well. I'm on Mavericks 10.9.2.
I am Crashing every single time i try to log in. This is ridiculous.
0D0D74DA-9D51-4305-8C09-3DF046D52C7A
03/04/2014 12:01 PMPosted by Machkhan
Thanks for the additional information. I'll get this over to our teams.

How often does this happen (4 out of 5, 9 out of 10, etc).

It's crashing every single time for me. It's great to have the auction house back before it shuts down, but it sucks that we still can't play after 2.0. I'd really love to take advantage of the bonus experience buff before the 25th, but I feel absolutely no confidence whatsoever that we'll have any such luck.

Is there any sort of time frame for when we can expect this crash issue to be resolved?
Same problem than the previous poster. I haven't been able to play since the update, it quits unexpectedly each time i hit resume game.
You want to know how often it happens? Too often. About 80%of the time.
It's been a week. 50crashes to 100 every day. Care to fix it? Some time this year please? :)
03/04/2014 12:45 PMPosted by Machkhan
I've added this to our Mac issues thread here: http://us.battle.net/d3/en/forum/topic/11914142073


So after playing a bit last night it seems to have increased. Same as before, if I idle in the menu's next resume/create game always crashes. However I can't seem to get consecutive games in like I did prior to yesterday before a crash. I'd say it has gone up to about 50% of the time now.

Same specs as I posted above.
Thanks for the additional reports.

I think this is related to an issue where you try to resume a game after viewing your character profile. This sound right?

    1. Log into Diablo III
    2. View the character's profile.
    3. Attempt to enter a game.
    4. ---> The client can crash.
For me, it's not like that. I just log into Diablo 3, then try to resume game without even viewing any character's profile! Then, after some time, the game quits, and i come back to the battle.net client
03/05/2014 05:52 AMPosted by Azgroth
For me, it's not like that. I just log into Diablo 3, then try to resume game without even viewing any character's profile! Then, after some time, the game quits, and i come back to the battle.net client

Any crash report IDs being displayed for you? This will help us out.
03/05/2014 05:30 AMPosted by Machkhan
Thanks for the additional reports.

I think this is related to an issue where you try to resume a game after viewing your character profile. This sound right?

    1. Log into Diablo III
    2. View the character's profile.
    3. Attempt to enter a game.
    4. ---> The client can crash.


Nope, that isn't it. Just resumed/created a few games after viewing character profile and no crash.

So I've been playing for a few hours this morning with NO apps open in the background and so far not one crash. I'm going to idle in the menu for a while and see what happens when I come back.

Also I just opened Safari to type this, so I've opened an app, oops...
Let me know the results. Our guys are still investigating this, but the viewing character profile and then resuming a game is something we've confirmed is happening.
03/05/2014 07:55 AMPosted by Machkhan
Let me know the results. Our guys are still investigating this, but the viewing character profile and then resuming a game is something we've confirmed is happening.


So it crashed as soon as I resumed a game after idling in the menu for 30 minutes. I reloaded Diablo, viewed my character profile and inspected her gear. It crashed next resume.
03/05/2014 05:54 AMPosted by Machkhan
03/05/2014 05:52 AMPosted by Azgroth
For me, it's not like that. I just log into Diablo 3, then try to resume game without even viewing any character's profile! Then, after some time, the game quits, and i come back to the battle.net client

Any crash report IDs being displayed for you? This will help us out.


I have the same thing, but no crash IDs are coming up. Just about every time I crash, I have to delete agent.db and the cache folder in order to reboot the game. about 70% of the time I'm able to start a game and play on one character, but if I try to change characters, the client will crash (no crash IDs reported) or it'll stall the OS and a hard reboot, followed by deleting agent.db/cache folder is required. These crashes occur for me at least once out of every 3-5 games I try to enter.

In addition, the "loading" screens for me take at least 10s. This includes teleporting from town to a player, using a waypoint, etc.
Sorry, no crash report ID when it quits!
When i tried to delete agent.db and the cache, it didn't change anything!
Sorry, i can't be more helpful!
It happens to me as well. I am using 10.9.2. The load times are really a lot longer than they were before the patch, and there is no crash report. It happens randomly, I'd say 50% of the time. It also does a weird thing where it will load the map (i.e. new tristram, etc) without my character for about 2-3 seconds, with all of the skill bars empty, then finally crashes out. This happens about 50% of the time that the program crashes.
No crash IDs for me either, won't load into a game even without viewing a character profile. If I had to guess, it seems to crash when trying to transition from the loading screen to the map. I'm running 10.7.5 on an early 2011 MBP. This has happened 100% of the times I've tried to start a game since the maintenance yesterday.
This has been happening to me off and on today. Just now it's happened 2 times in a row!! -.-

4320CC7E-80C9-49C3-AFBA-A518476657FC

BDB3A8A7-2109-4D1E-8E7F-845AAF318DFC

-.-'
100% crash rate for me, I'll try to get some report IDs in a minute here...

Join the Conversation

Return to Forum