A Prisoner's Journal BUG

Bug Report
Hello, I am reporting a bug that I have found. In the Halls of Agony 2 - I run to the end to where The Stranger In Need Event is. I wait for the Tormented Behemoth to appear and start attacking him. Upon his death he does not drop the ( A prisoner's journal ). I have ran this event about 20 times and have not had 1 single drop. Please Fix
Have you checked your journal and achievement progress? Lore books don't drop for characters who already have them in their journals.
I'm having the same problem, just finished it 5 or 6 times and never got it to drop. I have never found it before and it's not in my journal or achievements.
I do not have in my achievement progress its still needs to be checked off ( a quick study - Act 1 campaign) i ran it again another 20 times with a checkpoint at the highlands pasage and hoping back into the halls of agony 2 to see the event pop up and the tormented behemtoh appear only to drop items but not the journal. I have so far done it 21 times i have been counting and still no drop i am going to run it again another 40 times today and see if it drops.
Same problem. The journal didn't drop and I don't have it in my log either.
well i clocked in another 50 more times of killing the tormented behemoth and still nothing just random loot drops no (a Prisoner's Journal)
I have the same problem. This is the only Lore Book I have left to do for this achievement. I have run the Stranger in Need quest multiple (10+) times with 3 different toons, and the Behemoth only drops random loot, never the journal. I also checked my quests and journal log and the entry is not there.

Not sure what to do at this point, it really looks like a bug. Pretty frustrating at this point.
totally agreed with you medvanis maybe one day they will fix it and maybe they will read this topic and acutally do something about it till then i guess we are all out of luck with this prisoners journal
Not working for me either, on new or old characters. Infuriating.
I'm having the same problem. I have tried it multiple times starting from the three different quest points in "The Imprisoned Angel" over two different characters. Neither time the book dropped.
well im glad to see that im not the only one experiencing this problem maybe tomorrow Hotfix update they might actually fix this bug we can only hope!
I think the problem is that when they added loot 2.0, it changed his loot table to the standard one for unique monsters. Now instead of the lore book he's supposed to drop, he just drops random loot like others.
Same issue here.
Well, i'm "glad" I'm not the only one to have this problem !
Same problem here as well. I hope they fix it soon, it's the last book I need to complete the achievement.
See also: gameplay bug: no book from event http://us.battle.net/d3/en/forum/topic/11915701665
Same problem here, even with a brand new character, created since the patch.
Oh boy, things going crazy, same here, can't find that damn book
I have the same issue. I have completed the event multiple times on three different characters, and the book doesn't drop. It is not shown in journal and is the last book required for the "A quick study" achievement.
I'm having the same issue, some people said to just switch to a different toon and that would work. I tried that but still no journal and it's the last lore book I need to for the achievement. Hope this gets fixed soon.
Tried with a brand new character and still no book > _ < Please Blizzard, fix it !!

Join the Conversation

Return to Forum