Severe Graphic Glitching

Mac Technical Support
Prev 1 4 5 6 12 Next
Switching between windows didn't help at all, the glitch started maybe after 4-6 hours I launched the game. For all the info about hardware or Graphic card, I posted them already at the first page. Also the glitch happened once after maybe 6 months of playing on Mac.
03/28/2014 04:41 PMPosted by MysticalOS
I think it depends on hardware on how fast it's reproduced.


i have normally the problem after 10-15min in a group game if i play solo ... nothing for 3h

so i think you are right so few player more memory is needed so --->issue

if you have 3gb .... lucky guy... i have just 1gb so my bad!

Diablo III(1582,0xa04101a8) malloc: *** mach_vm_map(size=4435968) failed (error code=3)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug

please let me know if this is a validate bug report id
A5346A2C-AE08-350E-9E32-D48D5F33139A
if so i can deliver more as you wish
Really glad I stumbled on this thread. I have the exact same machine as the OP and I've had this issue- only once in ~20 hours of gaming in the last two weeks, but it's enough for concern, especially when my last MacBook Pro had the infamous 8600M GPU and I still shudder at the words "GPU failure".

I have to say, I Bootcamp for most games but Blizzard Mac ports tend to be of better quality (and not run at 1/2 the framerate of the Windows version, as seems to be the case with all of my Source engine games, for instance). This is the first time since the PPC->Intel switch I've had any real issue with a Blizzard game (WC3 on Rosetta was a !@#$% until Snow Leopard!), and I trust that they're working on it.
MacBook Pro Retina 15
2.7 GHz Intel i7
16GB RAM
NVIDIA GT 650M 1024MB
OS X 10.9.2

10-60 min after start.
More often than in continuously game play, it happens after I using a portal/door/waypoint.
03/28/2014 11:03 AMPosted by S4d1k
If anyone has a bug report ID that would really help. You get these when you crash.


Psychedelic glitch happens every 2-3 rifts on average, and even faster in group play. This time my game crashed just from returning to town from a rift without the kaleidoscope glitching happening first.

Crash ID: FE3702AF-114A-4E4C-A02A-DB2831D6B76E
http://i60.tinypic.com/2cerlhk.png

Yay super kaleidoscope mode. Happened after about 9-10 hours of gameplay, no crash code. It beachballed and I couldn't force quit and had to power cycle to get out.
03/28/2014 10:15 PMPosted by Erebus
It beachballed and I couldn't force quit and had to power cycle to get out.


This has happened to me a few times too.
03/28/2014 01:43 PMPosted by adobe
03/28/2014 12:15 PMPosted by weirdbeard
I play at 1920x1200 anyways. I've had the glitching start with both high and low textures, and on much lower resolutions.
One think i've noticed, however, for people who have been restarting the game when this happens, there's need. You can simply go into the video options, which remain outlined enough to read, if not easily, and swap the textures between hi and low. which ever you're using. Just accept the setting in the other, watch it reset the screen, then swap it back. it doesnt 'fix' it but it does accomplish the same temporary resolution that force-booting your comp does.


This is a welcome workaround as it will prevent one from exiting a game. Thanks.


Thanks. For all those who need a temporary workaround, try this out. Not an ideal fix, but atleast I can continue playing without having to leave party and game.
03/28/2014 10:58 PMPosted by grgjsp
Thanks. For all those who need a temporary workaround, try this out. Not an ideal fix, but atleast I can continue playing without having to leave party and game.


Really excited to try this out. If it does not work I'll edit post.
03/28/2014 10:58 PMPosted by grgjsp
03/28/2014 01:43 PMPosted by adobe
...

This is a welcome workaround as it will prevent one from exiting a game. Thanks.


Thanks. For all those who need a temporary workaround, try this out. Not an ideal fix, but atleast I can continue playing without having to leave party and game.


This is what I've been doing to workaround this issue. It works well as a temporary solution. I get it about once an hour, if I play for more than 90 minutes in a session.

Here's my system info:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B03
OS: 10.9.2
Mid 2012 MBP Retina
2.3 GHz Intel Core i7
8gb 1600 MHz memory
NVIDIA GeForse GT 650M 2014 MB
OSX 10.9.2

Happens every time almost exactly around the 2 hour mark of me playing. Starts with a frame rate drop, then just starts freaking out. Please fix this, I keep thinking it's my comp and im worried, but happy to see that other people are experiencing it and its hopefully something blizzard can fix

edit; spelling
Glad to see I'm not alone.

My experience is captured by everyone else that's posted...graphics flash in Fields of Misery and I'm lucky if I can complete one rift before graphics become unplayable.

Hardware Overview:

Model Name: iMac (Oct 2013)
Model Identifier: iMac14,3
Processor Name: Intel Core i7
Processor Speed: 3.1 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB
Boot ROM Version: IM143.0118.B00
SMC Version (system): 2.17f2
Serial Number (system):
Hardware UUID:

NVIDIA GeForce GT 750M:

Chipset Model: NVIDIA GeForce GT 750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fe9
Revision ID: 0x00a2
ROM Revision: 3762
Displays:
iMac:
Display Type: LCD
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C64)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name:
User Name:
Secure Virtual Memory: Enabled
Time since boot: 18:16
Happy to report that changing textures from high to low, then hitting cancel to accept changes, works on my end and I no longer need to restart the game.

However the game still crashes sometimes without any warning e.g., if I'm in a full game doing a rift and go back to town. Like another player said, game will sometimes crash and we'll be stuck looking at the colorful spinning wheel of death. This happened one time while I was in a fight and thankfully when my computer restarted I logged back in to see my crusader still alive.

Will edit post with crash ID next time this type of crash happens.
03/29/2014 10:03 AMPosted by weslandia
Mid 2012 MBP Retina
2.3 GHz Intel Core i7
8gb 1600 MHz memory
NVIDIA GeForse GT 650M 2014 MB
OSX 10.9.2

Happens every time almost exactly around the 2 hour mark of me playing. Starts with a frame rate drop, then just starts freaking out. Please fix this, I keep thinking it's my comp and im worried, but happy to see that other people are experiencing it and its hopefully something blizzard can fix

edit; spelling


I have the same computer you do. I have found that it happens EVERY single time I complete a rift. In fact it happens exactly after I accept the gold and xp rewards.
Same problem here http://imgur.com/a/Q7opL

A quick way to solve this problem is to change the quality of the textures and then return to the original settings.
03/29/2014 01:09 PMPosted by J3ear
03/29/2014 10:03 AMPosted by weslandia
Mid 2012 MBP Retina
2.3 GHz Intel Core i7
8gb 1600 MHz memory
NVIDIA GeForse GT 650M 2014 MB
OSX 10.9.2

Happens every time almost exactly around the 2 hour mark of me playing. Starts with a frame rate drop, then just starts freaking out. Please fix this, I keep thinking it's my comp and im worried, but happy to see that other people are experiencing it and its hopefully something blizzard can fix

edit; spelling


I have the same computer you do. I have found that it happens EVERY single time I complete a rift. In fact it happens exactly after I accept the gold and xp rewards.


I also have the same computer, and it doesn't happen EVERY rift, just about 80-90% of them.
I've been referring to this as "Aneurysm Mode." It has been happening to me on my MacBook Pro.

http://cl.ly/Uhwb
http://cl.ly/UhhE
http://cl.ly/UiuG


  • OS: 10.9.2
  • Model Name: MacBook Pro
  • Model Identifier: MacBookPro9,1
  • Processor Name: Intel Core i7
  • Processor Speed: 2.6 GHz
  • Number of Processors: 1
  • Total Number of Cores: 4
  • L2 Cache (per Core): 256 KB
  • L3 Cache: 6 MB
  • Memory: 8 GB
  • Boot ROM Version: MBP91.00D3.B08
  • Graphics Card: NVIDIA GeForce GT 650M


Now, my brother also plays on a MacBook Pro, but he has NOT seen these issues. Here are his specs (his is older than mine):


  • OS: 10.8.5
  • Model Name: MacBook Pro
  • Model Identifier: MacBookPro5,3
  • Processor Name: Intel Core 2 Duo
  • Processor Speed: 2.66 GHz
  • Number of Processors: 1
  • Total Number of Cores: 2
  • L2 Cache: 3 MB
  • Memory: 8 GB
  • Bus Speed: 1.07 GHz
  • Boot ROM Version: MBP53.00AC.B03
  • Graphics Card: NVIDIA GeForce 9600M GT


03/29/2014 01:27 PMPosted by VemeC
A quick way to solve this problem is to change the quality of the textures and then return to the original settings.
Awesome find. I'll be sure to try this.

_____________________________________________

EDIT: I just looked through the whole thread, and it looks like everyone here is having the issue on Mavericks. Like I mentioned above, my brother plays on a MacBook Pro as well, but he is still on Mountain Lion, and he has NEVER experienced this issue
Yeah on Mavericks too, not much else to add, Rifts cause it, it may happen quicker the more levels you go down in a rift. Anyway, I am relieved that this is happening to others and its not something wrong with my hard ware. Macs aren't cheap ya know!
Mavericks 10.9.2
Nvidia 675MX 1024MB
iMac Late-2012, 3.2 GHz i5, 8GB Ram.

Unsure of time when it happened, no crashes for me.

Hardware Overview:

Model Name: iMac
Model Identifier: iMac13,2
Processor Name: Intel Core i5
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: IM131.010A.B05
SMC Version (system): 2.11f14

NVIDIA GeForce GTX 675MX:

Chipset Model: NVIDIA GeForce GTX 675MX
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x11a2
Revision ID: 0x00a2
ROM Revision: 3707
Displays:
iMac:
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Join the Conversation

Return to Forum