Severe Graphic Glitching

Mac Technical Support
Prev 1 5 6 7 12 Next
Macbook Pro, Retina Mid-2012
Processor 2.3GHz Intel Core i7
8 GB 1600 MHz DDR3
Intel HD Graphics 4000 1024 MB
OS X 10.9.2

Having a problem where after sometime my graphics start acting up in game. Took a screen shot. Looks like this: http://s22.postimg.org/ncwq1ubjj/Screen_Shot_2014_03_30_at_12_19_15_AM.png

Please help, this started happening a few days ago.
03/27/2014 04:17 PMPosted by S4d1k
What OSX version you're using?
What's your video card?
How many hours before this happened (starting when you launch Diablo III)?
When it started, did you crash shortly after? If so, please provide the crash ID. (The long number in the crash reporter)


OS Version 10.9.2

- Intel HD Graphics 4000 with NVIDIA GeForce GT650M

- Usually within an hour, and sometimes faster when I am on certain maps in Act I or doing bounties or rifts, some part of the map start to flicks. Especially when I play in a party of 4, some of their skills starts to flick really bad and then my game starts to glitch.

- The game will crash if I keep playing too long or when I tried to change my resolution after the glitching begins, but I normally restart immediately because it's unplayable. I would say 10 minutes or so to force a crash.

Crash ID: 33F737F8-139C-4C54-85F4-276D6294B3C2
2nd time: AABDD48D-6C00-484C-ADFD-65DD0022F480
03/29/2014 12:37 PMPosted by BadLlama
However the game still crashes sometimes without any warning e.g., if I'm in a full game doing a rift and go back to town. Like another player said, game will sometimes crash and we'll be stuck looking at the colorful spinning wheel of death. This happened one time while I was in a fight and thankfully when my computer restarted I logged back in to see my crusader still alive.

Will edit post with crash ID next time this type of crash happens.


Or just quote myself and slap ID in here...

7BEE0500-2F2F-45F6-807F-D9850F2B346D

Edit: Happened again. Did 2 rifts and shortly after returning to town the game just crashed. 43A3E834-DEC1-496F-A8B7-951D838C4D3F
Posted by S4d1k
What OSX version you're using?
What's your video card?
How many hours before this happened (starting when you launch Diablo III)?
When it started, did you crash shortly after? If so, please provide the crash ID. (The long number in the crash reporter)

OS Version 10.9.2

- Intel HD Graphics 4000 with NVIDIA GeForce GT650M


new ID
after 1rift ( around 10-15min)
DC178A74-5088-44A0-A5C4-AAF8B9929E05
next crash
304EAE8A-3ABE-43E0-B85E-01BF75AE77D8
here we go buddys ;)
35C782D9-43F5-45DD-BEDD-BE3F97386D03
So, all in all, almost every Mac User with 2012 and 2013 models experience this issue. We did our work in providing blizzard as much information as possible to look into this issue. However, I do have some other concerns that are related to hardware.

I dont know how many of you guys that reported the problem actually look into the framerate. As i mention on a previous page before, after getting the glitch, my framerate drops SIGNIFICANTLY (down to 20fps).

I thing this has to raise some concerns, as changing texture settings is only resolving the glitch issue, but not the framerate problem. Even if you quit the game completely, and start running another game or applicaiton, the framerate is still very LOW. The only thing that resolved this for me was restarting the Mac completely.

For all the people that have not done so, I would suggest to observe your framerate, before the glitch, after the glitch, then after qutting diablo and running some other games/applications. I want to know if some of you guys share this experience, because if this is generalizable, im not buying the argument that this problem is only affecting the diablo3 experience, without influencing our hardware AND POTENTIALLY CAUSING DAMAGE TO IT.

I think this is very important, as people keep playing with the graphic glitch issue, not knowing if it affects their hardware in the long run.
Major graphic glitches on my MacBook Pro 15' Retina (2.3GHz, i7, 8GB 1600MHz DDR3)

After 30mins or so, the graphics glitches so much that the game becomes unplayable. You can't tell where you are going and what you are doing :(

It all started after 2.0.2 I think...
Same issue here. I've uploaded some video. Macbook pro (10.9.2) non retina with NVIDIA GeForce GT 650M with 1GB of GDDR5 memory. Usually happens after playing for a while. A restart of the game seems to resolve it for a time.
http://us.battle.net/d3/en/forum/topic/12318851793
Switching textures option to low and then back to high resolves the problem for me without being forced to restart the game.
So here is an error id:
996B9628-226D-47BF-9E2F-2BF5EA10D7A1
and another one
62C8A4E4-4C99-407D-867E-20E503FD9999
My mac:
10.9.2
2,7GHz i7
16GB Ram
Intel HD 4000 1GB / Geforce GT 650M 1GB
2880 x 1800

Diablo 3 settings:
Resolution - 1680 x 1050
Texture - Low
Shadow - Low
Physics - Low
Clutter - Low
Having a frame rate on around 25-45 with these settings

The Glitch happens more or less always when doing a rift.
Playing for around 3 hours on different characters no problem,
1 rift under 30 min and crash
03/30/2014 05:36 AMPosted by UatderBarbar
So, all in all, almost every Mac User with 2012 and 2013 models experience this issue. We did our work in providing blizzard as much information as possible to look into this issue. However, I do have some other concerns that are related to hardware.

I dont know how many of you guys that reported the problem actually look into the framerate. As i mention on a previous page before, after getting the glitch, my framerate drops SIGNIFICANTLY (down to 20fps).

I thing this has to raise some concerns, as changing texture settings is only resolving the glitch issue, but not the framerate problem. Even if you quit the game completely, and start running another game or applicaiton, the framerate is still very LOW. The only thing that resolved this for me was restarting the Mac completely.

For all the people that have not done so, I would suggest to observe your framerate, before the glitch, after the glitch, then after qutting diablo and running some other games/applications. I want to know if some of you guys share this experience, because if this is generalizable, im not buying the argument that this problem is only affecting the diablo3 experience, without influencing our hardware AND POTENTIALLY CAUSING DAMAGE TO IT.

I think this is very important, as people keep playing with the graphic glitch issue, not knowing if it affects their hardware in the long run.


This sounds like a case of the SMC to me, I used to have that problem. Somewhere along the line it disappeared. You could at least try reseting it http://support.apple.com/kb/ht3964
I just have really bad texture flickering in act 1 on adventure mode.
03/30/2014 09:55 AMPosted by Robczan
Switching textures option to low and then back to high resolves the problem for me without being forced to restart the game.


This is the best way I have figured out as well
Same issue. Retina MBP 2.2 16GB 650M 1GB.
03/27/2014 04:17 PMPosted by S4d1k
We can reproduce this after many hours of gameplay. If you find a better way, we would like to know.


Better yet, do you have any tool to do a GPU memory dump? I could do it while I experience the glitch. I'm getting it quite frequently while playing with someone else.

And if your theory is correct, then load a character with a stash-full of stuff, more players inside, and start teleporting between different places.

Actually, teleporting between portals is usually the trigger, my feeling is that some of the world textures are not getting freed, so jumping between different places loads even more textures, starts doing pressure.
This exact thing has happened to me 3 times in the past 2 days.

The first time it happened I was playing with my friend who was also on a mac and had the same problem at the same time.

At first it starting with being ported somewhere I didn't choose, and then when I tried to port to town, it didn't work. When I walked over to town it was... Interesting to say the least.

These are from the first event:
Tristam
http://imgur.com/dXRwqFj

Character Screen
http://imgur.com/jZ6JZlv

Menu (I call him my Glitch Doctor ;D)
http://imgur.com/kShEOwz
A60EAA0F-12C8-4179-9927-3C0AACDF13CC

right after rift
Thanks to everybody that sent crash IDs and informations.

All the crashes are related.

Technical explanation:
We are running out of memory address space. Which is causing the textures to be loading incorrectly and to show garbage data. Changing the texture quality tells the game to reload all its textures, this might avoid the problem for a short period of time.

This bug cannot cause damage to hardware.

The next time this happens, can you guy launch Activity Monitor and double-click on the Diablo III process, click on the Memory tab and post the Virtual Memory Size?

In the meanwhile, we put a tentative fix for the next patch. I say "tentative" because we have no good way to verify if this really fixes the problem.

Thanks for your help.
Good news. To avoid this, i have to install windows and play there.
MacBook 13, medio 2010
2,4 GH Intel Core 2 Duo
2GB 1067 Mhz DDR3
NVIDIA GeForce 320M 256 MB
WQ020AZZF5W
OS X 10.8.5 (12F45)

Running everything on lowest possible settings, resolution close to 1000xXXX

I am experiencing slight overheat from continuing to try and play when the flickering etc. happens.
Whenever this begins to happen, everything goes slow (because of overheat I assume) and restarting RoS may take upwards of 5 minutes.

The major problem seems to be using waypoints (getting into any kind of loading screen)
I've managed to get inside 2 rifts, rest DC upon entering.
Otherwise mostly DC upon making game/returning to town.

The loading screens take upwards of 2-3 minutes and at a certain spot it 'lags' and the loading bar stops for approx. 10-15 seconds and then resumes moving. Then I know Im going to DC.

runs WoW with no lag and no overheating.
runs Hearthstone with no lag and no overheating.

Im not good with information about computers and I haven't been able to get any of those 'crash' numbers others have shown, then again I don't exactly crash, just DC from the game and return to front page where you make games, access AH etc. this goes very slowly as described.

Hope anyone can help me find a solution as it is very frustrating for a guy that spends many hours a day trying to play this.

Thanks in advance.

Edit: Im from EU so my character isn't showing on this profile.
Here is my profile on EU: http://eu.battle.net/d3/en/profile/JohanJizzu-2122/hero/9050325
JohanJizzu, you have 2 GB of RAM. The minimum is 4 GB.

While upgrading won't solve all your issues, it will improve the game performance by a lot.

Join the Conversation

Return to Forum