Rift crashes on my Mac

Mac Technical Support
Prev 1 2 3 16 Next
ditto hard crash no crash ID 10.9.2 MacBook Pro tried resetting cache occurs is menus as well as game. have not figured out a pattern

Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP101.00EE.B03
SMC Version (system): 2.3f36
Def seems the common denominator is the lower vram hardware.
Rift crashes and rift lags seem to be problematic. They happen almost 90% of the time. That's a bad ratio.

Even people in chat who are using pcs complain about rift lags although they don't seem to be crashing.

Here is what the Mac Console had:
*Game crashed at around 3:43:51*

2014-03-29 3:43:46.341 PM battle.net[3305]: CoreText performance note: Client called CTFontCreateWithName() using name "Blizzard" and got font with PostScript name "Blizzard-Regular". For best performance, only use PostScript names when calling this API.

2014-03-29 3:43:51.545 PM battle.net[3305]: CoreText performance note: Client called CTFontCreateWithName() using name "Blizzard" and got font with PostScript name "Blizzard-Regular". For best performance, only use PostScript names when calling this API.

2014-03-29 3:43:52.745 PM Blizzard Error[3431]: Blizzard Error Report ID: 1AA948D1-FBC9-4F69-BE00-1C33717A8795

The Report ID was 1AA948D1-FBC9-4F69-BE00-1C33717A8795


Running the 13-inch retina late 2013.
2.4 GHz Intel Core i5
8 GB 1600 MHz DDR3
Intel Iris 1024 MB.

And right after crash, if I click Reopen, the battle.net desktop app runs an update that lasts about 1 sec. Weird.

A simple google search of both of those lands you in support with known problems:

Have you tried those steps?
Game is most definitely broken to us Mac users. It only happens to me when i return from a rift after clearing it. Which in turn is costing me gold and a lot of experience... As many others stated, it just hard crashes and I do not get a crash ID.
Probably has happened at least 7 times at this point

Also, to all of you how hard reset your Mac after this lockup, you don't have to. Hit CMD+ Option+ ESC and it force quits the game.
I have a 2014 iMac with the 780m card - 4096MB of vRAM on that card.

I've had my game crash out 5-6 times now while doing rifts - never get a crash report either.
Newest crash ID :
2014-03-29 11:02:57.452 PM Blizzard Error[4034]:
Blizzard Error Report ID: 8A677485-122A-4C5D-BDB2-05DA756D7A01
well.... happened 2 more times when playing single player. and times playing multiplayer are fine. this is becoming a pattern at least for me. Going to try to ask someone to join my game before town portaling to see if that helps....
...update. completing the rift seems to trigger the freeze. I killed a rift guardian. went back up 1 level and it froze again.

update: having a friend join you does not help. I still crashed. (but I was about to log back in, rejoin game and claim the exp/gold.

update: using the portal in game ( not your own tp ) allowed me to go back to town without crashing. This only happened once, but I'll be doing it from now on to see

update: was able to get out multiple times by using the in game tp. so there's a 'workaround' for some people
I'm having this issue as well. Rift's appear to be the most common locations for the crashes. I've been playing in multiplayer with two to three others. I'm getting no crash ID. It just crashes, leaving the bliz launcher on the desktop. It always seems to mostly happen on a load screen going from a camp to the rift. Also, load times between zones in rifts seem to take longer than others I'm playing with (though this may just be an issue with my comp being older).

Macbook Pro 2.4 Ghz Intel Core i5
Memory 4gb
Graphics Nvidia Geforce 330M 256mb
osx 10.9.2
I've done a few rifts on my little Mac Mini i5. Only had 1 crash, which occurred after I was around 80%-ish and had gone back to salvage junk (inventory was full). On my way back into the rift portal, D3 crashed. No crash ID.
Another one to add to the huge list of rift issues... I have yet to get any other issue, but I've only gotten thru a rift once. Every other attempt crash-exits to the Launcher within 10 seconds of entering a rift, no matter what it contains. Don't even get time to exit or 'port home. No crash ID has been seen.

I'm running an early 2013 MBP (MacBookPro10,1), if that helps.
Still getting this issue - but only in single player. Ran 10 or so rifts last night with a friend without a problem. Today - first one freezes right when I create the portal - there goes other 5 rift shards.
Have same issue with game closing as soon as rift is completed and I teleport back to camp. Game freezes in-between loading screen from rift to camp. Error code 88B575F4-D984-499F-A530-FCB032D29A9A.

Has happened on multiple difficulty levels for me. Issue has happened regardless of other on going graphical glitches reported in other posts, i.e those graphic glitches are not present when this problem occurs.

MacBook Pro
OS - X 10.9.2
2.6 Ghz Intel Core i7
8GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1024MB
mine was also in a rift as i was teleporting out
here is my crash id:

Running a late 2013 macbookpro 13 inch
I don't have a crash ID, but i've noticed that most of my teleport issues revolve around rifts that are located in Act V.
Same here
Just got up to 98% before the rift guardian appeared. Was full of junk, so went to salvage. Game instantly crashed when going back into the rift. Once again, no crash ID...

Did find a Manald Heal ring on my run, but still... wanted to kill that guardian.
Just tried my first rift as well...cannot load in...client crashes after about a minute loading screen.
Same issue as everyone else.

Join the Conversation

Return to Forum