Rift Shattering and Lag

Technical Support
Prev 1 2 3 4 7 Next
Same prob here, intermittent freezing on screen popups etc..and latency jumping up and down. I havnt been able to enjoy this xpac since it went live and its really getting old. My pc is more than enough to run d3 and I have no latency issues with any other game...Blizz, fix your mess!
please at least tell us this is being look at, thanks.
this is yet another reason why I'll probably not play hc for a long time.

this is !@#$ing crazy, I can't even check my inventory... 3 second freeze
Aliright, there is a simple work around. This appears to be caused by the rift progress bar, so if you click the minimize button on your objectives panel (hide the bar) the lag problem will disappear.

EDIT: Oddly enough, things work fine for me after I bring it back after minimizing it, so perhaps it's an issue with how it was initially rendered when you start a rift.
Bump. Same problem here. Blizzard pls do something.
Aliright, there is a simple work around. This appears to be caused by the rift progress bar, so if you click the minimize button on your objectives panel (hide the bar) the lag problem will disappear.


Ohhh, excellent, will have to try that!
This issue affects me as well. Opening up windows (character sheet / inventory, skills, etc.) often causes a few seconds freeze in the game when running Nephalem Rifts. After the initial freeze, subsequent opening of those windows is fast - until I adventure further in the rift.

Contrary to what others have reported above, minimizing the Objectives panel (the rift progress bar) does NOT help. What DOES help is dropping texture quality down to "Low". Perhaps the rifts just happen to be texture-hungry.

I'm running on a 2048MB nVidia GF108GLM (Quadro 1000M).

(Edit: Corrected the amount of memory on the graphics card.)
So, I did try it, and the workaround worked great for me =)

It also worked for my brother, but his experience was that he could pop it back out in single player after hiding it, but had to keep it hidden in multiplayer.

Hopefully reports like Voltara's can further help Blizz pin down the issue.
I don't have any problems with the menus, but I do have the same item lag you described, not to mention the frequent lag spikes and timeouts.

It happens mostly on Rifts as well.

EDIT: Hiding the objective bar didn't help with the lag, but at least I haveng got disconnected, so I can say that's an improvement.
Still having the same issues. Rifts are d/c when entering and teleporting to friends in rifts. Bounties and switching between waypoints are fine though.
I get frame stuttering/skipping and I've tried changing many settings.
Also getting this problem on a high end system.
03/30/2014 02:23 PMPosted by Tiakatt
Aliright, there is a simple work around. This appears to be caused by the rift progress bar, so if you click the minimize button on your objectives panel (hide the bar) the lag problem will disappear.


Ohhh, excellent, will have to try that!


Does not fix it.
I am actually experiencing the same issue. Sometimes it locks up for a full second or two, sometimes it runs pretty smoothly when doing those actions. My computer is pretty good, and has no problem running any Blizzard game, but by no means it is near being top of the line. I just chalked this up to having older equipment. I will keep tabs on threads like this to see how this thread develops.

Note: This will happen even when not rifting. I haven't tried Campaign, so it may be something exclusive to Adventure Mode?
Like others, Having massive problems running rifts, Huge freezes, and massive frame rate drops when running in groups, However is ok in single player. Should not be an issue at all with my set up (see below) Any sort of update or acknowledgement that this is an issue and is being looked at ?

Specs
CPU - AMD FX 6350 Hex core oc'ed to 4.4ghz, Watercooled.
GFX - Radeon 6950 2gb
HDD - SSD, RAM - 8GB
bump
Similar issue here.

Only occurs during Rifts. I get about an hour of play time before I disconnect. I get many lag spikes during the Rift. Several mobs being on the screen can cause me to DC also..

I can play for hours on end during Camp. mode Let me hit Adventure mode and/or a Rift and it's only a matter of time before the lag spikes and disconnect hit.
Same issue here. Animation will "catch up" (look like it's on fast forward) at times. Identifying items either on the ground or in the inventory can lag for a second. Same with opening a menu. I only started noticing this when I started running rifts. I am running a Samsung 840 Evo SSD, i7 4770k, 16 gigs Corsair Dominator Platinum 1866, and 2 GTX 780ti's in SLI so I don't think it's for lack of hardware. I can play Bioshock Infinite on Ultra and other games without even a hiccup. Surprised there has not been a blue in this thread yet.
04/04/2014 08:30 AMPosted by hal8999
post pathpings: https://us.battle.net/support/article/running-a-pathping-test


If it's client side latency, then why only in rifts? Obviously something is different and it's not something that we are changing on our end as we enter a rift.

Join the Conversation

Return to Forum