Freezing when doing Nephalem Rifts

Mac Technical Support
My game freezes up when doing nephalem rifts. Sometimes it lags out sometimes it doesnt. Anyone experiencing the same?

MAC OS X Mavericks 10.9.2
2.9 GHz Intel Core i&
8 GB 1600 MHz DDR3
I have similar problems
Same here, MBP 15inch. Seems to be happening to mac users.
Brand new 2014 iMac - Keep getting this issue. 10.9.2 OS.

It's getting really frustrating... I keep losing my reagents to open nephalem rifts because it'll crash right when I enter - or it will crash in between visits to towns.
I am having the issue as well. It only crashes when I am running the rift.

OSX 10.8.5

I dont even get a crash report the game just freezes then closes itself.
same here- just put Mavericks on and ran the desktop app repair and reset the permissions to the D3 folders to make certain they are read/write

the crash seems to be related to a graphics card exception from the error log

after all that I didnt crash at all last night on about 30 coops, though after 3 or so the graphics would glitch out and I would need to reset the game
same here. happened 3 times already today. open rift, walk in, crash.
same here. It happend 3 or 4 times over the last two days. I have to force quit each time.

OSX 10.9.2
ME TOO! Please fix. I have wasted 20 fragments on this. OSX 10.8.5. It happens every single time without fail, so I've stopped trying.
same here. happened 3 times when loading screen (returning to town).
OS 10.9.2
2.7 GHz Intel Core i5
12 GB 1333 MHz DDR3
AMD Radeon HD 6770M 512 MB
Just to add, that I have the same problem guys and it happens mainly with rifts. Blizzard please find a solution, because it is getting really frustrating.

Thank you.
Just a tip guys, for me it seems to work when i lower my graphics.
04/01/2014 07:43 AMPosted by Borissov89
Just a tip guys, for me it seems to work when i lower my graphics.

I tried that but the lag still persists and only when you open inventory, the menu, you get an notification or when a monster drops loot.
Also this happens with everyone on my party and we were all using win 7.
Same here :-( 3rd time in a row...

Mid 2012 MBP, OSX 10.9.2
I can't even teleport to town without getting disconnected. I can't even go to the rifts or use adventure mode. I uninstalled the game and reinstalled. I contacted Apple and I followed all their instructions. They are positive it's a Blizzard issue.

I am directly connected to our hub and skipped out using the wifi because we have the fastest speed available through ATT.

This is getting utterly frustrating.

and yes..I lowered graphics. Have the latest Marvericks. Nothing running in the background. To be honest, the only thing installed on this Mac is my Diablo.

grrrrrr
Game freezes every time I teleport back to town after killing the rift boss. This started a couple of days ago.
encountering the same issue, freezes in the middle of the rift. OSX 10.9.2

Seems to be doing fine when I'm in coop though
My game also crashes in Rifts, but only when teleporting out after killing the rift guardian. Very frustrating. Happens when playing Co-op. rMBP late 2013, OSX 10.9.2
Having the same issue. Finish the rift, teleport out. Then my loading screen freezes and I can reboot the game. Happens since either tuesday or wednesday. Doesn't always seem to happen, but 9/10 times it does. I don't mind that much, since I still have all the loot. But unfortunately I am unable to finish the "quest" and get the extra gold / exp. Hope it gets fixed. Early 2010, OSX 10.9.2 (no other problems, besides the known stuff).
I've never had my D3 freeze... or until now anyway. For several minutes now my load screen has just sat there... tried to enter a rift. It's the 1st time it's frozen for me. I've encountered the instant crash when entering as well as long load screens when entering, but a freeze? This is stupid.

Join the Conversation

Return to Forum