Weird graphics glitch

Mac Technical Support
Hello my fellow mac users!

I'm going to start with a couple screenshots of my problem, that way is easier to explain:

http://i.imgur.com/TulR1Lv.jpg
http://i.imgur.com/Ivuo0zB.jpg

Now some facts:

- It just starts, usually after load screens, from time to time (30 minutes ~ 1hour).
- It happens randomly. I can't see a pattern on what triggers it.
- The only way to solve it is completely leaving the game and starting it again.
- It's happening ever since before patch 2.0. But now it's more of an issue cause sometimes I'm almost finishing bounties in Adventure Mode, and i have to leave and lose my progress to fix it.
- I know theres a couple more posts addressing the same issue, but since it's not related in the Known/Under Investigation thread, i made another one.

Can i get some blue love here?

Thank you!

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f36
Serial Number (system): C02J43QFDKQ5
Hardware UUID: 169C99F6-7ABF-5092-ADC8-5EF6DB9F0516

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 1024 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: Retina LCD
Resolution: 2880 x 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C64)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: ####
User Name: ####
Secure Virtual Memory: Enabled
Time since boot: 4 days 3:58
I see the same since upgrading to Mavericks yesterday. Before the swap I was getting crashes in the rift (apparently a graphics card exception) but now every third run or so it goes glitchy as soon as I open my stash or the BS window
I have the exact same issue. I can't seem to see a pattern either. It's annoying when you have to restart the game to fix the issue. Hope this gets fixed soon!! Help! I have a Macbook pro retina as well, same model as above.
I'm being affected by this problem with this too! My friend runs a macbook pro and keeps getting this glitch, it forces him to quit right in the middle of rad quests. It's super annoying : P
I have the same problem. Get really weird loading screen and minimap gets whacky, symbols are changed on the mini maps etc (shrines turn into rift portals, health wells turn into hearts etc).

Usually happens after some time playing and I have to exit the game and restart. It starts off with something small being weird, like a weapon looking weird in the inventory and then it quickly escalates. Particularly annoying when you are in a rift.

Using a 2012 15" MBP Retina (10.9.2)
I have the exact same problem. Starts after awhile and whole display goes crazy. If i continue to play it will normally cause a crash and i have to restart. Good to know i'm not the only one. Thought I had a bad ram or something. It will always happen, normally after about an hour or 90 mins. I just played through a whole rift since it started at the beginning of the rift and i didnt want to waste my rift key. computer hung at the teleport back to town and i didnt get to hand in the quest so lost xp there.

Blue help requested please.

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B03
SMC Version (system): 2.3f36
Serial Number (system): C02K807ZFFT4
Hardware UUID: 5998DE96-69C6-5BA0-9CD5-DCA32574657B

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 1024 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Displays:
Color LCD:
Display Type: Retina LCD
Resolution: 2880 x 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Having the same problem... hope Blizzard will fix it soon.

I every 10 minutes or so must restart the game.

Join the Conversation

Return to Forum