Failed to Start Diablo III Launcher.

Mac Technical Support
I know there was a patch last night. I attempted to log in like I do every day at this time and I receive a message pop up:

Launch Failure
Failed to Start Diablo III Launcher.

Any ideas????
Hi SirRup,

We're currently aware of an issue and are looking for additional information. Can you please post the requested information in this thread? We'll also be providing updates there as we receive them.

    1. Click on the Apple Menu while holding down the Option key and select System Profiler 10.6.8 / System Information 10.7 and later.
    2. Copy the information from the following sections and paste them into your post. Please copy in the following order: Hardware Overview, Graphics, and Software. Do not include any serial numbers, hardware UUIDs, or account/login names or information in your post.

______________________________
Technical Support: Sunday-Thursday, 12pm - 9pm Pacific Time
How am I doing? // https://www.surveymonkey.com/s/Glaxigrav \\
I am having the same issue and this is very annoying I wanted to level my monk up to 70 today so that way i can be ready for the anniversary buff tomorrow. Sigh now I can't even play. Here is my system information.

Overview:
Model Name: iMac
Model Identifier: iMac11,2
Processor Name: Intel Core i3
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB
Graphics: ATI Radeon HD 5670
Software: OS X 10.9.2 (13C1021)
Same Issue:(

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i5
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.68f99
Sudden Motion Sensor:
State: Enabled

ntel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
Color LCD:
Display Type: LCD
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C64)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 4 minutes
Thanks!

In the mean time, one of our MVPs, TheTias, posted a workaround here.
please help me,

this warning.. failed to start diablo 3 launcher,

ı game is not starting,
I m using mac os 10.9.2
Regretfully, I am also suffering the same system failure. I know you're working diligently to resolve. Take care and best of luck. Please see the following requested information:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro9,2
Processor Name: Intel Core i7
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Boot ROM Version: MBP91.00D3.B08
SMC Version (system): 2.2f44

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 1024 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
Displays:
Color LCD:
Display Type: LCD
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C1021)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal

Take care. Sincerely, Corezonius
Corezonius, please use the fix found here: http://us.battle.net/d3/en/forum/topic/12674389999

This will resolve your issue.
________________________________________________
Technical Support MVP
Prime Directives:
1. Serve the public trust.
2. Protect the innocent.
3. Uphold the law.
4. Smash, Jay, Smash!
Here is my Info. In the meantime, I have just been opening my Apps folder and launching from there.
Inconvenient, but what's new. :/

I would rather understand why my screen locks DAILY and kicks me from the game when I am rifting.
But I guess one thing at a time. Thnx

Model Name: MacBook Pro
Model Identifier: MacBookPro9,2
Processor Name: Intel Core i5
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 1024 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
Displays:
Color LCD:
Display Type: LCD
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C64)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Same problem, doesn't matter . . . Next time TEST the freaking patch before you distribute it.

Here's the line that matters . . .

From D3Debug.txt

2014.05.19 01:04:53.273382924 Diablo III Release (No Assertions) running under Mac OS X 10.9.2 (13C1021)
2014.05.19 01:04:53.273657565 <BUILD>2.0.5.24017 (98453-1233810)</BUILD>
2014.05.19 01:04:53.273863837 System Model: MacPro4,1
2014.05.19 01:04:53.274004866 Cheats: DISABLED
2014.05.19 01:04:53.274211523 CPU Vendor: GenuineIntel
2014.05.19 01:04:53.274332078 CPU Details: Intel(R) Xeon(R) CPU X5550 @ 2.67GHz
2014.05.19 01:04:53.274512344 CPU Processors: 2
2014.05.19 01:04:53.274680845 CPU Cores: 8
2014.05.19 01:04:53.274866409 CPU Threads: 16
2014.05.19 01:04:53.275041366 16384.00 MB of total physical memory
2014.05.19 01:04:53.275198821 OS Language: English
2014.05.19 01:04:53.275380616 Application Path: /Applications/Diablo III/
2014.05.19 01:04:53.275503196 ----------------------------------------------

2014.05.19 01:04:53.275745127 Command Line:
2014.05.19 01:04:53.341353850 ERROR: [Launch Failure] Failed to start Diablo III Launcher.

Now, I CAN attach the debugger and thoroughly inspect the applications, but until you produce a reasonable dump on error you're going to get NOTHING from your users.

There's this thing in OS X called "CrashReporter". Learn to use it please.
Having the same problem. Haven't been able to start Diablo III since the latest update. Need help!

Thanks

Hardware Overview:

Model Name: iMac
Model Identifier: iMac10,1
Processor Name: Intel Core 2 Duo
Processor Speed: 3.06 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: IM101.00CC.B00
SMC Version (system): 1.52f9

ATI Radeon HD 4670:

Chipset Model: ATI Radeon HD 4670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9488
Revision ID: 0x0000
ROM Revision: 113-B8030C-253
EFI Driver Version: 01.00.367
Displays:
iMac:
Display Type: LCD
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: OS X 10.9.2 (13C1021)
Kernel Version: Darwin 13.1.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 20:50
I face the same problem "" Failed to start Diablo III Launcher.""
pls let me know how to solve tis problem, Thanks
same problem.

After launch "Diablo III setup.app", I confirmed that can boot on my MBP.
But even though, I met same error with usual "Diablo III Launcher.app".
Guys, the check the stickies. A solution for this was posted two weeks ago.

http://us.battle.net/d3/en/forum/topic/12674389999

Join the Conversation

Return to Forum