Game not responding at startup

Mac Technical Support
Hi, I have the late 2013 Macbook Air - Haswell i7, 8GB RAM, HD5000 and 256GB SSD. I bought the physical version of both SC2 and D3 and both games crash or stop responding at startup. For D3 upon launch, it gives me the D3 ROS logo and then the screen goes dark with the cursor changing as if it would start the game, but then it stops responding and just sits there processing and I have to force quit.

Ive tried repairing permissions and also launching from another admin account which displayed the same problem so I dont think the issue is with permissions. Ive also added D3 to exclusions list on firewall as well as avast antivirus. Ive also tried deleting battle.net and blizzard folders on /users/shared without luck. Ive also tried disabling launch applications.

One thing is that I cannot find the blizzard folder in the application support folder but if I manually insert it then it opens; however, the only file that is in it is D3Prefs.txt. Should there be any other files in there? There are also no com.blizzard files in Preferences folder. Should there be any?

I had pretty much the same issue with SC2 when I bought it and no response from support which was annoying. Spent hours reading and trying different solutions on various forums. Then thought maybe D3 would work, but no :( I would just like to play. Can anyone please help?? It would be greatly greatly appreciated.

Computer details:

Hardware Overview:

Model Name: MacBook Air
Model Identifier: MacBookAir6,2
Processor Name: Intel Core i7
Processor Speed: 1.7 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 8 GB
Boot ROM Version: MBA61.0099.B04
SMC Version (system): 2.13f7
Serial Number (system): C02LH2DWF6T6
Hardware UUID: EB92E2D9-763B-5B22-BDF7-4FE57FE2A0C3
Is there any other information you need?

Join the Conversation

Return to Forum