"Failed to start Diablo III launcher" error

Mac Technical Support
Upon installing patch 2.0.5 and restarting my computer, I am unable to open D3 from its app folder ad receive the following error message: Failed to start Diablo III launcher.
Same here. On an iMac. Tried from both the launcher and the finder folder itself. Neither work...
Me too: "Failed to start Diablo 3 launcher". (iMac)
Same with me neither launcher is working for Mac. The application "Diablo III Launcher" can't be opened. -10810
I get the same error.
Same error
I launched the battle.net app by going to Applications/battle.net. The app launches fine, however when I navigate to "Diablo 3" inside the Battle.net launcher, instead of the option to "Play" it gives me the option to "INSTALL". I'm seriously hoping my entire D3 client has not been corrupted by this patch. Re-downloading TWENTY-FIVE gigs is, I'm sorry, not an acceptable option in my mind. Blizz, please address this ASAP. Don't leave us Mac users flapping in the wind on this one.
Having the same issue.
Me too
Same here... WTF??
...
For now there are few work arounds...(either by launching the battle.net app in the applications folder or, if you have other installed blizzard games, launch the Blizzard launcher through SCII, WOW or Hearthstone).

Check out the forums.

Best Regards

/Draven
I have the same issue as of now. Running on the latest macbook pro.
same issue. 10810 error

Nothing was done since last play about 20 hours ago, even I didnt reboot my computer for these 20 hours. when playing again tonight, the error occurs

workaround for me, to start launcher by using SC2's one
an alternative workaround if you don't have another blizz game to open the batte.net launcher is to open the Terminal application and run the following command:

open /Applications/Battle.net.app --args Client.DriverCheckEnabled=false
Same problem here "failed to launch Diablo III launcher".

Opening Hearthstone or using the command as provided by willadelph will start the Launcher successfully, but I can't open it via the Dock or Finder.
Don't freakout... there is a patch coming and you won't be able to play till 11:00 AM PDT anyways. but if you really have to get on lol just follow the steps provided by @willadelph it will work like a charm.
Try this it's work for me

Open the folder that contains Diablo3
- Find Diablo III launcher
- Right click "Diablo III launcher" and click "Show Package Content"
- Enter "Contents"
- Click "MacOS"
- Then "Diablo III Setup"

The terminal should be open after click it.
wait and the B-net should be opened itself

Hope it work with you guys.
Thanks Califax. Why Blizzard can't get a game that works properly anymore is beyond me. Every patch just makes it harder and harder to use it seems.
Hey all,

Thanks for the report on this. I'm sending this up to the right teams for review. I'll post back when I have more information available.

Join the Conversation

Return to Forum