Creating Game Help

Aus/NZ General Discussion
I haven't been able to play for days... is there any known issues with D3?

I can log in... get to hero screen.. change level/hero/quest etc... select start game and it goes to the D3 logo screen and just HANGS!! I have tried logging in thru the AU server direct with no success. Help a girl gamer out ... tell me what I'm doing wrong. :(
I am also having the same problem.
Since doing the latest update I have had this problem on and off. I was fine yesterday but cant create/join a game today.
I have set up a manual connection to the AUS server with still no luck.

The biggest bummer is I can connect to the asia server and play without a problem but all my gear and characters are on the US server.
Couple of things.
Have you tried deleting the Bnet desktop ap & re downloading it ?
or Have you tried this ?
https://us.battle.net/support/en/article/deleting-battlenet-files
Onimaru .... yes I have done both of the things you have suggested. Still no improvement. I can sporadically log in, and have been able to play once in the last 5 days... the rest of the time the game simply hangs.

No closer to a solution .. so would really appreciate some help.
Sorry but that's about the limit of my troubleshooting skills.
Maybe hop onto the tech support forum.
Hope you get it sorted soon.
i would suggest posting in the tech/issues area or submitting a ticket to blizz.

hope you get it worked out

Join the Conversation

Return to Forum