Issues with Updating PS3

Blizzard Archive
Greetings adventurers,

[UPDATE] (8/11) - Patch 1.0.4 is now available in all regions.


[UPDATE] 1:20 PM PDT (8/7) – Patch 1.0.4 is now available for PlayStation in the Americas region, which addresses the console freezes that have been affecting some players. SCEE (Europe) and SCEJ (Japan) will also be patched; however, the patches for those regions will be rolled out at a later time. Please note that Xbox will not be receiving this patch, as the issue only affects PlayStation users.

If you continue to experience any issues after downloading and installing the corrective patch, please update the thread. Thank you!


[UPDATE] 11 a.m. PDT (8/6) - Thanks everyone for your continued patience and for helping submit the requested information! With your assistance we were able to track down the issue more quickly, and believe that we have now established the cause of the issue. As such, we are currently working to resolve this with a minor patch - although we don’t yet have the exact ETA for when this patch will be pushed, we don’t expect it will be too much longer from now.

We’ll return to the post with further updates as soon as they become available.


[UPDATE] 3:45 p.m. PDT - If you are continuing to experience issues with Diablo III freezing up after having installed the latest patch, please respond below with the following information:

  • Make/Model of router
  • Is UPnP enabled on the router: To determine this, please refer to the instruction manual included with the router for specific instructions.
  • Is port 3074 forwarded? - To check this, please visit the following page and select your router and then Diablo III for your appropriate console.
  • Please also let us know whether there are any other game consoles on the same network.

Thank you for contributing this information! We will continue to update the thread with more info as it becomes available.


Today a new patch was released for both PlayStation 3 (25601) and Xbox 360 (25238), which lays the groundwork for us to allow character exports between current-gen and next-gen console platforms. Although some players have been able to update just fine, there are reports from others that the game is locking up on the PS3.

We are currently investigating the issue, and will be sure to update you as soon as more information becomes available. In the meantime, you may want to try the following troubleshooting step which was offered here.

1. Sign out of PSN and launch the game -- OK
2. Click more options and select export save -- It'll prompt you to sign in, do that, you might get an error that says the diablo servers are busy, (this may take several attempts).

Thanks to Regor for the assist, and to everyone else who is currently affected for hanging in there.
Strange I got that message and can play just fine

Guess i'm just awsome :P
Except, make sure to sign out of PSN AFTER you go through that step, as in 3 different tests, leaving youself signed into PSN and qutting to main menu hung my system all 3 times.
I never removed myself from PSN i even played for 2h after the update with other people lol
Lucky you. Not all of us can.
Had to sign out of PSN in order to play. Bummer that I can't play online right now. Please let us know when the "freezing/hang" issue is fixed. Thanks.
It might also depend which model of PS3 you are using. I have 2 super slims, it works fine on the one bundled with the 500G hard drive but fails on the 12G model upgraded to a 500G drive.
I do not have access to a comp atm, this is from my ps3. I have a 120gb Slim, not super slim here. Can't check routrt info from here. Really though? Port forwarding for a console game in 2014? Come on now! My game ran fine always logged in on PSN until THIS PATCH. While I can't say for sure, I am pretty sure all the proper ports are forwarded and UPnP SHOULD be turned on. Game runs fine UNLESS on PSN, then constant hangs at character load. At least it's not asking for me to update my save data now? It still hangs at character load though, so nothing accomplished.
i updated the 1.03 patch right after i got the 1.02 and the moment it was signing on it froze. tried about 9-12 more times and then gave up. took the ethernet port out and i can play offline just fine.
The only difference i did from you all after updating to 1.03 is exporting my character

then i logged in
Router = Asus AC66U
Hooked up to a Linksys gaming adapter via cat 5, and using the DS4 via usb.

I have the gen 1 core updated with a 320gb HDD.

I also have my accounts linked and PS+.

It looks like UPnP is enabled but unavailable.
Thanks for the workaround
Tried everything. Even contacting playstation and still getting the same results. I have all 5 characters to bulk up and I can't do anything but watch my game freeze up. HELP!!!!!!
I was having the same issues, but got it to work using this method:

1) sign out of psn
2) start up the game
3) do the update if you haven't yet for 1.03
5) select "more" then "export save"
6) now it will prompt you to sign in to psn, sign in
7) a message will pop up saying that it's exporting, but will probably fail to connect to the server. This is fine
8) press triangle to change characters, and then just hit circle to return to the previous screen
9) select "more" then "export save" once again, and this time it should go through successfully.

Don't ask me why this works, but I tried a few combinations of everything until this finally pushed it through. It could've been coincidental that the server happened to be back up at this time, but I would just follow the steps as written above. Not signing in until you are prompted to, in the game itself, stopped the freezing issue completely.

After you successfully export the save, I would sign out of psn before doing anything else to avoid further freezes and crashes. No online play, but you can still play offline until the problem is resolved. Good luck, I hope this works for everyone
Hopefully this helps others. I'm on PS3 and ran into the same issue. I could mitigate using the log out from PSN, open Diablo, do the character save push, and play over LAN. However, if I tried switching my network settings in the game to anything online it crashed again.

I followed the link the Blizzard admin suggested for Diablo 3 port forwarding settings, and opened up 80, 1119, 3074, and 6881-6999 on my router, for the PS3

After that I repeated all the original steps (logout of PSN, etc ), but switching back to online mode did not crash me out. The port forwarding fixed the issue, and I can play online just fine. Good luck!
I tried the steps and I can't get past the start screen. Its frustrating. I'm completely stuck and I'm going nuts. So now what???
I had to disconnect a forwarding protocol for xlive (thinking a controller on another pc, as we don't HAVE a 360 in the house) to be able to forward port 3074, but now it works. Pretty unamused that I needed to manually configure my damn ps3 for an ip, and port forward it just to be able to use psn properly while playing this, and would really prefer to change my settings back once you have this fixed. No question now, that port issue is what was hanging D3 on my ps3.

Join the Conversation

Return to Forum