PS4 Issue: Cannot connect to any online games

Console Bug Report
Prev 1 2 3 4 15 Next
There is absolutely no support for this game. I can't even submit a ticket, and Microsoft says submit my problem to blizzard.

This has been an all around horrible experience my first time buying a blizzard game.
Going on day 3 and still unable to play with anyone on the Xbox One. And the problem seems to have gotten worse. People on my friend's list that were able to play together on day 1 were unable to play together yesterday. I think we all played solo because no one could connect to anyone. Would be nice to at least know they are working on a solution.
Yeh I'm uk having the same problem thought it is my fault but it's not there's no way to search for ppls games to join online on ps4 I set my network on diablo to (open to public) then I just start game no option to search for other online players I can go hours into game without having no online players joining my game as I can't search for one to join so I don't know if everyone is having this problem because after a few hours someone does join how I don't know all abit confused he seems like unless there not in your friends list you can't join any game this no (search for an online game to play) any help would be great thanks
Also on the higher difficulty games you need to be in groups kinda stopped me in my tracks abit
My only solution so far is to plug my PS4 directly into my cable modem. My connection goes to NAT 1, and I can join games.

However, then we have no wifi in the house, which doesn't go over so well with the wife...

I have done port forwarding, I have set my PS4 to use a static IP and placed it in the DMZ (outside of the firewall). I have even just completely turned off the firewall.

All of these things do not fix the issue.
Well untill they add the option join a party I can't join games in the mean time add me so I can join psn xlukeyx89
Yup i've never NOT been hard wired when i play. I still has the same issue. It's been about a year for me. (ps3 version of original D3 had the same issue.)
Wow 3 days and not even acknowledged by "support"
Hehe yeah its like a whole "Go ask your mom" "Go ask your dad" "Go ask your mom" (etc.) situation between sony/microsoft and blizzard.
You have the right idea. I believe it's a DNS problem. Hook your ps4 straight to modem get the DNS. Hook router back up and change the DNS of the router to the one you wrote down. I did this and havnt had a problem since...Or try google dns server
Hi Everyone,

This question is for PS4 players specifically: Could you please post what brand and model router you are using? I notice that a few of you have been able to connect and play in multiplayer games by bypassing the router and connecting directly to your modem. When you reply, could you please also let us know if that is working for you as well?

There is a separate issue with Xbox One connectivity, and that issue is currently being actively investigated and any new information we have to share about that issue will be posted in this thread. Again, the information I am seeking here is related specifically to players having issues connecting to multiplayer games on PS4 only.

Thank you!
Netgear Wireless-N 300.
I have also done port forwarding and placed my PS4 on a static IP in the DMZ. I'm still unable to connect to anyone.
When i directly plug my modem into my console it works, but disables my wifi and opens up the firewall to everything including my phones console and computer. So extremely dangerous.

My router is : "Belkin G wireless router"
Model #: F5D7234-4-BC V1
Belkin N wireless router
Model: f5d8236-4 v3
I'm having this issue using a Belkin F9K1002V1 and I know there is some hiccup between your game and my router because it does in fact work straight from the modem. Here are the steps I've gone through trying to fix this on my own:

-deleting and reinstalling the game
-restoring licenses
-checking the update (I'm updated to the current 1.02)
-hardwired my PS4 as opposed to wifi
-changing in game region settings
-I was only running my PS4 on my network
-I only have one PS4
-nat type: type 2
-15 mbs dl, 3 upload
-checked router settings, UPNP is enabled
-I even resorted to port forwarding and creating static IP address
-placing the static IP in the DMZ

My results are the same as everybody elses: I can join the main menu with friends, but after a few seconds they see me drop out. A few seconds later I see them drop out. If they launch the game, they get in but I see an infinite loading screen. If I join their game I get that same infinite loading screen. I tried a quick match with the same results. If they join my game, they get an error message.

Please fix this! I want to play with my friends!!
Belkin N150
F9K1001v1

Random that we are all using Belkin routers?

I have tried port forwarding, setting my PS4 static IP to be in the DNZ, and I have also set my DNS manually to match what my PS4 reads when it is directly connected. I have disabled the firewall, and tried various other methods.

Nothing works.
I can join friends games and quick match games without issue, but when I set my game to public, I have yet to have someone join my game. I've had it set to public from level 1-30, playing mostly on Expert but I did set it to Hard shortly to troubleshoot this issue.

Setup:
My PS4 plugged directly into an Airport Express via ethernet cable then connected to my Airport Extreme wirelessly. UPnP is enabled and my PS4 shows Type 2 NAT. I normally do not have any issues connecting to anything with my setup.
Although my friend has an Xbox one, I can confirm that bypassing the router also solves this problem on the One. He has a Belkin n300 router.
I have a PS4. Belkin N300 router. I am using a Lan Cable. NAT Type 2. Using a Dynamic type.

Join the Conversation

Return to Forum