Battle.net Account Link Issues

Console Bug Report
Prev 1 5 6 7
I still have this problem, can i have a heads up when it's fixed?
Really old thread, but I found a fix, at least for xbox. Try doing it through the game itself instead of the battle.net website. Or, if you can't find a way to do that, try it through microsoft edge. Seriously, worked on this for hours, but I got it to work. I hope anybody still viewing this thread sees this.
05/11/2017 07:02 PMPosted by tellub74
Really old thread, but I found a fix, at least for xbox. Try doing it through the game itself instead of the battle.net website. Or, if you can't find a way to do that, try it through microsoft edge. Seriously, worked on this for hours, but I got it to work. I hope anybody still viewing this thread sees this.
Still going on in 2017
I was able to go in and connect my PSN account. I just did this, hope this helps you guys too.

Log in your battle.net account and click the link PSN button. Notice that it will not go through and will take you to a white page that is not loading (no loading icon on top left). Do not exit or press back, just wait for at least 3-5 mins., and then press triangle to refresh the page. Now, it should show the loading icon on the top left. Wait for it to load and it will then tell you that the page is taking too long to respond. Just click the ok button, and you'll see an error message on the white page, press triangle to refresh it. It should now take you to the PSN log in page. Just log in, follow the instructions and it should say you've successfully connected your account.
Im having the same issues its all linked and connected but no item anywhere to be found =/ i loved D1 and D2/D2 lod now D3 and D3 ros and i was gona upgrade to a xbox one soon and upgrade my ros for it but at this rate im never gona buy a blizzard game agine with lack of patchs for old systems and lacm of support and caring its all about the money to them now =/
how do I even link my account I cant seem to find the link to do so
cant see my profile its showing that its unavailable due to inactivity but i play daily.
UPDATE:
Finally found that console players are very limited/restricted with forum posting. A PC license is required to post in most forums. This seems quite unfair to the console player, and I would hope that this could change. I'm guessing that the profile issue is related, as it is probably looking for a PC profile, and does not see the console profile.

2019, and still a problem. Linked through XBOX Live account and showing as connected. Same: profile is showing as unavailable due to inactivity. I can only post in Console Bug Report and Console Discussion, but in every other Forum subject, it states that I am not authorized with a "Starter Edition". Blizzard, please help!!?
I can not go into adventure mode it sez I've unlocked it but gliches me back into act 5 over and over ????

Join the Conversation

Return to Forum