The application has encountered an unexpected error.

Technical Support
Prev 1 13 14 15 26 Next
same issue plse fix D7B542AB-B599-4B4F-9594-1C6CE7DAF436
E49DF940-BC84-4A09-9CFF-01B82E961314
Same thing happened to me. I cannot login to battlenet
CA1C2B49-2194-4EFB-BFE9-6FB49AC92421

issue back again.. please help
Okay, I've tried all the suggestions given- this is on your end, not mine. I can reinstall the game and battle.net and it works for a while, then if I turn it off and try to play it again, the same stupid error happens. I've had no problems reinstalling, and I've done so twice at this point. I've tried disabling my firewall; I /thought/ that was the issue, but just now when I tried to play it wouldn't work. I tried adding to the exceptions list of the firewall, also no-go. I'm now reinstalling again, which seems to get around the problem at least temporarily. PLEASE find a fix for this that WORKS, because I really don't want to have to reinstall the game every time I want to play!

I'm on an Alienware 15 laptop, C drive is just the OS, everything else is on the D drive. I have more than enough power for the game, and until about a month or so ago I never had issues.
Hello i think i'm having the same (the application has encountered and unexpected error) I can't play any Blizzard game :( this is the code i get 73003A9A-EEE9-4FB4-96C9-87B14555455E
0928DF4E-BBC0-4128-874E-8784A2F4510C

I am having the same problem as well. Tried to fix it on my end, it is not working.
5A029B3B-E711-4AC3-BF0D-71784AD0C241

Updated everything, left it open, no issues. Closed it and attempted to relaunch and this everytime when the bnet app tries to open.
blizzard error
the application encountered an unexpected error

0417D27D-C56C-4DAF-B57D-E851C4B45055
Everytime I get to a certain point in the Blood and sand quest the game crashes

20C7E84F-B8E8-438A-A963-D8724FCFD46A

7642CD87-D512-421E-97B8-06252D3F42E3
65EA1BA3-C235-41FF-9F40-AA43A60A8468

same Oooooooo issue.. help please
11/26/2016 07:01 AMPosted by BlackOO
65EA1BA3-C235-41FF-9F40-AA43A60A8468

same Oooooooo issue.. help please


8ED1FB9D-7AEE-4869-8803-53E02AC4364C
try Disable or temporarily uninstall any security programs , i do it it fix
Hey everybody,

Just as a reminder, if your Battle.net application is crashing on startup, this is most likely a known bug which we are aware of and working on. If your Diablo III is crashing after you try to launch it from the Diablo III shortcut (which would usually launch the Battle.net application) it is probably this as well.

This isn't the long-term fix we want for this, but the only reliable work around we have right now is uninstalling and reinstalling the Battle.net Application on your C:\ drive. This should allow you to launch the application and the game successfully. If you try this and it fails, you're probably having a different issue and should start your own thread. This will help us keep the troubleshooting straight.

Edit: clarified that not all of these crashes are the known issue, though a large majority are.
I had the same problem until just now. I went to my battle.net file, deleted a file called Error (few KBs), then ran Battle.net as administrator. Worked like a charm :)
11/27/2016 01:17 AMPosted by Purestr
I had the same problem until just now. I went to my battle.net file, deleted a file called Error (few KBs), then ran Battle.net as administrator. Worked like a charm :)


This fixed mine as well. Delete the file called "Blizzard Error" and run as admin. Opened right up.

Nice one.
The above solution from Purestr has worked for me aswell. Thank you!
117584B6-A54F-4B82-9462-704FDE5616F2
same error, please reset my account if that fixes things
Dank,

85EFFEF5-8EB4-42EC-A273-36C976CE273B
can i get help?
11/26/2016 01:38 PMPosted by Drakuloth
Hey everybody,

Just as a reminder, if your Battle.net application is crashing, this is a known bug which we are aware of and working on. If your Diablo III is crashing after you try to launch it from the Diablo III shortcut (which would usually launch the Battle.net application) it is probably this as well.

This isn't the long-term fix we want for this, but the only reliable work around we have right now is uninstalling and reinstalling the Battle.net Application on your C:\ drive. This should allow you to launch the application and the game successfully. If you try this and it fails, you're probably having a different issue and should start your own thread. This will help us keep the troubleshooting straight.


Few days ago ive done that and reinstalled Battle.net, but after few days it started to crash again :/

Join the Conversation

Return to Forum