Error 3007!

Technical Support
1 2 3 10 Next
What's going on with the server? I got this error now 3x of code: 3007! I've always kicking me out of my room game!
ugotowned,

Let's try power cycling the connection.

Here's a support article with steps on how to do that:

Resetting Network Devices

If that doesn't work try flushing the DNS.

Let me know what happens.
______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
I've tried doing that, it doesn't work. I was kicked off for about 3 hours and let back on, and got the 3007 message after that.
By the way, I can't log on again. My roommate did something and said the problem was in Dallas.
Sorry, but it doesn't work when I've tried it just now :(
That's only happened when I play rifts.
ugotowned,

1. What security programs do you have installed?

2. Let's try running a selective startup to see if that helps. Please be aware that running while in this mode can potentially disable any security programs you may have running.

Here's a support article with steps on how run the selective startup: Closing Background Applications

______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
Hello,

I am currently having problems maintaining a stable connection to Blizzard’s Battle.net servers when using my current Comcast modem. S/N:266579766

The game that I am experiencing problems with is called Diablo III. I get error code 3007 (Your connection to the Battle.net service has timed out. Please log in again.) then get booted out of the game. This problem occurs intermediately.

Here are some other facts. When I get booted I am still connected to the internet so services like skype are not interrupted. I can also relog back into the game right away.

I tried two other Comcast certified modems and they had no issues with this game, no disconnects. When I returned back to my current Comcast modem, the disconnections continued to occur. It seems to be a hardware setting issue.

Has anyone experienced this issue and found a solution?
Shawmeck,

The OP's issue is not resolved. Please start your own thread so that we can assist you individually.
______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
There's no solution yet with Error 3007. My internet is ok and I got 100 mbps TWC connection. I've also experiencing to be booted during Season 1, but it's gone during that time but now at Season 2, the Error 3007, back!
ugotowned,

1. You still haven't told me what security software you have installed?

2. Did you try running the selective startup that I previously suggested?
______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
Oh sorry, kind of busy here...I have McAfee Total Protection installed here.
Will do try running the selective startup on Sunday.
ugotowned,

If you are willing to try, I would temporarily uninstall McAfee. I know you don't feel that's the cause of this issue, but doing so will at least help us rule that out as a possible factor.

If you would like to try that, you will want to use the McAfee Removal Tool to ensure that it's removed properly.

Here's how to download the tool:

1. Download the McAfee Removal Tool.
2. Click Save and save the file to a folder on your computer.
3. Navigate to the folder where the file was saved.
4. Make sure all McAfee windows are closed.
5. Double-click MCPR.exe to run the removal tool.

NOTE: Windows Vista and 7 users must right-click MCPR.exe and select Run as Administrator.

6. Restart your computer after receiving the message CleanUp Successful.
Your McAfee product will not be fully removed until the system is restarted.

Let me know what happens.
______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
OK I just finished my test just now & it looks like OK. I never drop for a few runs in rifts not unlike recently. But I don't want to run my PC without any anti-virus. :(
ugotowned,

If removing McAfee seems to have helped, you have two options. You can reinstall McAfee, and contact their support to ensure that it's set up properly so that it doesn't interfere with Diablo III, or you can try a different security program.

If you want to try another program, I'd suggest checking out Microsoft Security Essentials. It's free, and it works well with games.
______________________________________________________
I'm available Sunday through Thursday from 11AM to 8PM Pacific Time
Support Contact Information

Got some feedback?
I re-install the McAfee and play twice without kicking out of the game last night...will continue to do this, if the problem return then will try your suggestion.

Thanks for your time.
Still NOT working, even that free Microsoft Security Essentials is still not working :(
I think this is not in our sides since some of players are also experiencing with the same problem. These only happen to me twice now starting from season 1 but it's gone due an updated patch, but now in season 2, the problem return again.
I got this error too. It usually happens when I lag a lot. But today I had just entered the game, was doing trial for a grift and had zero lag then I got disconnected. Error 3007.
This is a very recurrent problem right now. I'm having this since the new season has begun.
No new software installed, internet based stuff working just fine (zero lag for netflix or other games).
Of course that this is nothing related to client-side, most likely server-side problems.
This is so "buggy" that, the client says you're disconnected, however you're able to move and cast spells just fine.
BUMP! Keep getting kicked out playing the new season. What a waste of time and keystones...Blizzard fail once again.
Well, still not fixed. Getting DC all day long today.

Join the Conversation

Return to Forum