D3 PTR Not Working On Mac

Mac Technical Support
1 2 3 7 Next
Updated the latest Mac OS, then later today updated the PTR... Try to run PTR, and get "Diablo 3 detected corrupted date, please run Scan and Repair..."... so I did, and it check the files.. unsure if it detected anything...

When I try to run PTR again, I get the same message... NO GO on the PTR for me now..

Macbook Pro fifteen inch, retina.. mid 2012 model with discrete graphics chip..
GondorNative, can you collect some Battle.net Logs and email them to our Battle.net Quality Assurance team? If there's a bug with installation/maintenance I want to make sure we capture it and get it tracked.

Once that's done, try uninstalling the PTR client and reinstalling. Let me know if this resolves the issue.
______________________________
Technical Support: Monday-Friday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
Hello. I've got the same error. MacBook Pro (Retina, 15-inch, Mid 2014). OS X 10.10.3 (14D136).
Trying to reinstall.

Sent email with logs.
Done.. thanks for your prompt feedback..
Im having the same issue.
Scan and repar 3 times. Didnt work.
Fresh Install. Didnt work.
As the Europeans do not have a propper Mac Support I need to try my luck here :)

Got the following message after updating PTR. I´ve also run the Scan & repair function as written but no luck to get the game running.

http://www.img-host.de/bild.php/56275,bildschirmfoto20150630um224112V59D5.png
ditto

Model Name: MacBook Pro
Model Identifier: MacBookPro11,1
Processor Name: Intel Core i5
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 8 GB
Boot ROM Version: MBP111.0138.B14

Scan and Repair noted nothing to fix. Reinstall did nothing.
Also had the same problem, sent email with logs as outlined.
It's a no-go after Deletion and re-install of the PTR..
Thanks for the information, everyone. Running this by our Mac and Battle.net teams!
______________________________
Technical Support: Monday-Friday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
yup it just flat out will not work on mac right now
Same problem here. Already reinstalled fresh, repaired disk permissions, restarted. No joy :(
Please fix this blizz, already behind the group for queuing up, frustrating. Blarggg!

Im being hung on this one too.

Tried scan and repair, gave up from it not working, trashed old PTR, downloaded newest client, getting same error.

It runs scan to the end fine, never states repairing, restart game,
same error, corrupt files, need scan and repair.

Frustrating bug.
Same issue here. Scan/repair says everything is fine but the PTR won't launch.
Same problem, Mac 15'', late 2013 model. Corrupted data.

Uninstalled twice (once the PTR game, and once PTR + client)

Also when I logged on to the loading screen yesterday, my mouse started jumping around the screen, some bug that was introduced at a earlier batch.

PLEASE FIX. This is really annoying.
Got some additional information.

Our Development team reviewed the issue and we have a potential resolution ready. It should be included in the next PTR build. Since it's a Public Test Realm I don't have a ton of additional information in regards to timeline, but should I receive any new information I'll be sure to update this thread.

Stickying this for now for visibility.
______________________________
Technical Support: Monday-Friday, 12pm - 9pm Pacific Time
How am I doing? || Support Agent Feedback ||
ETA?
Would appreciate if it would be asap. As PTR buff is the best time playing Diablo ;)

Thanks for your quick response and have it taken care of.
Cheers
I have the same problem :(.
Unable to play and can't be hotfixed, this is annoying.
I wish they would try and load it on a Mac before these things happen.

Next build?????

Blarrrrrggggg!

Join the Conversation

Return to Forum