Act V Bounty: Touch of Death

Bug Report
Searching around it seems this bug has been around a very long time. :|

I was running bounties on my demon hunter I'm quickly levelling and when I got to "Touch of Death", I searched around for the medical camp and the event began.

It spawned two punishers and the objective changed to "Kill the Punishers". I killed them very quickly, and nothing else happened.

According to the wiki I found it seems more punishers are supposed to spawn, as well as more dialog indicating more are coming. These events were never triggered and I instead got to stand around doing nothing while I looked up the bounty. I ran around and killed a bunch of other mobs on the map but nothing ever advanced the bounty event.
Hi,

just had Bounty: touch of death as well,

2 players in the game doing the co-op achievements. cleared the whole zone no reapers or medical camp showed.

2.3 patch is live I did it on

no helpful arrow showed and as the whole zone is revealed and the actual medical tile is not even to be found.

went over the whole zone 4 times to ensure it.
Same here, have the bounty, but the event is nowhere to be seen.
Still bugged, event does not spawn.
same problem to mee too.
I just ran into this too.

I have the bounty. I have cleared the entire zone and run around it several time. No event or arrow to the event ever showed up.

It was my last bounty of the set. Pretty frustrated I have to start over with no reward.
Touch of Death Bounty - Can't complete. Cleared everything and walked through the area numerous times. No monsters left and no medical camp or arrow or opportunity to finish. Can't get the legendary crafting materials because I can't finish this quest. spent 1 to 2 hours and did this as my last bounty in Act 5. very frustrating.
Same happened to me.
No arrow, no help on screen. I looked at a video completing the bounty and realised I've killed all the mob at the "medical camp", No mobs spawned after the 1st wave of punishers !
Same here. Cleared the whole map and no medical camp / arrow appeared.
Happened to me
Same problem, no arrow, no medical camp on map.
Same!
Same here!
Same here. PLEASE fix!!!
I got the same problem today, it have not medical camp on the map
Same here, bounty never spawned. Cleared whole map.
Same, still broken.
I can't find it anywhere on the map. Could you at least disable it . . . . can't get the cache with it not working . . . .
I ran the whole map five times, cleared any mob but nothing. I can't get the cache. Very frustating
Don't you have regression tests! It is not the first time a bug is reintroduced with a new patch...

And full murphy's law: Always the last bounty of this lame (for bounties) Act V that is bugged. The second time it happens to me.

Join the Conversation

Return to Forum