Performance Issues on PS4 since Patch 2.4

Console Discussion
1 2 3 15 Next
Hi, everyone,

I have D3:UEE on a new PS4 (CUH-1215A model), recently purchased. I am in North America.

Under the last patch, 2.3.0 (which was the first patch I ever had), the game ran smoothly, no issues whatsoever, be it Adventure Mode Torment 1 through 4 single and multiplayer.

After downloading and installing the latest patch, 2.4, my game experiences the following:

1. Noticeable Micro-stuttering/frame lag walking around New Tristram or other towns. Difficulty: Torment 3.
2. Noticeable Micro-stuttering/frame lag walking around and fighting in Adventure Mode in the Expanded Zones. Difficulty: Torment 3.
3. Lag in menus and when buttons are pushed.

I have experienced these issues on two different play sessions.

To resolve the issue, I have tried to:

1. Turning off the PS4 and turn it back on.
2. Resetting.

The issues still persist. While the issue is tolerable in town, during combat it is very frustrating.

Blizzard, please review. It seems users across both consoles and PC are also experiencing similar issues.

Thank you.
DW
I see the reports of the issue but I never had it at all and I was on my PS4 on D3 for hours yesterday...curious.

What region are you?
Give it a weak, I recall 2.3 being shaky for a week or so.
It's noticeable right away. It just doesn't feel right.

Any word from Blizzard?
Yea ive been getting lag and framerate drops since this patch. Maybe test and see if it does it when you play not connected to the internet
Hi,

I'm in North America.

This morning, I tried again, noticing Sony dropped a system update (3.15).

After this update was installed, thought this would help, but issues with D3:UEE persist.

It's odd and unfortunate.
I'm in the EU and have zero issues.
01/13/2016 08:45 AMPosted by Oceanbuffalo
Give it a weak, I recall 2.3 being shaky for a week or so.


Exactly
Yeah I have the same issues - lag, fps drops, button delay, screen tearing etc

It's a lot more noticeable in certain zones, which might explain why some people haven't noticed anything yet.

If you want to test it out, go to a big outdoor map like southern highlands and vault around on demon hunter - it virtually comes to a standstill sometimes. It seems to get bad when moving quickly through the map, like with vault or monk dash. Walking around slowly it's certainly not as bad.

I hope this will get addressed, as it is spoiling the enjoyment of the new content quite a bit for me :(
I notice it too. Its just very slight though, almost like I am having very minor internet lag. It really isn't bad enough that I lose and enjoyment though. Like another person said before...Give it a week or so and it will be back to normal.
Why would give it time help? Is not an online issue or server issue, it happens when playing solo and I bet it happens if I unplug my PS4.
Thanks, everyone.

I'm not sure how time will resolve it. Unless it's linked to the game needing online connectivity, like Destiny, and due to its launch, the server is handling an inordinate amount of requests as people download and install the patch.

Or maybe it's because they will apply some sort of hotfix?
It's not a server issue, since the problems persist even when not connected to the internet. I'm sure there will be a hotfix or two, and hopefully they will iron out these performance issues
01/13/2016 12:10 PMPosted by Badger
It's not a server issue, since the problems persist even when not connected to the internet. I'm sure there will be a hotfix or two, and hopefully they will iron out these performance issues


Yeah in time a hotfix will be applied. That is what I should have said.
Yes, I certainly hope so. Keeping this up, so it's noticed by the Moderators.
Just played for 3 hours, not one issue...EU seems to have no issues thus it can't be a coding/firmware.game isssue...must be something online based.
I'm EU and have the above issues, and i've tried online and offline - both are affected.

Just to clarify, are people who are saying they're having no issues trying high torment rifts?

From playing tonight, it seems greater rifts are ok, but normal rifts, especially in outdoor maps with high density, are the worst.

I even had rubberbanding where my character literally went back 2 seconds, not even connected to the internet.
I'm having the issues by playing bounties solo.
01/13/2016 03:08 PMPosted by Badger
I'm EU and have the above issues, and i've tried online and offline - both are affected.

Just to clarify, are people who are saying they're having no issues trying high torment rifts?

From playing tonight, it seems greater rifts are ok, but normal rifts, especially in outdoor maps with high density, are the worst.

I even had rubberbanding where my character literally went back 2 seconds, not even connected to the internet.


I run T10...did bounty's...did rifts and did a few GR65's...no issue whatsoever.
That's really weird. Could the differences in experience be due to different classes perhaps? Maybe certain class skills are causing it? I dunno, I'm a bit baffled.
-
edit: on second thoughts, that wouldnt explain the menu lag - there's even a second or two delay after pressing start game before you hear the sound - definitely something not right overall

Join the Conversation

Return to Forum