constant disconnects

Technical Support
Prev 1 4 5 6 9 Next
always getting DCed never can play the game I guess this is how Blizzard controls the leader boards I bought the game to play it not get DCed everytime I get on
MVP - Technical Support
Posts: 2,021
View profile
Look man, I can't do anything without seeing your information. Even if it IS blizzard's fault - how will I, a non-blizz employee who can't look at your equipment, tell that it's on blizzard's end if I can't see information from your side? Blizzard can't be asked to run diagnostics on everyone who is connecting to them (the technical term for such an action would be a denial of service attack).


Blizzard knows well and good that the problems are on their end. They try to blow off people with that BS about either our PC settings or by putting the blame on their ISP.

It's nice that you're willing to help people - but dude...read ALL the posts about the disconnects, 3005's, 3007's (all the same problem) as well as the lag/latency problems. See a pattern?

Blizzard: Run these tests on your pc and post the results here please.
Player: Obediently posts test results.
Blizzard: (crickets)

I'm a systems analyst (retired) and it's more than plain to me where the problems are. They had the same problems with D2.

If you'll ALSO take a peek at the other game forums (WoW, Overwatch, Starcraft, et al), you'll see the SAME problems repeating there. So if you had seen ALL that evidence, why would you insult the rest of us by requesting we paste our system information and/or run diags?

It's NOT our computers.

It's NOT our ISP's.

It's Blizzard's problem and they are taking our money without providing the product we purchased. I'm about ready to make it my credit card company's problem and let them deal with Blizzard. I bought TWO copies of RoS to play on my laptop or on my desktop.

Not happy....
Yeah I just tried playing. It's unplayable. Doesn't lag on anything other games.
yup!
Can play world of warcraft for like 4 hours straight without a single disconnect.
D3 = unplayable.
05/28/2016 07:14 PMPosted by Mintropes
Doesn't lag on anything other games.


This is like saying that because there is no traffic on the road going north of you then there should be none on the road going south. The traffic from your computer going to a different game is going through a different physical route, which means different switches, different wiring etc (once it leaves your ISP).

05/28/2016 05:16 PMPosted by BellaDonna
It's Blizzard's problem and they are taking our money without providing the product we purchased. I'm about ready to make it my credit card company's problem and let them deal with Blizzard. I bought TWO copies of RoS to play on my laptop or on my desktop.


I have been hearing this complaint for years. I've been fielding these tech support issues for years. In 80% of the cases it is caused by something in the user's home. 15% of the time it is caused by stuff in the middle - ISP, or peering partners. Maybe 5% of the time is something identified on blizzard's end that is causing lag. But you want to know how blizzard is able to identify a problem on their end? By asking users experiencing issues to post the diagnostics I already requested.

If you want to try to debug your issue I am happy to do so once you post information.
This exact thing has happened to me ever since I *upgraded* my PC! Anyone have a fix for this?
am having same problem,cant find out what code 3007 is,anybody know?
does blizzard care?wont be eager to buy from them any more
This is like saying that because there is no traffic on the road going north of you then there should be none on the road going south. The traffic from your computer going to a different game is going through a different physical route, which means different switches, different wiring etc (once it leaves your ISP).


its more like because you dont see any traffic congestion on the road you are on (running north and south) you expect that there is none on a completely different road running east and west. i think that would be the most accurate statement. like you say different games can take entirely different physical routes to their targets.

06/23/2016 09:09 PMPosted by Kushiel
This exact thing has happened to me ever since I *upgraded* my PC! Anyone have a fix for this?


downgrade your PC. :P

seriously though more explanation is required and it would probably be best to post at least a pathping.

06/24/2016 11:26 AMPosted by lan
am having same problem,cant find out what code 3007 is,anybody know?


start with the support article. which btw, you can find support articles by clicking "support" up at the top of the page.

https://us.battle.net/support/en/article/7500077
I cant even get into a game. its incredible. it use to only effect my seasonal chars. I roll one play for the night, get to level 17 or 20 log out, the next day I get a client disconnect error and I can never log on to that char again. I could only play my old chars. now though... I cant log on to any of them, it cant be me. cant play seasonals but can play older ones? then cant even play those? whats going on? wow plays fine, other games plays fine. when I can get on to my older chars the game played fine. now I cant even log into any of them.
05/28/2016 05:16 PMPosted by BellaDonna
Blizzard knows well and good that the problems are on their end. They try to blow off people with that BS about either our PC settings or by putting the blame on their ISP.

It's nice that you're willing to help people - but dude...read ALL the posts about the disconnects, 3005's, 3007's (all the same problem) as well as the lag/latency problems. See a pattern?

Blizzard: Run these tests on your pc and post the results here please.
Player: Obediently posts test results.
Blizzard: (crickets)

I'm a systems analyst (retired) and it's more than plain to me where the problems are. They had the same problems with D2.

If you'll ALSO take a peek at the other game forums (WoW, Overwatch, Starcraft, et al), you'll see the SAME problems repeating there. So if you had seen ALL that evidence, why would you insult the rest of us by requesting we paste our system information and/or run diags?

It's NOT our computers.

It's NOT our ISP's.

It's Blizzard's problem and they are taking our money without providing the product we purchased. I'm about ready to make it my credit card company's problem and let them deal with Blizzard. I bought TWO copies of RoS to play on my laptop or on my desktop.

Not happy....


The moment you get back here with *EVIDENCE* of your claims, I'll be ALL ears.

You sitting here yapping your piehole about how you KNOW stuff that you cannot and WILL NOT prove is garbage.

We'll ALL be waiting on your proof. All you're going to do is come back (if at all) and run your trap some more. You won't provide an ounce of PROOF.

Mark my words.
I have this problem for over two weeks. dc'd in the middle of rifts and grifts. disconnected from server. I see the complaints but do not see any answeres anywhere. did I miss the answere?
Constant disconnects, mid rift and mid greater rift. That stinks. Why are we even constantly connected vs a more forgiving connection.
hi i am trying to transfer character of D3 to reaper of soul. I have the original copy of d3 and export the character but when I try to import the new option does not appear
i cant login half the time and when i can its just disconnected. only just !@#$in bought this game im soo pissed off. is it possible to get a refund?
Bumping for a fix. Blizz plz halp us
I'm having latency issues as well. It'll go from 90ms - 250ms. I'm Texas. I've played blizzard games for well over 10 years. In WoW I'd get around 65-80ish. But recently in D3 nothing has changed on my end. I've tried everything under the sun and I'm a IT guy. But I see spikes 95 then bump 100ms to 190, to 224, back to 88.
same thing, as outlined in my thread http://us.battle.net/d3/en/forum/topic/20745735735

i can't figure out if it's my ISP or Blizzard;\
50% of the time I can log in fine, but as soon as I try to leave town by any means I'm finding there's about an 80% chance I'll get disconnected right after the loading screen. This has been going on for about two weeks. I should mention that if I do manage to get out of town I'm usually good for a couple hours before it starts up again. No idea what that means, and I'm sure that the issues are being worked on. God speed, good techs. I have faith.
I tried playing after taking time off for about a month. Three times tried a rift and got disconnected. Not gonna bother playing or trying anything until I'm confident the issue is fixed.

Join the Conversation

Return to Forum