60fps but animations and movement looks like 30fps?

Technical Support
I have had this issue since the original beta, the game runs at 60fps without dips but it looks like it's running at 30fps, the characters stutter as they move, and the animations look like they're running at far less than 60fps as they're not smooth at all. This problem isn't constant, but it happens very often and ruins the game for me. I'm hoping someone has had and fixed this issue.

I have tried windowed, fullscreen, numerous drivers, overclocked, stock, checked all temps, lowest settings, highest settings, capping with RTSS, with and without VSync, fresh Windows/game, Windows 7/8.1/10, HPET on and off, default bios etc etc but nothing helps.

i5 3570k @ 4.3GHz (same with stock)
GTX 970
8GB DDR3
SSD
Win 10
Tested with onboard and hardware sound card
Try restarting your computer by turning it off completely. What you describe only happened when I used stand-by mode for weeks.
What about your monitor can it go 144hz? Your video card is limited to your monitors hardware too if were talking about gaming.
What is your display scaling set to?

I run an i5 coupled to 16GB, Samsung Pro SSD and an older Ti 550. With all settings maxed, I average between 35-45. With settings trimmed back I can hit 60s. But even with the settings maxed it plays fairly smooth to my eye. It will slow down a bit when multi playering, or on certain maps, but besides that...

I have a 580 sitting here to install as a bit of an upgrade... lol Just haven't yet.

But I know this game has issues with scaling. There are also issues with certain programs that can interfere with it. For example, some remote desktop software 3rd party programs can cause issues, especially in any of the Windowed modes.

Obviously there must be something setup on that system that is making it run like that. What exactly, I have no idea.
What are your monitor specs? No matter how great your system is it can only display visuals at the monitor's max capabilities.
Uncheck "Vertical Sync."

I had horrible framerate problems, and still suffer occasional stuttering. I have all settings maxed, but I unchecked the "Vertical Sync" checkbox, and went from 60 FPS to 210 FPS. And most of the jerkiness went away.

There is still the initial stuttering on movement introduced with RoS, but it's at least tolerable now.

Uncheck "Vertical Sync."
03/14/2016 10:35 AMPosted by MrH
, with and without VSync,


03/14/2016 02:34 PMPosted by StoneOld
Uncheck "Vertical Sync."


Maybe you missed that part.
Do you have your power management mode set to "prefer maximum performance" under the Global Settings tab of the Nvidia Control Panel? I think by default Diablo 3 is set to adaptive, which doesn't allow the card to run at full speed. Prefer maximum performance always runs the card at the maximum clock speed.
Monitor is a 24", 1080p, 60Hz Liyama Prolite.

Power management is set to maximum performance.

Aspect ratio scaling, performed on display.
03/15/2016 06:09 AMPosted by MrH
Monitor is a 24", 1080p, 60Hz Liyama Prolite.

Power management is set to maximum performance.

Aspect ratio scaling, performed on display.


Well, 60Hz refresh is going to be the top speed there.

Power, fine.

Aspect ratio is not what I was referring to with scaling. I'm talking about the desktop being 100 percent scaled, or 125 or 150. When set to anything above 100, some weird !@#$ happens to Diablo 3. Settings for this should be under your Desktop or screen settings in Windows.

When you go under the game settings, and you are looking at the max and min refresh rates that they have listed, set your max to 60 to match your monitor, and be sure that vsync is off.

See what that does.
Ah, that is set to 100%. If I cap the frame rate in-game to my refresh rate and turn off VSync the screen tearing is some of the worst I've ever seen in any game, I couldn't play like that.
03/15/2016 08:18 AMPosted by MrH
Ah, that is set to 100%. If I cap the frame rate in-game to my refresh rate and turn off VSync the screen tearing is some of the worst I've ever seen in any game, I couldn't play like that.


I understand that. But does it help at all? Just curious if it at least corrects the "stuttering" Anyway.

Hmmmmm

I wish I had a better option. Sad that lesser cards don't seem to have that problem. Did you check into D3 profiles for the nvidia settings? I think they have a D3 profile for it.

You're not playing in 3D with the nvidia glasses are you? I do that on my laptop, and that can cause some freaky things.
03/15/2016 08:46 AMPosted by DTMAce
03/15/2016 08:18 AMPosted by MrH
Ah, that is set to 100%. If I cap the frame rate in-game to my refresh rate and turn off VSync the screen tearing is some of the worst I've ever seen in any game, I couldn't play like that.


I understand that. But does it help at all? Just curious if it at least corrects the "stuttering" Anyway.

Hmmmmm

I wish I had a better option. Sad that lesser cards don't seem to have that problem. Did you check into D3 profiles for the nvidia settings? I think they have a D3 profile for it.

You're not playing in 3D with the nvidia glasses are you? I do that on my laptop, and that can cause some freaky things.


Sadly not, and no, I'm not playing with 3D glasses. I actually bought the PS4 version just because and that version has no micro stutter at all, but it does suffer frame rate dips at times which is a shame!

Join the Conversation

Return to Forum