Delayed deaths with leap.

Barbarian
Can't seem to find any threads about this but I get these random deaths that seem to be a glitch of some sort.

So, it starts by taking near fatal damage. I'll quickly heal to full via BT heal or health potion. Suddenly, I'll just die and it just says I was "slain" even though I've leaped away from everything and am completely out of any ground effects. It happens the most frequently with arcane sentries. Sometimes it will actually say "slain by arcane sentry" but on my screen, I"m well out of any of the sentries.

Anyone else experiencing these weird deaths that don't really make any sense?

Also no I'm not complaining about dying. I really feel that there is some sort of glitch associated with either latency or graphics, or both that is causing deaths that don't actually match with what is happening on screen.
I feel it's a lag issue, what is your ping time generally.

Like i always / everytime get ping of 250~300 ms, but sometimes when it increases it happens to me too, where I feel I am away from mobs but actually they are near me and hitting me. So I feel it's not a glitch of skills, it could be a lag issue
07/09/2016 08:04 PMPosted by HellBoy
I feel it's a lag issue

Agree, it happens to me as well after appearing to move from the hazard you end up dying/dead. Usually at some distance from where you appear to be on screen. There have always been some issues with some causes of deaths, and I just take them when they come and don't ever play HC on this game.
Yeah makes sense. My latency hardly ever drops below 80 then it gets really bad quite often. Its my entire internet, we have a problem and I finally got Scamiacom coming out Tues to "check"/replace stuff.
Nice EQ barb.

I had leap lag death last era before they reduced the EQ ticks from 16 to 6 per second.

I basically couldn't play in groups.

What is happening here (you can't see this due to the graphics not updating) is that you Leap in and due to the delay in your rotation you die. You can't die while leaping, its always that little gap before your next Leap.

So you can compensate for this with options that smooth out your rotation.

In your case the easiest rotation smoothing fix is Superstition to Animosity.

If that doesn't work, drop Skular's for APD (You won't need to run Diamonds anymore)

Good luck and I hope they can sort out your net.
This also happens to me sometimes.

One death was rly weird:
I took some damage after first leap (hp dropped to ~25%), used health potion (hp up to ~85%) + second leap, further healing while landing second leap (hp to 100%) + third leap, after landing third leap immediately dead without taking further damage :-(
Yea this has been a frustrating issue. From what i can tell its do to random lag spikes.
Reporting in: I've played EQ with low latency (20-50 msec), no lag issues:

Reaching 0 HP while starting a leap animation will ensure you die as soon as you land.

Not sure if it's a bug or intended, usually happens when a ground DOT tick or something finishes you off.

I don't think it's lag related
07/10/2016 10:28 AMPosted by Archael
Reaching 0 HP while starting a leap animation will ensure you die as soon as you land.


Wanted to add something: I think -- haven't tested and not 100% sure -- that this happens even if you pop potion after the leap. In other words:

Fatal damage + starting leap animation --> pop potion mid air --> land and instantly die.

Again, not 100% on this, but I think that's how it works.


Fatal damage + starting leap animation --> pop potion mid air --> land and instantly die.
.


As opposed to fatal damage + starting leap animation?

Because that will also kill you, potion or not

hehe
07/10/2016 10:44 AMPosted by Archael


Fatal damage + starting leap animation --> pop potion mid air --> land and instantly die.
.


As opposed to fatal damage + starting leap animation?

Because that will also kill you, potion or not

hehe


Haha you know what I meant:

07/10/2016 10:28 AMPosted by Archael
Reaching 0 HP while starting a leap animation
07/10/2016 10:28 AMPosted by Archael
Reporting in: I've played EQ with low latency (20-50 msec), no lag issues:

Reaching 0 HP while starting a leap animation will ensure you die as soon as you land.

Not sure if it's a bug or intended, usually happens when a ground DOT tick or something finishes you off.

I don't think it's lag related


This has been around for a while and I personally never mentioned it but I Experienced that many many many times. You take fatal damage mid leap but don't die till you land, or if you're lucky end of the third leap.

Join the Conversation

Return to Forum