Achievement is Not Recognised

Bug Report
I have completed The Demonic Prisoner at least three times in a coop game but it has yet to be recognised. On the first two occasions, I was in a coop game but completed the task by myself. Today, I called in the other player and we completed the task together. He got the achievement but when I checked his achievement list, it showed single player only. This is my last coop achievement, so it is annoying that it will not fire.

While it may have worked in the past, I would assume, from today's test, that it doesn't recognise the coop completion anymore.
Glad I found your post, we have the exact same problem with cooperative achievement events not being recognised.

We played all day, and completed the following events several times in cooperative mode:

    Penny For Your Troubles
    The War That Time Forget
    The Demonic Prisoner
    Tollifer's Last Stand


"Penny For Your Troubles" finally stuck after several re-runs, but we couldn't get the others to activate / stay in our achievement tab. Very demoralising considering some of these events are so hard to find, particuarly in coop games.

I took several screenshots of the action, what messages were displayed, what bosses where killed, who started / ended event, and the resultant non-achievement.

I can't understand what "we" may have been doing wrong, other than there's a bug in the game not recognising / triggering the awards.
It's extremely frustrating but often this is due to the 'delay bug'.

Blizz has added a lot of features to the game over the years but fails to test/fix stuff. I don't get it from such a fabulously successful company. They have resources no?
Moving to our Bug Report forums for our QA and Developers to look into. This is not a Technical Support issue but a bug report. Thanks for being so detailed in your posts everyone that helps a lot!
I raised this in the Tech Support thread as it is very unlikely that all players are affected by the problem. Intermittent effects tend to be ignored by software developers and it seemed that a band-aide solution to affected players was more likely to be applied. The length of current bug report lists, with no comment from Blizzard, is not encouraging.
All events with a Siege Rune Keeper need to be done in Campaign (=Story) mode to tick:
- The Demonic Prisoner
- The War That Time Forgot
- The Time Trap
They don't count in adventure mode.

There is no known bug reganrding Penny For Your Troubles or Tollifer's Last Stand
I redid The Demonic Prisoner in Story Coop and it was recognised, as McLight suggested. There is nothing in-game that suggests that these missions do not count in Adventure mode, so I still see this as a bug. If Blizzard believe it is WAD, it would seem their intention is to frustrate people.
First: sorry for my bad english, i'm from Brazil. :)

I have the similiar problem, but just in two... and already made one observation in 3/27/2016 as referred link:

http://us.battle.net/d3/en/forum/topic/20742925692

thanks and good working!
I reran these events in campaign mode as suggested by McLight, and these two were successful:

    The Demonic Prisoner
    The War That Time Forgot


However, I ran a cooperative speed run through Act 5 (start to finish) about 2 week before hand, and had to complete both of these events in order to pick up the siege runes, so these should have been successfully picked up then.

So adverture mode / campaign mode, I'm still calling this a bug, more so there is no explanation to the player these need to be run via adventure or campaign, and that just frustrates game players and turns them off.
The cooperative's achievement is not scoring.

***Achievements***
*Cooperative*
Act V
- Disorderly Conduct
-> The War That Time Forgot
-> The Time Trap

My problem still the same... Now with the new patch in PTR i hope you guys can fix it.

Thanks!

Join the Conversation

Return to Forum