Screen freezes on Desolate Sands, but Sound is working.

Technical Support
I tried all of the work suggestions for game and Video card settings in the forums, but none of those work. I found a posting that suggested a change in the Video card driver, but it also said the that was to fix the crashing issue and was not for the screen going dark but sounds was still playing. The game continues on cause I can hear it and when I click the mouse to shoot secondary weapon I hear it go off.

I didn't find a forum entry for this problem. Can you help by either directing me to that forum or through this ticket?

Video Card: AMD Radeon HD 6570
Driver installed: 15.201.1151.1008
Driver release date: 11/4/2015
Computer: Intel CPU 650@ 3.20 GHz
Operating system: Windows 10 64-bit
Memory: 16GB
System Type: x64-based processor

This only happens on Desolate Sand (DS) screen. I can approach from the Hidden Aqueducts and I can port into the Ancient Path, but when I get to the entry to the southern most part of DS the screen goes blank, but sound is still heard. I also cannot port into DS.
Computer: Intel CPU 650@ 3.20 GHz
Video card: ]AMD Radeon HD 6570
Operating system: Windows 10 64-bit


Radeon™ R5 235X, R5 230, R5 220, HD 8470, HD 8350, HD 8000 (D/G variants), HD 7000 – HD 7600, HD 6000, and HD 5000 Series
http://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows+10+-+64

Two choices to install
Catalyst Software Suite 245 MB 15.7.1 7/29/2015
Radeon Software Crimson Edition Beta 313 MB Crimson Edition 16.2.1 Beta 3/1/2016

Installing 16.2.1 beta will alleviate the freezing issue. If don't wish to use AMD beta, then follow instructions for 15.7.1 workaround.
http://us.battle.net/d3/en/forum/topic/20747744924#2
I took the option to install the 16.2.1 beta and I can now access the Desolate Sands.

Thank you for your help.
I have this same problem, also one of the newer sewer areas doesnt work, sound and no video. Have tried all these "solutions" and "workarounds" but no dice , still doesnt work in those two areas. Makes the game unplayable when you never know if you will be able to finish a rift or run of bounties. This has been an issue for me for more than a year now and nothing has worked , never had help when posting in forums , have followed other discussions and tried plethora of different fixes that seem to work for others , still no DS. I even sat out last season because of it. Now as a cherry on top i cant run HOTS anymore either and the only fix iv seen posted about the playbutton problem is to revert to 2001 version of direct x , wtf? What drives me crazy the most with diablo is that its not even the whole map, after alot of trial and error there are sections of DS that i still load fine if i port to someone that has walked far enough away from WP, why is that? I mean why are there just 2 small sections of two of the maps that screws my video? and wouldnt it have been easier to fix those 2 small areas instead of forcing so many people to juggle drivers in the hopes that it might decide to work? Regardless , iv tried enough of these so called "fixes" to sour me on this game for another season , maybe for good , and to think i was excited to be jumping into season 7 next week lol. I guess majority of effort is being shoveled into new cashcow overwatch, since you already have my money why not shaft and ignore me right? guess its back to steam for me now that the last two blizz games i still play dont work anymore even after spending 10 hours of my day off this week troubleshooting these things and reinstalling game after game , driver after driver. Oh well , it was a good run.
07/28/2016 07:55 AMPosted by JohnGalt
have this same problem, also one of the newer sewer areas doesnt work, sound and no video.

Desolate Sands and Cesspools? Do you get error message or just freeze? If just two areas, then you most likely have AMD video issue. Post background information (computer specs, windows specs, video card and installed video driver version)

First step of troubleshooting is for you to do. Run windows update and verify no failed updates. Check motherboard site for driver / bios updates and verify all drivers up-to-date (video, audio, network, chipset). The usual fix is simply to update video driver to latest. Check link for details.

http://us.battle.net/d3/en/forum/topic/20747744924#2

07/28/2016 07:55 AMPosted by JohnGalt
I mean why are there just 2 small sections of two of the maps that screws my video?
Coding isn't stagnant based on one point in time. AMD, Nvidia, and Intel provide companies with code requirements as new drivers are released. They are supposed to be backwards compatible. All AMD video drivers released following 15.7.1 fixed A2 Desolate Sands and A5 Cesspools freezing issue. Of note, AMD will no longer be supporting non-IGN cards (legacy cards).
I'm running into the same issue in DS. I have the AMD 15.200 driver version. All suggestions do not work. I don't think it's the driver version at all as the game plays flawless until I get to DS. Note, I have tried to install the 15.7 driver and it does not accept as it freezes up at about 60%.
07/29/2016 04:59 AMPosted by lhntx1
same issue in DS. I have the AMD 15.200 driver version. All suggestions do not work

Most Act2 Desolate Sands freezing is due to AMD video driver 15.7.1 released August 2015. Problem is Windows 10 auto updates to 15.7.1 not the latest, In addition, AMD still lists 15.7.1 as optional install for some cards. Run windows update and verify no failed updates. Check motherboard site for driver / bios updates and verify all drivers up-to-date (video, audio, network, chipset). Post background information (computer specs, windows specs, video card and installed video driver version)

Note: if have AMD APU Processors (cpu with built-in graphics), use steps 1,2,3,4 to know which is correct driver to download.. Latest is 16.7.3 hotfix for some cards. Legacy cards 16.2.1

AMD drivers ... http://support.amd.com/en-us/download
A2 Desolate Sands ... http://us.battle.net/d3/en/forum/topic/20419433789

If nothing else works, then use 15.7.1 workaround. Temp fix is to place two 13.12 dll files (atiumd64.dll and atiumdag.dll) in Diablo.exe folder (may result in gray screen). If do such and at future time install newer driver, then delete added dll files (show hidden files).
-- https://mega.nz/#F!8tlAhDyQ!2AkAQukJKAYuIWEzDTGtFA
-- Driver DLL // DirectX 9.0 // 13.12.zip
All has been verified , my game doesnt crash and i get no error messages . I get stuck on the load screen with the red diamonds bugged , if i alt tab and then back its just black screen , but i can still townportal/ alttab again and see town fine without restarting game. Like it says in the sticky link you posted this is amd and nvidia problem,"Please note that this is just for the issue of the game crashing when entering the Desolate Sands area primarily. It is not for another issue we're seeing where the game will suddenly "black" out while the user continues to hear the game sounds in the background. That particular problem is not brand specific, happening to Nvidia and AMD users alike. " that being said i see no fixes for this issue , only with crashes and freezes. And none of this works, iv done it dozens of times now, on windows 10 and 7. After more than a year of this same problem and wasting so much time trying to get it running correctly, i wish i could just cut those two areas out of my game entirely. Thanks for linking all the obvious btw lol , but it looks like ill just check back in another year , its really amazing how much one area messing up like that ruins the entire game for you considering all the time you spend in rifts late game.
@ JohnGalt,

What is your specific situation. Do you have AMD APU or hybrid graphics? If APU, check post #8 this thread. Follow steps 1,2 ,3 4 not using autodetect. Post background information (computer specs, windows specs, video card and installed video driver version) ... If error message, post D3Debug.txt.

Post DxDiag.txt. (use code button)
Post D3Prefs.txt (found in .../documents/diable iii/...folder)

Obtaining System Files ... https://us.battle.net/support/en/article/obtaining-system-files
Contact Support / Online Chat ... https://us.battle.net/support/en/help/product/diablo3
It's a bit unfair to play for years successfully and then with no reason be unable to play due to a desolate sands lock up. Our money was paid and it seems we get too many issues that prevent us from enjoying what is supposed to be 'our' game. We can't play offline and have gotten accustomed to that caveat but why is it we need to do anything on our end to solve your issues? Mine was fine until yesterday 12/23/16......no changes on my end and supposedly none on yours yet all of a sudden boom...cannot enter Desolate Sands. It's pretty sad.
Howdy Greyjoy!

With the Desolate Sands lock ups this is almost always resolved by updating to the newest Crimson drivers for AMD. We haven't seen this issue with NVIDIA yet so if you have a NVIDIA card or if updating your drivers doesn't work please start your own forum post with your DXDIAG posted.

It's always best to start your own post instead of necroing an older post. Due to how old this forum is I will be locking it but please start a new post if you continue to have issues after updating.

Join the Conversation

Return to Forum