2.4.2 pathetic performance; stutters, freezes, frame drops!

Bug Report
Diablo 3 has never been optimized, EVER. That's no secret. Never ending "magical" stutters, frame drops, lags and the other sh!t - and equally magical user solutions. It happens to everyone regardless of the rig they are using, be it 1k$, 2k$ or 8k$ PC. Matters not. You can have 128 cores, 256 PB of ram and 64 way SLI and D3 will still be able to use 2 cores and even that it can't do properly. To make things worse it can't even be forced to use v-sync in nvidia panel...

I have an i5 3570k @ 4.2 GHz, MSI gtx 970 and 16 GB DDR3 ram and d3 is installed on an HDD; I'm using a 60Hz display.

Diablo never ran great for me, it was okish. I always had frame drops from time to time but it was... bearable. After 2.4.2 diablo's joke "performance" is... well there is none. I always had v-sync on but now without a framerate overkill by unlocking it, it stutters every few seconds to like 37fps with 0.5s freeze in the middle. The situation seems related to mobs or "objects" since I can stand on an empty screen and have const 60 fps, no freezes. BUT the moment I enter a rift... it's unbearable. The only way I managed to find to counter this is to unlock everything, no vsync, no fps limit - which makes my PC sweat like a pig for no good reason. OBVIOUSLY it's not an ideal situation as i dont need 200+ fps i just need constant (STABLE) 60. I've read/tried a lot of different thing; deleting d3pref, fullscreen/windowed etc., changing graphics options, editing d3pref. D3 just doesnt give a sh!t!

My hardware is an overkill for this puny game, clearly. At this point it should run on a potato but instead it chokes, stutters, drops frames, freezes and performs as if i had P2 133MHz and a TNT2.

Example: me: mote barb in a4 going for the keywarden. On screen: 3 oppresors; result: frame drop to 40 fps.
Here is a list of issues/questions I have:
1. Why is D3 not using more then 25% CPU with vsync on (instead it stutters)? EVER!!!!
2. Why the 1st 30sec after starting a game and being in town is like slide show - ONE CONSTANT stutter?
3. Why and what for is D3 ignoring my nvidia setting (vsync, triple buffering)?
4. Why D3 was ok pre 2.4.2 and now it's not?
5. Why was it never optimized to use 4 cpu cores?
6. If the Witcher 3 can keep 60 fps on reasonably high settings why can't d3 do the same?
7. Why item's icons on the ground (I use round icons, not letters) often skip or chop when moving instead of fluently transitioning "through" the ground?
8. HOW can I fix this silly game once and for ALL?
9. Why do I have to write all this in 2016, 4 YEARS after the game has been released?!

I'm from EU but since it's dead I am posting here. In the EU no one gives a damn so I decided to draw some attention here.
I have a similar but strange issue. 2.4.2 killed my fps...

Since last season I've swapped a 980ti for a 1080, haven't loaded the client since but now 4k@ 60hz hovers at 27-30 fps, and dropping back to 30hz makes the fps hover at 13-15fps. Both in-game and fraps confirmed...? Other games are fine (fps increases as expected).

Blizzard wtf?
08/03/2016 05:43 AMPosted by Elusivity
I have a similar but strange issue. 2.4.2 killed my fps...

Since last season I've swapped a 980ti for a 1080, haven't loaded the client since but now 4k@ 60hz hovers at 27-30 fps, and dropping back to 30hz makes the fps hover at 13-15fps. Both in-game and fraps confirmed...? Other games are fine (fps increases as expected).

Blizzard wtf?

Oh, I see you got it even better. GG blizz!
Yes, of course. Why would a blue respond? There is no need to fix years old issues which ARE GETTING WORSE!
Same for me, game has been good since they fixed the stutters. Has returned along with longer load times since this patch. Again a good PC 4790K (i7) 16Gb RAM Diablo is on its OWN SSD. 1060 graphics. Core of Arreat is back to its old school stuttering best.
hello i have lost 50 fps since 2.4.2
Similar situation here to all of the above. I have a decent specification of PC which I use for Video Editing and Production as well as games.

What annoys me is, when creating 4K Video my CPU (8 core AMD @ 4.4Ghz not overclocked) runs 4C cooler using all 8 cores at almost 100% than it does when running Diablo 3 using 2 cores.

I would guess the official response would be something along the lines of "We had to make it an x86 application to cater for the users out there who do not have modern PCs with good specifications". Well, I would disagree with that line of thought, as I suspect the majority of people who play games have mid-high-end machines and the rest are in the minority. Time to start catering for the majority if you ask me.
Same here.

Amd fx-8370 (4.7ghz)
16 Go of 2133mhz ram
nvidia 1060 OC Strix Rog 6gb

and this game lag at me at anytime ... It's not really enjoyable for those kind of setups :/
I just wanted to add. My problem is NOT related to my connection, at least from what I can tell. I am @ nearly permanent 65ms latency and always have been.
Same here, i7 6700k,16gb ram and gtx 1080. Fps without vsync more than 300,vsynced a stuttering mess in 4 player games. Wtf?
Add me to that list.

i5 4690k, 16GB RAM and GTX970. Latency is constant at 65-75ms but actions/skills/movement have a delay of 3-4 seconds, making it impossible to play.
Same here with perfomance issues. Also I can't connect the game first time. I spawn into town/camp and I'm losing connection to the game. This patch destroyed this season.
i7 5820K + 980 Ti, hovers around 20fps.
Seems a bug makes the game thinking it is always running in the background.
Change to Windowed mode bring the fps back to normal.
Using Fullscreen or Windowed(Fullscreen) will result unusual low fps.
Haven't found a work around yet.
Same here

Using
Windows 10 64-bit
FX 8350 @ 4 GHz
16 GB RAM
Nvidia GeForce GTX 970, 4 GB VRAM
Using a SSD
Diablo 3 runs butter smooth on ps4 yet my PC thats 10 times faster then a ps4 on both cpu / gpu performance has hitching issues especially in groups and if you decide to run the game without vsync with beyond 100 fps it stutters like crazy, seriously this game has been broken since 2012 when diablo 3 was launched and is one of the only games that must be installed on a ssd or it will lag like crazy, devs should be ashamed of them self for not being able to fix this even now, pretty sure even developers from Ubisoft would screw up this bad.
rather amusing people complaining about their computer rigs and the game being slow when their network connection is the reason it is slow/stutters.

welcome to the world of lockstep network gaming. there are ways to fix this by tuning your tcp/ip stack, your router qos/mss and getting a decent isp. granted the latter isn't always available depending on where you live but it does matter.

most fps games are better when you're a lpb (low ping bastard) but for blizzard games it isn't a convenience but a requirement.
08/11/2016 03:35 PMPosted by kehlarn
rather amusing people complaining about their computer rigs and the game being slow when their network connection is the reason it is slow/stutters.

welcome to the world of lockstep network gaming. there are ways to fix this by tuning your tcp/ip stack, your router qos/mss and getting a decent isp. granted the latter isn't always available depending on where you live but it does matter.

most fps games are better when you're a lpb (low ping bastard) but for blizzard games it isn't a convenience but a requirement.

There is nothing amusing in this whole situation. Having of ping of ~65ms constantly can hardly be called a reason for slowness and stutters. So yeah... you are wrong here.
same, big freez, fps drop since 2.4.2 ...
nice blizzard
Did anyone from Blizzard ever respond to this or offer any help? I am experiencing this too and its ridiculous. I have tried installing on an SSD, which did not do anything to help. I have limited frame rates to 60 and still no dice. I run way more complex games than this at high, consistent framerates. WTF is going on with this crap?

Windows 10
i7-6700 @ 3.4Ghz (Quad Core)
16GB RAM
GeForce GTX 970
BenQ XL2730Z
Windows 10
i7-6700K
16GB RAM
EVGA GTX 1070 Superclocked - 8GB VRAM


Same. I have random stuttering just from movement on an empty map. Not even spamming abilities, or while having a ton of models on screen.

Join the Conversation

Return to Forum