Diablo III doesn't start

Technical Support
Tried to the start Diablo III from the Battle.net program and it won't start but Battle.net says that's it running. I just did some updates of Windows 10. Does anyone have this problem?
Hey WHMcC4101,

I'd like to have you try our troubleshooting steps in the sticky post at the top of this forum. Here's the link:

Windows 10 Anniversary Update and Game Crashing

If those steps do not help you may also want to try disabling the Blizzard Streaming within the Battle.net app to see if that has any effect.
I am having similar issues on PC Win 10. The latest security patch seems to have killed the game. It launches, but never starts, although I can see the Diablo 3 retail in my Task Manager.

Battle net says the game is running, even after I close battle net and restart
Yeah none of that stuff works. I've looked on every forum. We might as well play something else and wait for a patch.
09/26/2016 04:10 PMPosted by Jambrix
Hey WHMcC4101,

I'd like to have you try our troubleshooting steps in the sticky post at the top of this forum. Here's the link:

[url="http://us.battle.net/d3/en/forum/topic/20748204992"]Windows 10 Anniversary Update and Game Crashing[/url]

If those steps do not help you may also want to try disabling the Blizzard Streaming within the Battle.net app to see if that has any effect.


This fix worked for my problem and I have been able to play again. So go look at the Windows 10 Anniversary update crash fix and it should work for you too.
I also have this prob. Did up date, Diablo says it is running, but never loads...
This happened to me. I restarted and now it works.
I know you all have probably tried this but just in case.......
The trouble-shooting in the 10th anniversary update article fixed my issue
Fixed for me.
run the file Diablo III-setup(1).exe from your taskbar right click the windows start button then click run find the file and open it, you should see an update,then restart and done. The only other thing i did was disable streaming. G/L
Having same problem
nothing I do helps please help

now why a negative lol
turned off streaming does not work
Alright I did literally everything on the list. I deleted the cache files, reinstalled Diablo, repaired it, turned off the xbox whatever thing, then I finally went into the Blizzard launcher and disabled streaming and that was the step that fixed it for me.
SORRY CAPS Gorc HAS FIXED JUST READ POST
Yes I am having the same issue. The temporary solution I found was to CRTL- ALT-Delete then end task on Diablo 3 retail, give it a min or two then run again and it works fine. I am running through the Battle.net laucher.

Join the Conversation

Return to Forum