Sound Choppy using crusader blessed hammer

Bug Report
Prev 1 5 6 7 Next
This issue still exists with no acknowledgement from Blizzard. Seems to happen with hammers and steed. At least tell us you're aware...
I'm having this problem also. Only ever happens with Hammers...
Still getting the same chopping sound.

Total ambandonment...
Damn, all of these posts for the last few months and not even a "We will check it out" blue post. Zero "F"'s given on blizzards end huh?
bump.
Still happening...This is insane that blizz is not doing anything about this.
This thread is mildly upsetting.
Favorite class, favorite build.
Quite a long running thread, and in my opinion, a really glaringly obvious issue.

Between all my seasonal and non seasonal hammerdins, I've spent probably 600 hours listening to this sound glitch.

The day when they change the sound effect to something like Burning Wrath, which doesn't cause this very issue... Will be a god send.
+1 same issue
Same issue here. Sounds like the audio is distorting.

Win7 64bit
6600K @ 4.7ghz
X-Fi Titanium (onboard processor)
Both 2.1 and 5.1 setup in windows/game causes the issue
16-128 sounds ingame setting does not fix it

I notice it a lot more in the Act 2 temple type areas. My soundcard does have an old driver, because it is not supported by creative anymore. However, out of the hundreds of games I have played, this is the only one to have this issue.
I am reporting this bug too. Getting really bad audio stutter while playing Crusader.
ugh... one would hope that after months this would be patched :(
I experience this bug when I am playing a crusader or if someone in the party is playing one.
for reference my specs are:
Windows 10 Pro 64-bit
Intel Core i7-4790 3.6GHz
Kingston HyperX Fury Black 32 GB DDR3 1600 ram
MSI z97 Gaming 5 motherboard
MSI Nvidia Geforce GTX 970 4GD5T OC edition
- core voltage +20mV
- Core Clock +185MHz
- Memory Clock +495MHz
- In Game - GPU clock 1513 MHz - Mem clock 4001 MHz
all drivers are up to date.
I can't believe this hasn't been addressed yet. I just came back after a few years off eager to play a crusader but its unplayable with this sound bug!
As a sound engineer, this seems more likely to be a problem that cannot be fixed. When a sound of very similar frequency (or the same) is played slightly out of sync you get a phenomenon known as 'comb filtering'. Basically, you have too many of the same sound playing fractions of a second apart and you actually lose those frequencies all together. Thus, creating the "illusion" that the sound is in fact not playing or disappearing.

Just a personal opinion.

If this is the case, the sound file should only be activated once and remain on loop for the duration of the spell, as opposed to having a separate sound for every single hammer sent out.
I get the same issue.
Just created a crusader not knowing that this problem existed, Thought my sound was messed up but nope its the hammers.
Glad to see that I'm not alone with this issue. Sad to see that Blizzard is ignoring the issue.
+1
Same over here.
Will hope for a fix hopefully sooner than later
Started playing diablo3 two days ago, again, and quite enjoyed it, its just that sound bug with spamming hammers on crusader that causes the sound to stutter.
Unplayable and quite frustrating.

I hoped for some quick online research and some qucik fix, but seeing this monthly old thread here leaves me....
.......
....
....
....
maybe I switch to hammerdin on diablo 2
I am also experiencing this issue with Crusader Blessed Hammer WTF

Join the Conversation

Return to Forum