Teleport responsiveness and other changes

Wizard
01/13/2017 12:28 PMPosted by Nevalistis
Thanks for the report on this. We'd like to do a bit more in-depth digging, so I'd like to ask a few questions:

  • What version of Teleport are you using? Rune or whether or not it is the Archon version would be good to know!
  • Are you using any items or powers that affect Teleport, such as Aether Walker or Illusionist?
  • What actions are you attempting to take immediately before or after teleporting? Just movement, or casting a spell? If so, which spell(s)?
  • When does the delay occur? Before your character actually moves, or after the teleport occurs?


More responses would be more helpful, as that can help us hone in on a commonality between these reports and an ultimate source issue. It's always possible latency is playing a part, but if there's a clear cause we can take action on, we of course want to take care of it!


Being in archon form (4piece vyr) teleporting (activating the skill) too fast will result in "rubber banding" porting you back and forth.
I cant believe that this bug was never fixed.

01/18/2017 06:02 PMPosted by Jumpman
I'm also really tired of this teleport bug and the electrocute bug and I really want these two bugs fixed asap so I went ahead and created videos and detailed it all out in a new bug report.

Lets make sure this thread stays alive because the teleport bug is the biggest offender for wizards and I bet this is the reason why a lot of people feel more squishy than they used to. When your teleport fails to work you always notice it happening because your probably now dead or your cheat death went off.

https://us.battle.net/forums/en/d3/topic/20752470380


I cant believe that were being forced to deal with these bugs for the whole season! This feels like a giant (slap) to the wizard community. If wizards actually had another viable way to keep up with the speed of other classes without teleport that would be different but teleport is required to even keep up with speeds. Its even worse in high grifts when your instantly killed from ground affix's, frozen, or jail because teleport fails to proc and instead of teleportating to safety you die.
please remove delay from all runes
Responding here since I think I happened to accidentally capture a video of the issue. Granted this is on 2.5.0 PTR, and the Teleport was already slow, but it looks like it might be what players here have been talking about:
  • https://youtu.be/hiP_TcHF7Qo?t=1865

I use Force stand when I teleport. Notice how I'm also channeling (holding down the right mouse button) when moving.

Going after the globes was kind of risky, but I sure thought I could do it. =)

Let me know if this is or isn't the same as what you're seeing.
Finally, I was able to capture the delay in a video.
The delay still occurs, but it is less "heavy" compared to 3 weeks ago.

I made a quick review of the video and marked some moments with the delay. But, I will check it again for other spots.

We can see, that in these cases, the Teleport skill key is pressed, but the action delays.
05:43 After Speed pylon (05:30), but not all teleports.
06:43
07:25
11:44
12:14
12:56
https://youtu.be/ALZeyRjI9ag

FB Archon with illusionist was used. The delay is manageable in this build, but in Tal6/Vyr4 builds can cause significant problems.

Finally, in 24/01/2017 Nvidia released new drivers, and I updated them. Also, I did all three tests from looking-glass, but they didn't report any problems.

I apologize for the video quality; it is the first time.

I hope it helps.
01/13/2017 12:28 PMPosted by Nevalistis
Thanks for the report on this. We'd like to do a bit more in-depth digging, so I'd like to ask a few questions:

  • What version of Teleport are you using? Rune or whether or not it is the Archon version would be good to know!
  • Are you using any items or powers that affect Teleport, such as Aether Walker or Illusionist?
  • What actions are you attempting to take immediately before or after teleporting? Just movement, or casting a spell? If so, which spell(s)?
  • When does the delay occur? Before your character actually moves, or after the teleport occurs?


More responses would be more helpful, as that can help us hone in on a commonality between these reports and an ultimate source issue. It's always possible latency is playing a part, but if there's a clear cause we can take action on, we of course want to take care of it!


I use the Calamity rune and have the Aether Walk in the cube ..
I see alittle delay but not really bothersome for me .
The biggest thing is no action at all when I hit button to move .. nothing at all happens .
I did test with no Aether in Cube and seen more delay but still moved and only once did the button not work in say 100 hits , but was delays ..
So is with and without the Aether being used .. I mostly seen the button not working in GR's .
on the delays they occur mostly when I hit button and nothing happens and then it moves .. for me a few times I hit button to move to spot and it didn't and I move cursor from landing spot and then the move happens .. and is at any point between the move and point and what I was doing the next with cursor .. Not good ,, I usually die at that point

hope this helps ya
Just changed the batteries in my wireless keyboard and mouse... Problem solved!
Teleport seems sticky. I find myself dying to elite affixes that spawn on me even when I teleport away to safety. This is using Archon's Teleport, while using Disintegrate Beam. I think part of the reason is lag. Teleport also seems to rubber band even under low lag conditions (<100 ping), and this happens with all runes and variants of teleport. I also notice that monsters have slight homing capabilities, aiming where we are teleporting almost automatically. This is most noticeable when fighting monsters such as Lacunis and Winged assassins, as well as Moon Clan Spearman. This is leading me to believe that teleport is ghosting, allowing us to be hit both before and after the teleport.
-> wizard _________ x_______________
->teleport _________x______________x
->teleport finish___________________x
I can confirm that teleport is also very buggy for me. Sometimes it takes 4 key presses and a few seconds to activate (no, it's not on cooldown). This has been happening only recently for me, past few weeks. Very annoying!
Hello, I apologize for the mild necro, but I have observed that this issue is happening again.

During February, I made some performance changes and now my FPS in town are up to 57-60 from 35-37 before. Changes made due to FPS drop in 4man play.
These changes, I though have helped the issue.
But, the last 10 days I experience again laggy behavior that has been described in previous posts.
I observed heavier delays with Aether Walker-Teleport Calamity, than with Archon teleport.
Also, player Leontokardos found delays with Aether Walker-Teleport Calamity.

My new observations may have a new information set of the issue.
First reports of the issue on Jan 11: New patch, new season, DoT Event.
Second reports of the issue now, starting from ~14 March: Late Season push, End of season, new patch, players get back due to Primal fever.

So, I am thinking. Could this behavior be justified by "traffic"?

Thank you in advance.
I am happily retired to lands of my Steam backlog. So someone else will have to do the follow up work. FWIW, I never saw anything in the patch notes saying this was fixed, and last time I checked this is a problem mainly on the 64 bit client.
03/24/2017 09:55 AMPosted by Gbrav13
So someone else will have to do the follow up work. FWIW, I never saw anything in the patch notes saying this was fixed, and last time I checked this is a problem mainly on the 64 bit client.

Glad to help in any way I can. Unfortunately, I did not capture these recent delays.
I was happily shocked by Mrs Nevalistis quick response, but indeed I am not aware of any new information, response or change since then.
Back to January, I found this issue both in 32bit and 64 bit on EU servers.
But, tbh, now I always play on 64bit.
Just change teleport to Dashing Strike! The Monk "teleport" is better. <g>
still waiting on that performance change to match dashing strike
I'm having the same exact input delay issue with all versions of teleport. In and out of Archon, with all runes and Aether Walker. I'd have to hit the hotkey multiple times for it to cast. And there's also the problem with the character being mysteriously "stuck" randomly at the destination. My average ping is 26 ~ 31.
Just ran into this last night and lost another HC Wiz...RIP oh well but didn't realize it was a bug until reading here and I am getting the exact same thing!

I switched up my gear for one run with a friend to try paralysis and ended up stuck in a corner hitting my teleport button (calamity rune), only to watch my wiz get pummeled and die after both cheat deaths went off and I was STUCK...had teleport on cooldown and full arcane so know it was a bug and not me, but stinks losing my freshly geared wiz!

-DooB
Have recently returned and have noticed some rubberbanding issues with TP. Only occurs in Archon form.
Still a major problem 8 months later... Been 3 months since it was bumped so figured it was due for another.

Standard Tals 6/Vyrs 4 build. Teleporting while in Archon form causes horrific rubberbanding on certain maps. If I hold down left click to keep blasting disintegration wave while teleporting it doesn't seem as bad.

In fact the rubberbanding is so bad at times, I can get from point A to B faster simply by walking and not even using teleport.

Just to be 100% clear... I do not have issues with normal teleport. Only Archon teleport.
08/01/2017 07:51 AMPosted by Dravis
Still a major problem 8 months later... Been 3 months since it was bumped so figured it was due for another.

Standard Tals 6/Vyrs 4 build. Teleporting while in Archon form causes horrific rubberbanding on certain maps. If I hold down left click to keep blasting disintegration wave while teleporting it doesn't seem as bad.

In fact the rubberbanding is so bad at times, I can get from point A to B faster simply by walking and not even using teleport.

Just to be 100% clear... I do not have issues with normal teleport. Only Archon teleport.


I am gonna go out on a limb and say this wont be fixed. The state of the game is very poor at the moment (for me) with severe stuttering issues and other problems. The 64 bit client has become quite unstable since the necro launched.
01/13/2017 12:28 PMPosted by Nevalistis
Thanks for the report on this. We'd like to do a bit more in-depth digging, so I'd like to ask a few questions:

  • What version of Teleport are you using? Rune or whether or not it is the Archon version would be good to know!
  • Are you using any items or powers that affect Teleport, such as Aether Walker or Illusionist?
  • What actions are you attempting to take immediately before or after teleporting? Just movement, or casting a spell? If so, which spell(s)?
  • When does the delay occur? Before your character actually moves, or after the teleport occurs?


More responses would be more helpful, as that can help us hone in on a commonality between these reports and an ultimate source issue. It's always possible latency is playing a part, but if there's a clear cause we can take action on, we of course want to take care of it!


I do not use aether walker, but I notice this in archon.

Typically I notice it most when also channeling my beam. From what I notice is that it is activating, as it cancel my beam and plays the audio, but I simply teleport in place.

Join the Conversation

Return to Forum