Can't access beta forums

Technical Support
Been 24 hours and still can't access the beta forums
Howdy Dragonslayer,

If you are still unable to access the beta forums we recommend resetting the password to your account. That should fix you up and allow you access to the forums.

https://us.battle.net/account/management/settings/change-password.html
I just did that, I have access, still cant access the forums, been almost 27 hours since i received my invite. Also still cant access the game.

http://imgur.com/EpPV1Yq

Thats my account (everything of importance is hidden)
04/26/2017 06:08 PMPosted by Joynueer
Howdy Dragonslayer,

If you are still unable to access the beta forums we recommend resetting the password to your account. That should fix you up and allow you access to the forums.

https://us.battle.net/account/management/settings/change-password.html


Did as you asked and it still is not showing

http://i.imgur.com/Xz5V9e5.png

**here is what it says im my acct management **

I have reset password 4 times today with no success on this matter
33+hrs still dosent work
just reset pw again nothing
04/26/2017 06:08 PMPosted by Joynueer
Howdy Dragonslayer,

If you are still unable to access the beta forums we recommend resetting the password to your account. That should fix you up and allow you access to the forums.

https://us.battle.net/account/management/settings/change-password.html


I reset my password yesterday, after a full day of no access to the beta forums. It is now day two of no access to beta forums.

I've also tried clearing my cache and cookies and tried a different browser.
2 days no fix yet...
04/26/2017 06:08 PMPosted by Joynueer
Howdy Dragonslayer,

If you are still unable to access the beta forums we recommend resetting the password to your account. That should fix you up and allow you access to the forums.

https://us.battle.net/account/management/settings/change-password.html


I changed my password and I still cannot access the forums. Password change is super annoying btw, a recent change disallows pasting into the editboxes to change your password, which is essential if you are using a password manager and promotes bad security. Had to disable Javascript for the account page just because of that <.<
still dont have beta forum access but i did get logged into beta
Still no beta forums what givs
I believe that it has something to do with the flags on our accounts (I can't access to the forums) since I get the 300016 error. It appears that once we use our token for the beta, it flagged our account to access to the forums and the game. I presume you might have PTR character copy over as I did and it probably overwritten the Beta flag or something and now our accounts is saying that we don't have beta access. That is what I am believing what is happening to the whole thing.
04/27/2017 08:31 PMPosted by Rykert
I believe that it has something to do with the flags on our accounts (I can't access to the forums) since I get the 300016 error. It appears that once we use our token for the beta, it flagged our account to access to the forums and the game. I presume you might have PTR character copy over as I did and it probably overwritten the Beta flag or something and now our accounts is saying that we don't have beta access. That is what I am believing what is happening to the whole thing.


I would say this is more than likely what happened. I remember some people saying they couldn't reuse the beta token before the patch.
Well this would explain why I cannot access the necromancer beta section.
I cannot access the necromancer beta forum as well - got 404 error with any links to it. PTR beta game is available for me for some days, but I cannot report to the forum.
04/27/2017 08:31 PMPosted by Rykert
I believe that it has something to do with the flags on our accounts (I can't access to the forums) since I get the 300016 error. It appears that once we use our token for the beta, it flagged our account to access to the forums and the game.


I don't think it has anything to do with that.

Because I've been able to access the Necro Beta forums from the time I first noticed the Necro Beta license appearing on my account. Here's my timeline of events

* Needed to open battle.net email to get new MVP chat system details
* Noticed email Welcoming me to the Necro beta
* Checked battle.net account management , said I had D3 Necromancer Beta license
* Started install of Diablo 3 Public Beta Test
* Tried to login , received Error #300016
* Turned to forum for guidance , found Beta forums down bottom of forum list for some reason
* Day or so later , could login
* Went to create Necromancer character
* Purchased Necromancer toon with "Necromancer Beta Token"

I didn't do the PTR character copy tho. Might try that next. For SCIENCE!
7am cst still no beta forums access
No access...did everything. This is just an account flag issue problem on Blizzard's side IMHO.
has to be cause im getting tired of resetting my dang password to try it out fixin to set it bck to usual and not changing it again. then im gonna log into the beta if it is up
04/28/2017 05:02 AMPosted by GolfMike
No access...did everything. This is just an account flag issue problem on Blizzard's side IMHO.


Yes it is. They are the ones who have to fix it. Once they do, a password change can force a data refresh which can help, but until they do their part, nothing YOU do will help.

Join the Conversation

Return to Forum