nobody is talking about the game crashes since 2.6?

General Discussion
I just did 3 full rounds of bounties and in that time I crashed with "unexpected" application error twice.

It is a very common occurrence with me and the players that I play with

blizzard, please fix this.
Are you using the 64 bit client ? If so change it to 32 bit in the launcher options. The 64 bit client still has issues like random crashes / memory hole etc.
if your using 32 bit launcher u will crash often, switch to 64 for smooth stable and no crashes , me and everyone else gets none for months now, if I ever get a crash in few months of none it was my electricity go off. and got old computer, besides no other reason to go 32 to crash all day exept if u use google maps, wich is worth it if u can survive ur nerves crashing non stop, other than that from smooth and perfectly stable game on 64 u also gain the dx11 texture ad mostly instant loading.
Maybe I should be more specific.

I was using 64bit client, but it was laggy.

So I switched to 32 bit.

Its been very stable in 32bit but since patch 2.6, it hasn't been stable in either 64bit or 32 bit

Now I get a windows "Unexpected application error" with the D3 app crashing to me desktop once every 2-3 hrs on avg.

I see guys on my friends list signing in and out often. They tell me that they are crashing to the desktop too. So its just not me.
Just yesterday all 'clan' functions stopped.. and it was not even listed on the social menu at all. . . something is going on~
Have all kinds of crashes since 2.5 like many others. But i doubt Blizzard is doing anything.
Having way more crahes since 2.6 as well :(
technical support section is talking about it
try reinstalling or repairing your install (scan and repair option)
No issues for me. I see a lot of people having issues, like stuttering and lag, but Ive never had those issues. Game runs nice and smooth for me. I dont know what could be your issue. Bad drivers is probably the most obvious issue or too heavy an over clock if you've done that.
I am getting 1016 error network disconnect a couple times a day and I have done everything on my end to find a fix, still happens.

I assume at this point it is a Blizzard problem on their end.
07/08/2017 04:01 PMPosted by Sarah
I am getting 1016 error network disconnect a couple times a day and I have done everything on my end to find a fix, still happens.

I assume at this point it is a Blizzard problem on their end.

Same here. It has been discussed earlier and summary is there is no clear unswer how to fix that.
07/08/2017 03:29 PMPosted by Love
technical support section is talking about it
try reinstalling or repairing your install (scan and repair option)


Thanks for the suggestion. I've run the scan and repair. Lets see if it helps

07/08/2017 03:39 PMPosted by MrXanthis
No issues for me. I see a lot of people having issues, like stuttering and lag, but Ive never had those issues. Game runs nice and smooth for me. I dont know what could be your issue. Bad drivers is probably the most obvious issue or too heavy an over clock if you've done that.


no overclock, but it very well could be drivers. I'm going to update everything to the latest.

Thanks for the suggestions guys
Not talking about it because it doesn't happen to me.
Actually got a bluescreen last night. reported it but don't think it will do much.

Join the Conversation

Return to Forum