Error 1016

Technical Support
How do i get my money back for the necro xpac? Its not that I dont love it its that the game is unplayable and blizzard keeps passing the buck on the players for the bad lag, constant disconnects.
Bladeyama,

You already have 2 max level Necromancers on the account which means you've already experienced the content. I'm sorry but your account doesn't qualify for a refund.

What troubleshooting steps have you tried to resolve your lag and disconnect issues?
I made sure my Windows 10 was up to date.

Made sure the network card is up to date and the setting are set properly.

Ran the computer in a selective startup mode.

I power cycle the network equipment and flush the DNS.

I released and required my IP

I set the blizzard launcher to open in admin

I set the blizzard launcher to close completely when I press play

I submitted a winmtr report

I ran antivirus and malwar software
Like i said I enjoyed playing the necromancer but it is so fustrating when you get close to the end of high level greater rift and get dcd before you can turn it in.
Bladeyama,

If you're only seeing issues when playing in high level rifts, it's something you should be posting in the Bug Report forum.

https://us.battle.net/forums/en/d3/5386229/

Tech Support can only help you with issues on your end, we don't have any input as to how the game is made or any bugs that may exist. For example, for troubleshooting purposes, and yes, I know it's a big hassle, could you relocate your PC to a friend's house perhaps who is using a different ISP than CenturyLink or just play on their PC with your account and see if it's any better or not. That information helps to determine where the problem is coming from. Or if you have the means, try using your phone as a mobile hotspot for the PC as a test that would be using a different connection.
08/01/2017 04:50 PMPosted by Omrakos
Bladeyama,

You already have 2 max level Necromancers on the account which means you've already experienced the content. I'm sorry but your account doesn't qualify for a refund.

What troubleshooting steps have you tried to resolve your lag and disconnect issues?


lol thanks activision
08/01/2017 04:50 PMPosted by Omrakos
Bladeyama,

You already have 2 max level Necromancers on the account which means you've already experienced the content. I'm sorry but your account doesn't qualify for a refund.

What troubleshooting steps have you tried to resolve your lag and disconnect issues?
Well thats kind of scummy. Ive done everything and its not getting better. ONLY battle.net d/c not anything else i have running. I play HC only, at least its kind of an adrenaline rush.
I am not just seeing it one part of the game on all parts of the game and I am not the only one. It doesnt matter what I am doing in game I get dcd and I loose what ever it is I am working on in the game wither it be bounties, rifts or Greater rifts. This is only happening on world of warcaft and Diablo 3. I called my ISP and they said nothing is wrong with my connection. Also I am disabled home and bed bound So i cant just go to someones house.

08/01/2017 05:40 PMPosted by Omrakos
Bladeyama,

If you're only seeing issues when playing in high level rifts, it's something you should be posting in the Bug Report forum.

https://us.battle.net/forums/en/d3/5386229/

Tech Support can only help you with issues on your end, we don't have any input as to how the game is made or any bugs that may exist. For example, for troubleshooting purposes, and yes, I know it's a big hassle, could you relocate your PC to a friend's house perhaps who is using a different ISP than CenturyLink or just play on their PC with your account and see if it's any better or not. That information helps to determine where the problem is coming from. Or if you have the means, try using your phone as a mobile hotspot for the PC as a test that would be using a different connection.
I haven't been able to play at all for over a week. On the rare occasion I get in, I get kicked off within a couple of minutes. Even starting a new character level 1. So it isn't rifts at all. WOW and Diablo 3 are unplayable. I have also gone through the numerous help forums trying to fix this.
I had the same issue last night and am on comcast. I had no other connectivity issues except for connecting to and maintaining a connection with blizzards servers.
Ive been having the same issue all night as well. Insane ping (200ms avg, spikes up to 700ms). Unstable gaming experience when i can login, havent been able to actually login for four hours though because i keep getting 3006 error when i try to log on. If i can log on i cant check leaderboards or players profiles, and even switching characters takes five minutes to load my hero list.
I'm getting constant error 1016 aswell.
Weird thing is yesterday afternoon I could play without any problem at all. Played for about 4 to 5 hours without any disconnecting. And today error 1016 is back again. Furthermore some friends seem to have no problem at all.

Can't seem to find any fix or workarround anywhere.
I've tried all the troubleshooting options posted by Silverfox, Misscheetah and Blizzard since March.
I'm clueless on what to do next?
I guess I'm not the only one experiencing this problem as of late.

I can get about an hour of consecutive game time before error 1016 kicks me out of my game and to the login screen.
Well, thats happening to me as well, but if I switch regions or account, then it works fine. But if I switch back to Europe, i login, and after 5 second i disconnect with an 1016 error.
08/01/2017 05:40 PMPosted by Omrakos
Bladeyama,

If you're only seeing issues when playing in high level rifts, it's something you should be posting in the Bug Report forum.

https://us.battle.net/forums/en/d3/5386229/

Tech Support can only help you with issues on your end, we don't have any input as to how the game is made or any bugs that may exist. For example, for troubleshooting purposes, and yes, I know it's a big hassle, could you relocate your PC to a friend's house perhaps who is using a different ISP than CenturyLink or just play on their PC with your account and see if it's any better or not. That information helps to determine where the problem is coming from. Or if you have the means, try using your phone as a mobile hotspot for the PC as a test that would be using a different connection.


I am having these same issues, code 1016, code 2, code 4, JSON Error token 2, 4, latencies that regularly breach 3.5K EVERY day, all hours of the day, weekdays, weekends, YES I HAVE brought my PC to a friend's house, even several states away. Same. I have uninstalled/reinstalled, flushed DNS, redone my entire network, had professionals check out my network. EVERYTHING on my end is perfect. You want PC specs?

AMD-FX 9590 8-core 64-bit 4.71GHz non-clocked
32GBs DDR3 RAM
Military grade ceramic/alloy capped ASUS mobo
Self contained watercooling
1000 WATT PSU with UPS
24TB HDD enclosure WITH full 24TB drive space raided for data protection
SSD for OS and games
Dual nVidia GeForce GTX 580 1.5GB
Dual 27" high def monitors plus 13" video tablet as a third monitor

Before the latest patch, I could run D III ROS alongside Skyrim on both monitors with both games' settings at their highest as well as watch youtube or Twitch streams WHILE I PLAYED. NO, it is not on my end, it is not my ISP. This is a terrible situation where devoted fans of a game get to sit and watch latency stay in the red or get to the very end of an awesome, personal best record GRIFT just to see it freeze up due to lag and lose that work. Like seeing your potential last piece of the build drop, but lag says no, you have to do it all over again for nothing and most likely won't see it again for a while.
I get code 1016 after about 25-30 min but always seems to be at end of bounty or gr just before I get stuff lol
I get code 1016 after about 25-30 min but always seems to be at end of bounty or gr just before I get stuff lol. Is there a fix. I have played for years on this computer nothing new on this end!
Getting code 1016 everytime I'm about to finish a rift or even if I'm just sitting in town. It's getting frustrating, just bought necro xpac last week and can't enjoy playing it cause of the crash. Checked my network and everything and I still get the crashes. Did not get the crash before the update. Please help!!
I found that my network card driver was out of date. I updated the driver and this fixed the problem.

Join the Conversation

Return to Forum