Error code 1016 during Greater Rift

Technical Support
I just started a greater Rift today at 7:00 AM, got about 10 minutes in and suddenly an error code pops up and signs me out of Diablo 3.
Howdy!

Error code 1016 is a general disconnection error code, it means the connection to the server has been disconnected.

I'd recommend the following to help troubleshoot this error:
- [url="battle.net/support/article/31851"]Power Cycle Network Devices [/url]
- [url="battle.net/support/article/82450"]Flush the DNS Settings. [/url]
- Swap to Google DNS.

Notes: If running IPv6, contact your Internet Service Provider(ISP) to change protocol to IPv4.
- We have also seen disabling Chroma (Razer Synapse) help resolve this issue. You can always attempt to update your Razer software if you use it first before testing disabling the software.

If the issue continues try running a WinMTR when the issue is at it's worst. Paste the results back here within code blocks.

Thank you!
Wondering if this has anything to do with the upcoming patch.

I'm getting the same problem suddenly both in Live and on the PTR server. First on live while in a bounty group and after that right after I tried to make a private game in the PTR.
09/13/2017 11:14 AMPosted by Zuvykree
Error code 1016 is a general disconnection error code, it means the connection to the server has been disconnected.
If it happened to both servers, it is likely something on your ISP or your connection. The servers run independent from one another for PTR vs Live. Could be a bad hop from one hub to another further down the connection to blizzard, neither yours, your ISP, or Blizzards fault at that point. Just a bad hop in your path.
when i kill GR chief - there is no time for picking up items or update stones and im getting message "There was an error. (Code 1006)"

its happening only in Greater Rifts.. i can play all day long and no problem.. until i start GR im geting 1006

i try "Swap to Google DNS." not working for me..

sugestions ?!
03/01/2018 04:34 AMPosted by Psihologs
sugestions ?!

This:
09/13/2017 11:14 AMPosted by Zuvykree
If the issue continues try running a [url="https://battle.net/support/article/000027780"]WinMTR [/url]when the issue is at it's worst. Paste the results back here within code blocks.

Thank you!
report nr 1
|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| 192.168.1.1 - 0 | 670 | 670 | 1 | 2 | 25 | 5 |

| 212.180.224.229 - 0 | 670 | 670 | 1 | 2 | 24 | 2 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

report nr 2
|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| 192.168.1.1 - 0 | 473 | 473 | 1 | 2 | 16 | 2 |

| 212.180.224.229 - 0 | 473 | 473 | 1 | 2 | 17 | 3 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
Hi Psisolog,
Please input IP address of D3 server for WinMTR test. They can be found in the support article https://us.battle.net/support/en/article/000027780
North America 24.105.30.129
Brazil (Americas) 54.94.196.47
Europe 185.60.112.157 or 185.60.112.158
Korea 182.162.135.1
Taiwan 210.242.235.6
Australia 103.4.115.248

Run the test while you are having connection issue. Refer to he article for full details.
Error 1016 happens EVERY TIME in any Rift to include set rifts at the end of the just before completion or immediately after defeating the guardian and the loot drops. It's like a cruel joke.. ALWAYS right when you 'win' and see all the rewards in front of you it takes it all away.

This is so consistent as to certainly be a Blizzard problem.
|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| 192.168.1.1 - 0 | 577 | 577 | 1 | 2 | 26 | 3 |

| 10.169.2.1 - 0 | 576 | 576 | 1 | 2 | 22 | 4 |

| 212.180.224.228 - 1 | 573 | 572 | 2 | 3 | 26 | 9 |

| sm-lim10g-ags00-xe-0-0-6.supermedia.pl - 0 | 576 | 576 | 2 | 3 | 24 | 6 |

| sm-lim-itr01-10ge-4-8.supermedia.pl - 0 | 576 | 576 | 1 | 10 | 226 | 4 |

| war-b3-link.telia.net - 0 | 576 | 576 | 1 | 3 | 70 | 10 |

| ffm-bb4-link.telia.net - 0 | 576 | 576 | 19 | 20 | 49 | 21 |

| ffm-b1-link.telia.net - 0 | 576 | 576 | 19 | 22 | 85 | 24 |

| blizzard-ic-316506-ffm-b1.c.telia.net - 0 | 576 | 576 | 18 | 20 | 45 | 23 |

| ae1-br01-eqfr5.blizzardonline.net - 0 | 576 | 576 | 19 | 50 | 1257 | 22 |

| No response from host - 100 | 116 | 0 | 0 | 0 | 0 | 0 |

| 185.60.112.157 - 0 | 576 | 576 | 24 | 25 | 36 | 27 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
Hi Psihologs,
| 212.180.224.228 - 1 | 573 | 572 | 2 | 3 | 26 | 9 |
At hop 3, there is 1 data packet lost. This should be at your end (between your pc and ISP gateway). If it is a single instance, it may not be an issue. Try reset your network equipments first. The procedures are here:
Power Cycling Your Network Devices: https://us.battle.net/support/en/article/31851
IP Release, Renew, and Flush DNS: https://us.battle.net/support/en/article/82450
Other procedures (including Advanced Troubleshooting section): https://us.battle.net/support/en/article/112206

| ae1-br01-eqfr5.blizzardonline.net - 0 | 576 | 576 | 19 | 50 | 1257 | 22 |
At this hop, the worse time 1257ms is a-bit high. But the average is fine. It may also be a single instance (or caused by the upper hop).
This hop is near server end. I suggest you to present the WinMTR output to the support of Europe server:
EU Technical Support forum: https://eu.battle.net/forums/en/d3/4436696/
EU support: https://eu.battle.net/support/en/help/product/diablo3/273/277/channels
I have also had this problem. I am ready to stop playing hardcore altogether. I don't mind losing a character to my mistakes or bad luck, but these disconnects are getting really old.

I do seem to be having a large loss percentage once I get to blizzard if I am reading this correctly.
|-----------------------------------------------------------------------|
|______________________________________WinMTR_statistics________________|
|_______________________Host______________-_%|Sent|Rec|Best|Avg|Wrst|Lst|
|--------------------------------------------|----|---|----|---|----|---|
|_____________________________192.168.0.1_-_8|__52|_48|___1|__8|__13|__7|
|____________________________10.131.144.1_-10|__50|_45|___7|__8|__17|__8|
|__________________________24.248.104.110_-_0|__67|_67|___7|__9|__21|__8|
|____________________________70.169.88.10_-_0|__67|_67|___7|_10|__22|__9|
|__________dalsbbrj02-ae3.0.rd.dl.cox.net_-14|__43|_37|__18|_21|__47|_19|
|____________________________70.191.61.14_-11|__47|_42|__18|_21|__33|_30|
|_______ae1-br01-eqda6.blizzardonline.net_-14|__43|_37|__18|_21|__39|_18|
|hu-0-0-0-0-pe02-swlv10.blizzardonline.net-60|__20|__8|__53|_63|_122|_56|
|______be3-pe01-swlv10.blizzardonline.net_-44|__25|_14|__50|_57|_120|_50|
|_et-0-0-13-br01-eqla1.blizzardonline.net_-60|__20|__8|__53|_78|_170|_63|
|_______be1-pe01-eqla1.blizzardonline.net_-58|__21|__9|__52|_61|_120|_52|
|_lax-eqla1-ia-bons-02.blizzardonline.net_-58|__21|__9|__53|_61|_119|_53|
|___________________________24.105.30.129_-_4|__63|_61|__51|_52|__60|_52|
|____________________________________________|____|___|____|___|____|___|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
sou far works for me.. thx..
Hi MDWilkins,

I have also had this problem. I am ready to stop playing hardcore altogether. I don't mind losing a character to my mistakes or bad luck, but these disconnects are getting really old.

I do seem to be having a large loss percentage once I get to blizzard if I am reading this correctly.
|-----------------------------------------------------------------------|
|______________________________________WinMTR_statistics________________|
|_______________________Host______________-_%|Sent|Rec|Best|Avg|Wrst|Lst|
|--------------------------------------------|----|---|----|---|----|---|
|_____________________________192.168.0.1_-_8|__52|_48|___1|__8|__13|__7|
|____________________________10.131.144.1_-10|__50|_45|___7|__8|__17|__8|

There are 8% data packet loss starting from the first hop onwards. The first hop usually your router. We expect 0 data loss here.

That means the problem is between your computer and your router.
Try steps (including Advanced Troubleshooting section) in this support article:
https://us.battle.net/support/en/article/112206

If you are using WIFI connection, try to use a LAN cable. Or, plug your computer directly to your modem, by passing the router. This is to proof that the issue is at wireless connection.
I will work with Cox to address the initial hop issues.
From the Blizzard perspective, I am concerned that I am having problems with all of these blizzardonline.net hops. I read elsewhere that these may have something to do with authentication or detection of bots. Is this true?
I am also concerned that none of these show up when I test against NYTimes.com. This is not a consistent result from my perspective. With the same computer, router, modem, isp, etc. I get great results from other sites

March 6 at 01:00 AM
|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------------|------|------|------|------|------|------|
| 192.168.0.1 - 0 | 63 | 63 | 1 | 9 | 15 | 8 |
| 10.131.144.1 - 0 | 63 | 63 | 7 | 9 | 19 | 9 |
| 24.248.104.110 - 9 | 48 | 44 | 8 | 11 | 22 | 13|
| 70.169.88.10 - 9 | 48 | 44 | 7 | 10 | 19 | 13|
| dalsbbrj02-ae3.0.rd.dl.cox.net - 25 | 32 | 24 | 18 | 21 | 30 | 27|
| 70.191.61.14 - 20 | 36 | 29 | 18 | 21 | 30 | 22|
| ae1-br01-eqda6.blizzardonline.net - 33| 28| 19| 18| 30| 148| 22|
|hu-0-0-0-0-pe02-swlv10.blizzardonline.net- 33| 28| 19| 51| 54 | 60| 54|
| be3-pe01-swlv10.blizzardonline.net - 42| 24| 14| 51 | 54| 65| 53|
| et-0-0-13-br01-eqla1.blizzardonline.net - 42| 24| 14| 53| 61| 122| 54|
| be1-pe01-eqla1.blizzardonline.net - 20 | 35 | 28 | 51 | 54 | 62 | 52|
| lax-eqla1-ia-bons-02.blizzardonline.net - 44| 23| 13 | 52 | 56 | 67 | 53|
| 24.105.30.129 - 0 | 63 | 63 | 51 | 53 | 61| 51|
|___________________________________________|____|_____|____|_____|____|____|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

NYTimes.com
|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 192.168.0.1 - 0 | 67 | 67 | 2 | 10 | 15 | 10 |
| 10.131.144.1 - 0 | 67 | 67 | 7 | 10 | 16 | 14 |
| 24.248.104.110 - 0 | 67 | 67 | 8 | 11 | 18 | 15 |
| 70.169.88.10 - 0 | 67 | 67 | 8 | 10 | 21 | 8 |
| dalsbbrj02-ae3.0.rd.dl.cox.net - 0 | 67 | 67 | 17 | 21 | 33 | 18 |
| 199.27.73.46 - 77 | 17 | 4 | 0 | 19 | 20 | 19 |
| 151.101.129.164 - 0 | 67 | 67 | 17 | 20 | 25 | 21 |
|___________________________________|_____|____| _____|____|____|_____|
WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
| 24.248.104.110 - 9 | 48 | 44 | 8 | 11 | 22 | 13|

On the first test, there was 9% packet lost. The IP belongs to Cox.

| 199.27.73.46 - 77 | 17 | 4 | 0 | 19 | 20 | 19 |
In NYTimes test, there was 77% packet lost here. The IP belongs to other ISP, likely ISP of NYTimes.

Like traffic jams, they don't happen all the time, or at the same place. Each connection may take different route. So, each test may vary. However the test can show issues at both ends and help narrow thing down.

To get more precise result, run the test for longer time, at least 10 minutes, when you are playing the game and experience laggy connection.
f.... i can play all day long in team any GR and absolutely no broblem.. maybe few seconds something gliching but all ok i continue playing.. as soon as i playing solo F..g done.. after killing boss im getting beautiful 1016 errrror.... IF its my network provider fault then how can i play in team and no problem..?! until i play alone -done.. i try everything what i can find about 1016 error.. and im more pist off then before.. and its realy network problem but not blizzard ?!?!?!?!?!?!? realy ?!?
03/16/2018 04:35 PMPosted by Psihologs
f.... i can play all day long in team any GR and absolutely no broblem.. maybe few seconds something gliching but all ok i continue playing.. as soon as i playing solo F..g done.. after killing boss im getting beautiful 1016 errrror.... IF its my network provider fault then how can i play in team and no problem..?! until i play alone -done.. i try everything what i can find about 1016 error.. and im more pist off then before.. and its realy network problem but not blizzard ?!?!?!?!?!?!? realy ?!?
Sometimes it really was at server side. In those cases, many posts flooded the forum. Blizzard usually could fix the problems within hours. There is no such incident recently. So, I'd say that it is unlikely a server side problem for your case.

You are playing on Europe server, you better seek help on EU technical support forum: https://eu.battle.net/forums/en/d3/4436696/
Periodically, error 1016 occurs in GR.From the beginning of the season watching the game lags and freezes.When tracing at 157 and 158, WinMTR issues...the all-clear.But when you trace on the ip of the server on which you played the creeps much more interesting picture.The latter 1016 was yesterday at 22: 50 GMT.

|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| LESHANIDZE - 0 | 875 | 875 | 0 | 0 | 0 | 0 |

| 100.96.20.1 - 0 | 878 | 878 | 0 | 1 | 72 | 2 |

| nkz98nat-te-0-1-0-3041.ll-nkz.zsttk.ru - 1 | 849 | 841 | 1 | 1 | 1 | 1 |

| nkz201br-be2-245.ll-nkz.zsttk.ru - 2 | 849 | 840 | 1 | 15 | 185 | 1 |

| brl0601.transtelecom.net - 2 | 837 | 823 | 6 | 7 | 60 | 8 |

| 80.249.210.177 - 2 | 832 | 819 | 94 | 95 | 132 | 95 |

| 80.249.208.83 - 1 | 852 | 844 | 94 | 94 | 97 | 95 |

| 37.244.10.35 - 2 | 835 | 824 | 93 | 93 | 95 | 94 |

| 37.244.10.103 - 5 | 761 | 730 | 94 | 95 | 98 | 95 |

| 185.60.114.153 - 14 | 585 | 508 | 97 | 97 | 99 | 98 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| LESHANIDZE - 0 | 586 | 586 | 0 | 0 | 0 | 0 |

| 100.96.20.1 - 0 | 586 | 586 | 0 | 0 | 29 | 0 |

| nkz98nat-te-0-1-0-3041.ll-nkz.zsttk.ru - 2 | 559 | 552 | 1 | 1 | 2 | 1 |

| nkz201br-be2-245.ll-nkz.zsttk.ru - 2 | 547 | 537 | 1 | 15 | 197 | 1 |

| brl0601.transtelecom.net - 2 | 555 | 547 | 6 | 7 | 89 | 7 |

| 80.249.210.177 - 2 | 563 | 557 | 99 | 101 | 194 | 99 |

| 80.249.208.83 - 96 | 122 | 5 | 99 | 99 | 99 | 99 |

| 37.244.10.33 - 74 | 150 | 40 | 103 | 103 | 104 | 104 |

| 37.244.10.101 - 2 | 551 | 542 | 102 | 102 | 105 | 102 |

| 185.60.114.167 - 74 | 150 | 40 | 102 | 102 | 103 | 103 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
|------------------------------------------------------------------------------------------|

| WinMTR statistics |

| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

| LESHANIDZE - 0 | 1145 | 1145 | 0 | 0 | 1 | 0 |

| 100.96.20.1 - 0 | 1145 | 1145 | 0 | 0 | 134 | 2 |

| nkz98nat-te-0-1-0-3041.ll-nkz.zsttk.ru - 1 | 1113 | 1105 | 0 | 1 | 2 | 1 |

| nkz201br-be2-245.ll-nkz.zsttk.ru - 2 | 1065 | 1045 | 1 | 13 | 182 | 2 |

| brl0601.transtelecom.net - 1 | 1109 | 1100 | 6 | 6 | 86 | 7 |

| 80.249.210.177 - 2 | 1081 | 1065 | 95 | 96 | 140 | 95 |

| 80.249.208.83 - 98 | 234 | 5 | 0 | 96 | 97 | 96 |

| 37.244.10.33 - 47 | 402 | 215 | 95 | 95 | 96 | 95 |

| 37.244.10.101 - 37 | 466 | 295 | 95 | 95 | 98 | 95 |

| 185.60.114.169 - 41 | 438 | 260 | 98 | 99 | 345 | 99 |

|________________________________________________|______|______|______|______|______|______|

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
My provider is already aware of his problems.Deal with your problems.
@Leshiy
| nkz98nat-te-0-1-0-3041.ll-nkz.zsttk.ru - 2 | 559 | 552 | 1 | 1 | 2 | 1 |
In all 3 logs, starting from hop 3, there are data packet loss.
I think you know who is zsttk.ru.

| 80.249.208.83 - 98 | 234 | 5 | 0 | 96 | 97 | 96 |

Also, this hop has serious data loss. 80.249.208.83 belongs to Amsterdam Internet Exchange B.V.

I suggest you to contact your ISP. Show them the WinMTR logs. They should be able to help you.

Join the Conversation

Return to Forum