Game still stuttering!!!

Technical Support
Would be nice to see a blue respond about this. Been going on for a while now. Changing to 32 bit doesn't work for me. All drivers are up to date. Getting really annoying to have the game freeze on you for a few seconds at a time every minute of game play. SEVERAL people are having the same issue, but yet it seems you continue to ignore it
Same here. The game was running perfectly and now it freezes every 30 seconds or so. Did the repair, checked for overheating, scanned for viruses, latest drivers installed, etc; in-game settings are irrelevant because the game had been running perfectly before the freezes started occurring. It's none of those.
It is somehow related to the connection to the servers. Because it also disconnects periodically, (error 1016) and it now takes three to four times longer for the game to launch. Or something is wrong with
My game is also stuttering, really badly. Every 20secs or so , even in town. Tried everything, seems the necromancer patch screwed things up.
Diablo III Performance Issues

-- Windows / system specs?
-- improve performance by setting windows to "adjust for best performance" (right click File Explorer / This PC / Advanced system settings)
-- install drivers posted on manufacturer or motherboard web support page (compare stability vs latest device driver available)
-- optimize windows for gaming & power users (online blogs and youtube)
-- disable settings/services and uninstall apps you don't need
-- set Blizzard App / Diablo 3 shortcuts compatibility mode "run as administrator"
-- test by switching between 64bit and 32bit Diablo 3, widowed full screen instead of full screen
-- test by using a "free to use" gaming booster like ASUS GPUTweak2
You keep posting the same copy paste but as most have said they have tried everything posted and it's still going on. It wasn't going on before the patch now it is. I as many others have said would just like someone to say oh hey yeah this is messed up we are gonna fix it rather than the same old have you tried unplugging it and plugging it back in that never fixes anything. Most if not all of these settings people have turn on anyway and probably have for a very long time. This is a new problem and no one seems to be saying anything other than a list of things everyone has done to no avail.
I've been having the same issues also, driving me insane.
Gtx 970
Also tried all of the suggestions it's very frustrating.
i can log in, but the second the town screen loads the game completely freezes up.
11/15/2017 10:28 AMPosted by KorbenDallas
tried everything posted and it's still going on

I rarely lag or stutter playing Diablo3 with an older system (i7 4790k, 8gb ram, m.2 ssd boot, MSI 7870, Win10 insiders build 17035, Mediacom cable internet). 64bit and windowed full screen. When I lag, usually others in game are too. Sometimes yes I get disconnected but that is rare. I don't usually lag before GR100 up to 4 elite packs grouped. There are posted suggestions in forums, reddit, on the web how to setup.

Optimize your windows. Some consider WIn7 better than Win10 for gaming. Microsoft admits there are Win10 issues with games. D3 video options vs Nvidia Control Panel settings and AMD Raedon Settings (Gaming). Tweak or don't tweak your system -- that is your choice.

Read more
Nvidia control panel best settings for gaming

1.Go to the Nvidia control panel and make sure that 'High performance' under energy power management is selected.
2.In your Nvidia control panel make sure that PhysX is running on your GPU. (this might was the problem for me!)

Found a performance fix for all nvidia users!
Hi Players. I found a massive performance boost for the game. I use a gtx 1080ti and i got stutters and frezzes.
I went to the nvidia control panel and change one setting.
choose the "NVIDIA Control Panel" -> "Manage 3d Settings" and then manually add Creativerse.exe to the list. Then set the Power management mode to "Maximum Performance".
Now i have zero stutters and over 100fps.

Possible Stutter Fix For Some Nvidia Users

Nvidia Control Panel
Look in your Nvidia Control Panel under Manage 3d Settings. Select "Program Settings" and go to CS:GO. In here, look for a setting called Shader Cache. What this does is it saves textures and shaders to your Hard Drive. Turn Shader Cache Off, Hit Apply, and Start up your game

AMD Raedon Settings
-Right click desktop - Radeon Settings -Games tab -Add csgo.exe to your Application Profile list, to do this (click add icon on right top corner, and find your exact game exe (steamapps/common/fallout4) -After you added csgo.exe to your list (Note that this is NOT global settings) -Click Counter-Strike:Global Offensive box in list -Now you will see alot of options box in this window -Click the one called "Shader Cache" -Click drop down list --> Switch to "ON" instead "AMD Optimized" Done, there's no save button, just simply go back to main page without closing entire window, and your changes will be saved automatically
i dont think this is a graphics issue, its a audio driver issue. found a fix changing /updating to a newer version of the fmodex.dll inside the d3 folder it fix mine but after exiting d3 updates and revert the original fmodex.dll causing stuttering again.

I hope blizzard will look into updating there fmodex.dll to a newer version T_T its frustrating.
I'm also having that issue.

I've been playing Diablo 3 since day 1, and RoS on the exact same machine since season 1, and I've never had that issue until now.

The last major update I did was install a SSD drive 6 months ago, game was running really fine until 2 days ago.

So yeah, it's a bit frustrating to see only copy/pastas about tweaking my system when my system was running it perfectly. The only change is the Diablo 3 updates, so it looks like something's screwed in those updates.
11/15/2017 07:47 PMPosted by Masquerouge
it's a bit frustrating to see only copy/pastas about tweaking

Diablo3 updates, windows updates, driver updates, yet D3 forum posters mostly just complain and don't post system / windows information. Which windows version / build are you running? Players report stuttering/FPS issues with quite a few games. Video driver release notes state fixed and known issues. You may need to revert to previous driver because latest is causing issues. Other tech support forums require or at least suggest to post your system / window specs. You get generalized support because no specifics. Help each other. Suggest what works and doesn't work for you.

If have Windows 10, I have under settings/gaming
-- game bar (record game clips, screenshots, broadcast OFF)
-- game DVR (record in background OFF and record audio when OFF)
-- game mode (nothing)
-- trueplay (trueplay OFF)
-- xbox networking (nothing)
11/15/2017 07:28 PMPosted by WLGORREZ
i dont think this is a graphics issue, its a audio driver issue. found a fix changing /updating to a newer version of the fmodex.dll inside the d3 folder it fix mine

What is your Diablo3 audio settings? I have D3 audio settings: lowest (16), default, stereo. Installed D3 64bit audio is fmodex64.dll 7/04/2017. Intalled Win10 Realtek (High Defintion Audio Device) driver 10.0.17035.1000 with driver date 11/03/2017.
Game stuttering Issue(all games)
If you have "upgraded" from windows 7 to windows 10, most of your issues are from there. Resolution: Do a clean install of windows 10. No upgrade, no reset, nothing else. A clean install of windows 10 that formats your current OS installation. Please back up all your data in the OS partition before doing this. After installation of windows 10, you will have to install your applications again

Q: Frame rates may drop on some DirectX 9 games at high fps (>120fps) after installing Windows 10 Fall Creators Update
1. From the Start Menu, right-click the affected app and select More > Open File Location. File Explorer will open to the app’s location.
2. In File Explorer, right-click the app and select Properties.
3. On the Compatibility tab, check the box to Disable fullscreen optimizations

NVIDIA Releases GeForce 388.31 WHQL Game Ready Drivers
Changes and Fixed Issues•
occurs in games when GPU monitoring tools are monitoring GPU power ("Power" monitoring enabled).[2016377]

388.13 is notorious for a bad stutter.

All games stuttering with FPS drops since Windows 10 Creators Update
Please, try also this: in your Windows registry try adding this Value under 1.HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers
2.(DWORD type) TdrDelay = 6
...and reboot.

Windows 10
1.Open Settings.
2.Click on System.
3.Click on Storage.
4.Turn OFF the Storage sense toggle switch.
Still no blue post, lets go Blizz! Show some support! This is an issue affecting more than just a few people. Lets get it fixed!
11/12/2017 02:56 AMPosted by Spencetron
Game stutters constantly. Using a 1080ti on all low/off settings still having stutter issues, latency is holding at 66. Never had this problem till season 12

11/16/2017 03:15 AMPosted by Spencetron
Still no blue post,

Contact Support (D3 Performance)

EDIT: Many have benefited from posted "copy paste" over past few years. Suggest to be more open minded. Question: why downvote a Blizzard CUSTOMER SERVICE link with either a Web Ticket, Callback, or LIve Chat ???
Well I found the fix to the problem... exit the game and go back to playing Grim Dawn!

Join the Conversation

Return to Forum